LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 09-20-2006, 05:43 PM   #1
ScoobySnacks
LQ Newbie
 
Registered: Jun 2006
Posts: 6

Rep: Reputation: 0
On booting Suse 10.1 KDE doesn't start - all I can get is the command line


Hi

I am a Linux newbie so please be gentle.

I have recently installed Suse 10.1 with KDE GUI and have got it to work adequately and spent a fair amount of time reconfiguring it. Unfortunately, since installing updates a week ago as recommended by that orange exclamation mark in the system try, I have been having problems. When I boot up Suse now I get the command line up prompting me to login, which I do but I am unclear what has happened to the desktop and how to restore it. I have tried logging in as root and using the "init" command to change runlevels and I have been able to access YAST with the command line but frankly I don't know what I should do to correct this issue and restore the more familiar KDE GUI desktop.

I would be grateful for any advice.

Thanks
 
Old 09-20-2006, 05:49 PM   #2
google01103
Member
 
Registered: May 2006
Distribution: Suse 10.2 x64
Posts: 247

Rep: Reputation: 31
from command line type "startx" and post results

it could be you upgraded your kernel and now must re-install your video drivers as the drivers are kernel specific
 
Old 09-21-2006, 05:18 PM   #3
ScoobySnacks
LQ Newbie
 
Registered: Jun 2006
Posts: 6

Original Poster
Rep: Reputation: 0
Many thanks google 01103 ... it worked

Most grateful, you were absolutely right I just needed to re-install the graphics driver.

Thanks again!
 
Old 10-27-2006, 12:21 PM   #4
Ion Flux
LQ Newbie
 
Registered: Oct 2006
Posts: 3

Rep: Reputation: 0
Hi. I'm having the same problem but reinstalling my graphics drivers from the command line doesn't seem to help.

Running startx from the command line results in this:

hostname: Unknown host
xauth: creating new authority file /home/ion_flux/.serverauth.3666


Fatal server error:
Could not create lock file in /tmp/.tX0-lock

giving up.
/usr/X11R6/bin/xinit: Connection refused (errno 111): unable to connect to X server
/usr/X11R6/bin/xinit: No such process (errno 3): Server error.



Any help is immensely appreciated!
 
Old 10-27-2006, 12:33 PM   #5
Ion Flux
LQ Newbie
 
Registered: Oct 2006
Posts: 3

Rep: Reputation: 0
After searching the web with the error message, I think I know what may have caused the problem.

I tried to mount my Windows partition using the YAST2 partition manager. I set the mount point to /tmp. If this is the problem, then:

A. How can I fix it, and ...

B. ... what's the correct way to be able to access files on the Windows partition without buggering my linux install?

Thanks again for any help!
 
Old 10-27-2006, 12:43 PM   #6
gkiagia
Member
 
Registered: Oct 2003
Location: Greece
Distribution: Debian sid
Posts: 248

Rep: Reputation: 30
Mount your windows partition on /windows
/tmp must not be used for mounting such filesystems.

To fix it, run yast from the command line and fix it in the same way that you messed it up. (You have to use the arrows and tab to navigate. Press enter to click)

To quick fix it and load X, try "umount /tmp" as root. You can then use the yast GUI.
 
Old 10-27-2006, 01:04 PM   #7
Ion Flux
LQ Newbie
 
Registered: Oct 2006
Posts: 3

Rep: Reputation: 0
Awesome. X server and KDE are back and running. I love you.

Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to start gnome or kde? command line? playa4002 Debian 18 11-06-2006 12:54 PM
start kde-panel from command line ankur_linuxfan Linux - General 3 02-09-2005 02:12 PM
when i start slackware i only have a command line, how do i get to kde Longinus Slackware 8 12-13-2003 10:23 AM
Change kde theme & wallpaper from command line or start scripts? JHuizingh Linux - Software 2 12-11-2003 06:44 PM
booting gnome from the command line... pdmackenzie Linux - Software 2 09-11-2003 06:42 PM


All times are GMT -5. The time now is 02:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration