LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Nvidia problem with Suse 9.2 on Dell Inspiron 8600 laptop (http://www.linuxquestions.org/questions/suse-novell-60/nvidia-problem-with-suse-9-2-on-dell-inspiron-8600-laptop-273583/)

c_anindya 01-04-2005 03:40 AM

Nvidia problem with Suse 9.2 on Dell Inspiron 8600 laptop
 
I have installed Suse 9.2 Pro in my new Dell Inspiron 8600.After installation I went on to install Nvidia driver since I have geforce Go5200 (32mb vram).After installation,I modified XF86Config to driver nvidia from nv.
Nothing else were required since there was no "Load dri" in module section.I have chosen lcd flat 1200x800@75Hz as no inspiron 8600 monitor model was not available under selection.But,after that I try to go X,and it says init 5 level has been reached but it stays in console and no X comes up.Where as if I modify it to nv again it loads up but obviously with no 3d acceleration.Am I missing some more configuration? when I modify nv to nvidia and run 3Ddiag the output shows everything is ok,but on trying to go to X it does not do anything,no error comes in console either.

I have tried 1.0-6629(latest) and 1.0-6111 both driver from Nvidia

will be great if I get some pointers.

solspin 01-06-2005 11:35 PM

Well, I just got 9.2 today and have been trying to install the Nvidia driver on my desktop and get the same thing. Here is a clip from my Xorg.0.log file.

EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Apparently you can use Yast to install the nvidia driver, and it worked on 9.1, but doesn't work for 9.2. What the fudge is up with that?

Jihan 01-08-2005 09:02 AM

Hah! The same old damn problem here as well... anyway...
 
Ei maha jhamela niye gato ak bachchor kato je forum khullen manushera, ami nijey oy probleme porhechchilam, jai hok-->

First of all go for,
Code:

nano /etc/X11/xorg.conf
(or whatever is there in your machine)

Then check out what driver is installed (Did you configure your xorg.conf after installing?).
If driver is "nvidia", then it's alright and nothing is needed to be changed, and if not change it to "nvidia"

Then CTRL + X to get out of that and enter:
Code:

sax2 -m 0=nvidia
The "0" is digit, remember.
Now, log on and reboot to test everything!

:jawa: says :D Enjoy!!!

Caeda 01-08-2005 08:55 PM

c_anindya
You should be following the instructions it gives you in the nvidia readme and with suse, and using "telinit 3" to switch to runlevel 3 and then running sax2 and properply picking and configuring the driver and screen resolutions.

solspin
YOU works just fine for installing the updates, as long as you pay attention to the fact that there are kernel updates in YOU as well and don't do them after or while installing the nvidia driver. You have to re-install the driver after apparatly ignoring the warning YOU has against installing the kernel update if you are using/installing the nvidia driver.


All times are GMT -5. The time now is 05:13 AM.