LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 10-21-2007, 03:18 PM   #1
riccisit
Member
 
Registered: Jun 2004
Posts: 59

Rep: Reputation: 15
no sound: how to update the kernel or alsa in opensuse 10.2?


Hi

for some reason headphones and microphone won't work on my hp dv6000: I'm using Opensuse 10.2 (sound card mcp51 High Definition). Although Yast sees the sound card, I get sound just from the speakers. In this way Skype is not usable, for example.

I read every forum that exists, no one has a real solution. But I know that OpenSuse 10.3 supports this sound card perfectly (I tried that, but then I could not stay with it due to wlan drivers). It is a question of kernel, I know. The newest alsa will suport the sound card as well.

Now, it seems I have three options:

1) burn a opensuse 10.3 dvd and start with an update;
2) install alsa (but how can I uninstall the version I have installed?)
3) update the kernel.

Which is the best solution? And in case, how can I update a kernel or alsa? I tried to download rpm's for opensuse 10.2 of both of them but yast prevents me to install them because there are a lot conflicts. Especially I noticed that the kernel won't install because of ndiswrapper that I'm using.

Any help? I feel very frustrated;(

Thanks!
Fabio
 
Old 10-21-2007, 04:26 PM   #2
DiBosco
Member
 
Registered: Nov 2001
Location: Manchester, UK
Distribution: Mandriva, Mandriva, Mandriva. (Three different releases depending on the computer)
Posts: 710

Rep: Reputation: 35
It's odd that the speakers work, but headphones and mic don't. Could it be something as simple as the mic gain and the headphone gain not being turned up? Can you run kmix or alsamix and see whether the gains are up?

I have an Intel HD installation on my laptop (not Suse) and once I got the speakers going, the mic worked too...
 
Old 10-22-2007, 03:37 AM   #3
riccisit
Member
 
Registered: Jun 2004
Posts: 59

Original Poster
Rep: Reputation: 15
Hi DiBosco

thanks for your kind reply!

If I run kmix, it shows OUTPUT, INPUT and SWITCHES. In the output I have Master, PCM, Digital. In Input I have DIGITAL and CAPTURE. In Switches, Line and Mic

Everything is ok, still can't find the way to hear sounds with my headphones. If I insert them, speakers don't turn off, the headphones are simply ignored.

Any idea?

Thanks
Fabio
 
Old 10-22-2007, 09:06 PM   #4
Wal_t2000
LQ Newbie
 
Registered: Feb 2005
Posts: 5

Rep: Reputation: 0
The workaround below worked for me in Suse 10.2 with an ASUS A6000VM:
---------------------------------------------------
This is only needed in Ubuntu Breezy on this Asus notebook. With Dapper all hardwares works (almost) perfectly. Only the SPDIF OUT must be configured for listen music on headphones. For do this U need to insert this line at the bottom of file /etc/modprobe.d/alsa-base, and then make a restart

options snd-hda-intel model=z71v position_fix=1
 
Old 03-25-2008, 08:18 AM   #5
stalonge
LQ Newbie
 
Registered: Mar 2008
Posts: 1

Rep: Reputation: 0
Talking @ WAL T2000 Great Tips

Quote:
Originally Posted by Wal_t2000 View Post
The workaround below worked for me in Suse 10.2 with an ASUS A6000VM:
---------------------------------------------------
This is only needed in Ubuntu Breezy on this Asus notebook. With Dapper all hardwares works (almost) perfectly. Only the SPDIF OUT must be configured for listen music on headphones. For do this U need to insert this line at the bottom of file /etc/modprobe.d/alsa-base, and then make a restart

options snd-hda-intel model=z71v position_fix=1
UBUNTU 7.10

Man , after days trying to put the headphones to work with my ASUS A6000VM , your tip were great ... my earjack is working fine .. now i can talk in skype with private ..

Thanks a lot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing alsa on opensuse 10.2 with intel sound card kamransoomro84 Linux - Laptop and Netbook 6 05-02-2007 11:51 AM
ALSA Sound Problem In OpenSuSe tehkaao Linux - Hardware 3 04-15-2007 04:42 PM
No sound after update packages....(including update alsa) Mathsniper Debian 8 11-22-2006 04:43 AM
snd_8x0/alsa Trouble after update from SuSE 9.3 to OpenSuSE 10.1 acernotebook Linux - Software 1 06-02-2006 10:48 AM
Kernel, GLIBC update, no Alsa! But I can get sound. swinchen Slackware 3 10-28-2004 01:52 AM


All times are GMT -5. The time now is 09:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration