LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   No root device found, exiting to /bin/sh sles9 (after mkinitrd) (http://www.linuxquestions.org/questions/suse-novell-60/no-root-device-found-exiting-to-bin-sh-sles9-after-mkinitrd-740561/)

knockout_artist 07-16-2009 11:32 AM

No root device found, exiting to /bin/sh sles9 (after mkinitrd)
 
Hi,

I was trying to add a driver/modules(qla2xxx). I used mkinitrd.
After that server wont boot.

1-It prints "No root device found, exiting to /bin/sh" error message.
2-I have root FS on vg(lvm) setup.
3-I have booted server with Opensuse-11 live cd.

Now where should I look to fix this issue.

Thanks.

jschiwal 07-17-2009 05:25 AM

Did you add qla2xxx in a line in /etc/sysconfig/kernel and then run mkinitrd?

INITRD_MODULES=""

Or alternately run the YaST2 -> System -> /etc/sysconfig Editor, and add to the System -> Kernel -> Initrd Modules dialog?


See if the lvm volume is still OK. I doubt the problem is in the lvm volume itself.

Do you have a separate /boot partition that contains the initrd file, and do you have the old one in a backup.
If /boot/grub is on a separate partition, look at your menu.lst file. Do you have the vg device nodes? If not, look at the "vgmknodes" program to create them.

If the lvm volume is OK, and you can mount them manually, my guess is that adding the qla2xxx driver, causes a new disk device to be added when you boot. The line in /boot/grub/menu.lst for the root device is now wrong. E.G. was "root (hd0,1)" but now should be "(hd1,1)".
---
If you can create the LVM nodes, mount the volumes manually (under /mnt/) and then "chroot" to the old system, you can start running your system, fix menu.lst and maybe the /etc/fstab file, run grub-install and reboot.

Another option is to restore your old initrd file from a backup. ( Or if you have an older kernel/initrd entry in the grub menu, select it when you boot. )

Another option is to re-install grub from the grub shell after editing any changes needed in menu.lst and /etc/fstab.


All times are GMT -5. The time now is 12:36 AM.