LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 09-21-2006, 02:52 AM   #1
galrub
Member
 
Registered: Sep 2006
Posts: 41

Rep: Reputation: 15
newbie with two small problems


Hi all...
Name is Gal an I'm NEWBIe... last time I saw linux was 13 years ago, it changed a lot!

I installed SuSE linux 10.1 on my PC and got two problems:

1) when I open any of the browsers, I can't see google. I can go on Novell's site, but, most sites seem blocked (unavilable). what can I do to have a normal access to all sites (it's so bad, I have to use the XP to post this).

I have an external ADSL LAN modem/router, but I don't think it's a problem with him couse when I star winXP
I dont have any restriction.

2) I have two HD's. on hda I have winXP/sp2 and on hdb have the linux. I cant access the XP (NTFS) drivers from linux. int the initial startup I can catch a glimps that the mounting process fails beacouse "dev/hda1 not exist" or something like that.

thanks a lot,
Gal
p.s. I posted on the newbie forum and got nothing maybe this time...
 
Old 09-21-2006, 02:58 AM   #2
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
Post is in the SUSE Part of the Forum...
but never the less. What if you search with google can you open every site you find?
Check the SUSE Firewall if all HTTP and HTTPS is allowed.
 
Old 09-21-2006, 04:42 AM   #3
galrub
Member
 
Registered: Sep 2006
Posts: 41

Original Poster
Rep: Reputation: 15
cant even do a search

thanks odcheck,

I cant get to that point of actualy getting search result. and anyhow, most sites are blocked.

how do I Check the SUSE Firewall if all HTTP and HTTPS are allowed?

thanks in advance,

p.s.: Iron Maiden is a great band, love there bass player.
 
Old 09-21-2006, 05:40 AM   #4
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
Oh the last Sig. I've got was - We shall never surrender which I thought fits great to Linux...

By the way use YAST to configure it check allowed services. And make your device a trusted one.

But as 1st I would recommend to shutdown the firewall completely to see if we really have got an issue with it. to test.

let me know
 
Old 09-21-2006, 06:05 AM   #5
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Not sure about suse, but on fedora you need a specific kernel module to read ntfs. A while since I set this up, but I'm sure a quick search of the archives along the lines of "mount ntfs" will get you oodles of hits (oodles is a very technical word if you haven't come across it much)
 
Old 09-21-2006, 12:06 PM   #6
galrub
Member
 
Registered: Sep 2006
Posts: 41

Original Poster
Rep: Reputation: 15
well...

hi friends,

well, the bad news is that I loged on as root and could see Any web pages, but, it seems that the processes stop within the system, the requests are blocked by linux and dont even get to the modem/net.

I open YaST, looked at the netwok services and couldn't see nothing indicating HTTP, there was ftp.. and pop3, but the 'HTTP' word does not appear there. hope that helps.

P.S. still looking in that mount problem. when I 'ls' the 'etc' sub I can see 'hda' but not 'hda1' or any other (hda is where the winXP is).
 
Old 09-21-2006, 03:53 PM   #7
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,537

Rep: Reputation: 149Reputation: 149
As it's more a technical question than an introduction, the thread is moved to SuSE/Novell subforum.
 
Old 09-22-2006, 01:27 AM   #8
galrub
Member
 
Registered: Sep 2006
Posts: 41

Original Poster
Rep: Reputation: 15
Thanx Mara

ok... we're moving
 
Old 09-22-2006, 01:33 AM   #9
galrub
Member
 
Registered: Sep 2006
Posts: 41

Original Poster
Rep: Reputation: 15
Mount problem solved... the net problem.... not yet

thanks for all the help. let's go on with the internet access problem.
 
Old 09-22-2006, 08:33 AM   #10
galrub
Member
 
Registered: Sep 2006
Posts: 41

Original Poster
Rep: Reputation: 15
nothing yet... got this

hi all,

as far as the mount, everything is fine, thanx...

I tried curl and got this:

linux-zsnc:~ # curl -v www.google.com
* getaddrinfo(3) failed for www.google.com:80
* Couldn't resolve host 'www.google.com'
* Closing connection #0
curl: (6) Couldn't resolve host 'www.google.com'

1)you guy said "disable Firewall" and "ping", how do I do it?

2) DHCP? the router has DHCP, how do I sync between the linux and the router?

2) firefox plug-ins install? dont know if there are. how do I check and install?

guy's, let's face it, in most cases, the SuSE archive is really BAD.

thanks
 
Old 09-25-2006, 07:23 AM   #11
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
If you're in yast it will not so hard to find the firewall.
Check all Items in KDE you'll find the firewall.
next if you have a router like you said that includes a dhcp.
Then you're network card will get a dhcp lease. Cause If you didn't changed anything during the setup the default value is dhcp on.
So open a terminal.
enter
Code:
su -
then verify your root password.
How said use curl -v ??!?!
in that terminal after you've gained root access.
Code:
ping www.google.com
it will probably end with the same result.
so next
Code:
ifconfig
if the only device you see there is lo or sit0 then check your network card config using YAST.
Check if your card starts when the system starts at boot time and that dhcp is enabled.
Next
Code:
cat /etc/resolve.conf
if you see an entry called nameserver=ip address then we have to check some more if not. you will have to edit the DNS Server entry with YAST or use vi to edit the resolve.conf
Mostly it's like this.
IF YOUR ROUTER HAS GOT THE 192.168.2.1 then DNS = 192.168.2.1 for the clients and also the Gateway address. The Problem is in the most cases that even if dhcp is running on the router only an IP within the range is delivered to teh client including the gateway address but the DNS address isn't. So you'll have to edit the file /etc/resolve.conf so that there is a nameserver entry with the IP of your router. e.g. nameserver 192.168.2.1
Thats it.
 
Old 09-25-2006, 07:32 AM   #12
galrub
Member
 
Registered: Sep 2006
Posts: 41

Original Poster
Rep: Reputation: 15
the problem with the DNS was solved, the problem is really withing firefox, because the konqueror works perfectly.
 
Old 09-25-2006, 08:50 AM   #13
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
I've seen it you double posted!!!!
slap youself :-)
But I am glad that it's solved so far.
But firefox still doesn't work.
Check if you maybe have proxy enabled in firefox which is of course a mistake in your current internet configuration. In Firefox there is a option tab for connection.
See if Proxy is enabled there, it should be set to direct connection.
 
  


Reply

Tags
access, mount, suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie to Damn Small Linux 357mag DamnSmallLinux 9 01-12-2006 02:36 PM
newbie help on small shell script ripcurl Programming 5 09-20-2005 03:17 PM
Small super-newbie problem Plice Slackware 10 10-11-2004 02:29 PM
Small Linux for newbie to start with? dive Linux - Newbie 8 08-19-2003 07:13 AM


All times are GMT -5. The time now is 07:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration