LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 02-17-2007, 04:21 PM   #1
oldmartian
Member
 
Registered: Feb 2007
Location: Akron, Ohio
Distribution: Kubuntu
Posts: 31

Rep: Reputation: 15
Thumbs down New to Linux - Trying SUSE - Not good at all.


I've run a zillion Live CD's and on my laptop I've installed a few distributions just to see what they would look like.

At the recommendation of a few people I was pointed to SUSE. For my Desktop. I just installed 10.1 and got it working right away, except it configured my CRT monitor with my LCD screen parameters. In looking this site over I saw everyone has ATI problems with SUSE. Well, trying to get my two monitors to run "dual head" I fiddled with ATI drivers and followed what looked promising and got the 2 monitors working in SUSE but in tandem instead of independently.

But I had to boot back into Windows for something and when I rebooted, the graphical interface didn't load. Just the black terminal mode.

No amount of re-installing, repair or boot options get me back to the GUI.

I'm thinking of just scrapping SUSE because of this and they way it partitioned my primary hard drive and won't give me permission to use either my secondary HD or my SATA drive or my CD/DVD drive. I haven't got to those problems yet because I don't have my GUI!

That's long-winded I know, but that's why I'm here. I don't need dual head function right now: I just need one monitor showinf my some graphics!

Last edited by oldmartian; 02-17-2007 at 04:23 PM. Reason: Bad tags
 
Old 02-17-2007, 08:55 PM   #2
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 58
can you run 'startx' or 'startkde' at the command window?
 
Old 02-18-2007, 09:49 AM   #3
oldmartian
Member
 
Registered: Feb 2007
Location: Akron, Ohio
Distribution: Kubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
You sound like an expert to me: an answer without explanation! (Kidding)

What exactly will starx or starkde do?

I came across a person who got my GUI back. We used vi and edited the devices section of the xorg.conf file and removed the driver fglrx (something like that) and replaced it with vesa.

I'm up and running again but still without dual head. Searching the Net I find that ATI didn't write a driver for the Radeon 7500 card and that open source ATI drivers for something that old aren't really availabe or "might" work.

For the time I'm putting into this I would do better to run out and buy a cheaper newer (not newest) NV card. Too negative stuff on ATI.

While I'm experimenting I might revert the xorg.conf file and see what starx will do. So I would still like your input on what starx does.

Thans,
Oldmartian
 
Old 02-18-2007, 09:59 AM   #4
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 58
what will startx do? it 'starts' 'x'. 'x' is shortform for the X-Windows windowing system in your machine.
what will startkde do? it 'starts' 'kde'. 'kde' is i believe the graphical environment in SuSE.

a while ago i had an ATi card and the driver worked fine. i never tried any advanced stuff that your doing, with dual monitors. i now have an NVidia card and it works just as well as the ATi (driver-wise). again, im doing any advanced stuff with it, so cant help you on the duals.
 
Old 02-18-2007, 10:38 AM   #5
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Moved: This thread is more suitable in Suse/Novell and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 02-18-2007, 03:05 PM   #6
swerdna
Member
 
Registered: Jun 2006
Location: Oz
Distribution: openSUSE 10.x
Posts: 80

Rep: Reputation: 15
Another answer with no explanation
 
Old 02-21-2007, 10:21 PM   #7
sonic
Member
 
Registered: Jan 2002
Location: PA
Distribution: Suse 11.1, Mepis
Posts: 58

Rep: Reputation: 16
Quote:
Originally Posted by oldmartian

At the recommendation of a few people I was pointed to SUSE. For my Desktop. I just installed 10.1 and got it working right away, except it configured my CRT monitor with my LCD screen parameters. In looking this site over I saw everyone has ATI problems with SUSE. Well, trying to get my two monitors to run "dual head" I fiddled with ATI drivers and followed what looked promising and got the 2 monitors working in SUSE but in tandem instead of independently.
I have to run Suse 10.0 for my ati 8500aiw in order to get it to work. In 10.0 I have 3d graphics and everything right out of the box. Once I go to 10.1 or 10.2 everything is a disaster in terms of the GUI. I believe that this is a problem with the xorg version and the radeon/ati driver support.

On another computer I had a radeon 7500 and swapped it out with a Nvidia card and all the graphics problems disappeared. I am able to run Suse 10.2 with Beryl, 3d and all that good stuff. Funny thing about the Nvidia is that it will occasionally hang when booting WinXP.

Don't be discouraged by the experience. The linux desktop experience has dramatically improved over the last couple of years. It is kind of tough when it knocks out the GUI and using the command line slows down the repair process for most users.
 
Old 02-22-2007, 02:58 AM   #8
vmelkon
Member
 
Registered: Feb 2007
Location: Canada
Posts: 99

Rep: Reputation: 15
You had 3D graphics with 10.0 when you installed?
I have a 9700 and I didn't.
Someone gave me some info on how to install it.

I'm wondering if 10.2 is worth it
My 10.0 is fucked up and I having trouble with installing the drivers now.
 
Old 02-22-2007, 07:25 AM   #9
sonic
Member
 
Registered: Jan 2002
Location: PA
Distribution: Suse 11.1, Mepis
Posts: 58

Rep: Reputation: 16
The 3d is with the standard radeon driver. All I had to do was check enable 3d during installation. It works so good I didn't even bother with the ati driver.
 
Old 02-22-2007, 09:18 AM   #10
garthkh
LQ Newbie
 
Registered: Feb 2007
Posts: 13

Rep: Reputation: 0
Just loking at Oldmartian's GUI problems. Maybe I can thow my 2 bits in. I'm no guru yet at Suse but I went through lots of pain trying to get out of GUI problems until I bought myself the Suse 10.0 Bible and guess what ... There it was.
In terminal mode (use ALT/CTRL F1 if not there already).
Type in
init 3
when thats gone through type
sax2
and it will open up the sax screens to setup your screans and cards etc.
For me it's the easiest way out.
I used the go through using the midnight commander editor (mc off the command prompt) and edit the config file with numbers that were copied from elsewhere.!!!
Hope this helps
Garth
 
Old 02-22-2007, 11:31 AM   #11
LuisC-SM
LQ Newbie
 
Registered: Mar 2006
Location: Mexico
Distribution: Xandros, Linspire, Ubuntu, SLED 10
Posts: 29

Rep: Reputation: 15
or ... install SLED 10 and forget about those problems (ATI nVidia).

SLED 10 automatically recognizes the 2nd monitor and it configures it (as per my own experience). Once you have signed up, you are asked to add ATI and nVidia repos and after installing either one of them, you just enable the 3D graphics and you are in busines without any kind knowledge.

Regards.

Luis C. Suárez
 
Old 02-23-2007, 09:30 AM   #12
oldmartian
Member
 
Registered: Feb 2007
Location: Akron, Ohio
Distribution: Kubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
I gave it up

Thanks for all the ideas, friends.

I lost control of my 'puter for a few days (grub vs. me) I won. Actually I lost when I used grub th remove two "unallocated" partitions that SUSE thought I might need. Then I decided to delete the 4 linux partitions. When I rebooted grub gave me a terse Error 22 message.

Well, I found the SuperGUB disk and fixed the drive (mbr)

So, for now I'm Linux-free.

Here's where SUSE failed me:
Only saw one printer
Upgrade tp 10.2 took out CUPS and wiuldn't give or let be config either printer
Saw wrong monitor as prime
Saw but didn't let me have access to 120 GB NTFS ATA drive
Saw but didn't let me have access to 300 GB NTFS SATA drive
Saw but didn't let me have access to CD-ROM

In playing with other distros on my laptop in the fall, most of them saw and let me use all my resources. All Live CD's I ran on my desktop saw and let me access all drives and hardware.

I'm going to put Kubunu 6.10 on the desktop. With SuperGrub disk I'm not too worried about loosing my Windows partition. My wife would shoot me dead if I lost her stuff (which I NOW have backed up on the SATA drive).

Thanks for all the help and continuing messages. Perhapd there will be a Forum on "newbie to Kubuntu." I hope not!

BTW, look for tags on "unallocated" and see that part of my troubles. SUSE was gone by them.
 
Old 02-23-2007, 10:55 AM   #13
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 58
did you try and access the drives as root or as your regular user?

if you can access it as root then your entry for the device in /etc/fstab just needs to be modified, let us know.
 
Old 02-23-2007, 04:02 PM   #14
oldmartian
Member
 
Registered: Feb 2007
Location: Akron, Ohio
Distribution: Kubuntu
Posts: 31

Original Poster
Rep: Reputation: 15
I was in root at all times necessary. My ATI card is a Radeon 7500; quite old by computer technology standards. It was well published on the web (if one looks hard enough) that ATI didn't write drivers for that card and the open source drivers are not suitable for that card.


I'll try the recommendation of SLED but I don't hold much hope. I'll have Kubuntu up in a few hours so I'll see if that makes any difference.

Yes I used sax2 and fstab (forgetting now whay they were meant for) and I used aticonfig. Aticonfig kicked in the graphics card because to screen became lightning fast. The other two proggies kicked in a line on the ATI configuration screen asking if I wanted to run 2 monitors. Clicking the box and then going in to configure the monitors still only showed 1 monitor. The option to stretch the viewing area over two screens worked. But that's not what I wanted. I messed with the prorgams and parameters enought to gain the knowledge that they just weren't going to get the dual monitor funtion working.

For the time I've spent on it, it is now worth it just to buy a dual monitor NVidia card, so that's my charted course right now.

I'm too lazy to re-read this message for errors. I broke my wrist and my left hand is in a cast, so I'm typing with a variety of digits... The cast comes off next week, thank you.
 
  


Reply

Tags
ati, dual monitor, gui, radeon, suse


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What's a good printer that works good with linux? badmofo666 Linux - Hardware 7 02-23-2006 10:10 AM
Any good strategy games for SUSE linux? izquierdista Linux - Games 8 05-27-2005 06:15 PM
What is a really good way to Learn Linux? What about a Really Good Linux magazine? Howerton Linux - Newbie 9 09-02-2004 04:59 AM
SuSE 8.2 any good? jtsai256 Debian 3 09-28-2003 10:12 AM
Suse 6.2 good??? wiredX Linux - General 2 08-01-2003 12:58 PM


All times are GMT -5. The time now is 06:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration