LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 10-27-2004, 03:15 PM   #1
JTC
LQ Newbie
 
Registered: Oct 2004
Posts: 3

Rep: Reputation: 0
ndiswrapper installed wlan0 not present


I am running SuSE 9.1 Personal from a downloaded ISO.

I can not get wlan0 to be present and active even though all the client software and network card drivers are installed.

I am using a Linksys WMP54G v2 (rev. 3 according to lspci) PCI card.

lspci shows the card as present and identifies it as having an IRQ assigned to it.

I have installed the following RPMs:
GCC
Glibc-devel
Make

I have compiled and installed "ndiswrapper-0.11" from Sourceforge (which incidentally compiled with usb errors under this version of SuSE - commenting out the appropriate usb lines in the appropriate Makefile resulted in an error free install of the ndiswrapper).

I can, and have, loaded the bcmwl5.inf file, and have loaded the ndiswrapper module, and both show up as present and loaded.

eth0 was set to "disable" in Yast, and ifconfig does not show it as present.

doing an "ifconfig wlan0 up" responds with "Interface wlan0 is not present"

Upon booting the system I can see the ndiswrapper gets loaded, and then see the process count down trying to activate and setup the wlan0 interface, but finally it fails.

The Yast network device installation screen shows the interface as a "configured" bulleted item in the bottom section of the split screen, but not as "available" in the top section as it does with my built in ethernet NIC.

So, how does one get wlan0 to exist and be present in SuSE 9.1 Personal?

Thanks
 
Old 10-27-2004, 03:19 PM   #2
electronique
Member
 
Registered: Mar 2004
Location: Menomonie, WI
Distribution: SuSE 9.2, Slackware Current, Arch Linux 0.7
Posts: 119

Rep: Reputation: 15
did you load the module first? i.e. 'modprobe ndiswrapper' and then try and see if wlan0 is up
 
Old 10-27-2004, 05:27 PM   #3
JTC
LQ Newbie
 
Registered: Oct 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Yes I did load the module first and then did an "ifconfig wlan0 up" after. I am trying to use ndiswrapper-0.11 instead of the version .6 RPM that comes with SuSE because in the end I need to use WPA AES-CCMP as the encryption method.

Is there supposed to be a module called 'WLAN' that loads at boot time in addition to the ndiswrapper? If so, what init file should call for this to load?

I would post some log files but until this is done I can't get Linux connected to the net, and I have Windows 2000 ntfs with SP4 so the ntfs partition (separate drive) is mounted read only which means I can't pull any text files saved in SuSE over into windows.

Steps were:

1) "ifconfig eth0 down"
2) ifconfig to make sure eth0 was not up - it no longer shows (neither does wlan0 at this point)
3) "ndiswrapper -i [driver location]" to load bcmwl5.inf driver into ndiswrapper
4) "ndiswrapper -l" to make sure driver was loaded - yes it is present
5) "modprobe ndiswrapper" to load ndiswrapper
6) "lsmod" to see if ndiswrapper was loaded - yes it is present in the list
7) "ifconfig wlan0 up" returns "Interface wlan0 is not present"

8) Enter into Yast and physically disable eth0 so it remains disabled at boot
9) Set up wireless device so that "ndiswrapper" is in the module section and "- i [driver location]" is in the parameters section (so that it calls the ndiswrapper at boot time)
10) set an ESSID in Yast and (router has no encryption at this point)
11) "ifconfig" to see if ESSID makes a difference - no wlan0 present
12) manually check the config file to make sure ESSID was recorded - it was
13) reboot linux
14) F2 to watch boot sequence processes
15) see ndiswrapper get loaded as processes start
16) see wlan0 attempt to be activated and fail
17) when system is up "ifconfig" to see if wlan0 is present - no it is not
18) "ifconfig wlan0 up" same error message as before
19) "ifup wlan0" responds that it is not present

Thanks
 
Old 10-27-2004, 05:45 PM   #4
JTC
LQ Newbie
 
Registered: Oct 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Well after a power down and reboot everything is up and running (ain't it always the case that cold boots are better) so a big thank you to all the folks who had detailed instructions on installing the ndiswrapper.

For other SuSE 9.1 Personal folks, make sure you visit SuSE ftp site and download the following RPMS before you try to install ndiswrapper:
GCC
Glibc-devel
Make

Drivers:
Copy **both** the bcmwl5.inf and .sys files from the vendor's CD-ROM to a directory on the SuSE partition


Now to get AES-CCMP going with the additional WPA supplicant.
 
Old 11-24-2004, 03:48 PM   #5
geostone
LQ Newbie
 
Registered: May 2004
Location: Washington, DC metro area
Distribution: openSUSE 10.3
Posts: 19

Rep: Reputation: 0
Hi! I just want to thank you for your detailed information on how to get Suse to set up the wlan0 interface! I have been trying to get a wireless lan card working for months. I tried ndiswrapper today, but encountered the same interface error you cited in your post. Well, after following your steps, including the cold boot, voila! I am using a Belkin F5D6001 version 2 wlan pci card that uses the ADM8211 chip.

Thanks!
 
Old 11-24-2004, 08:23 PM   #6
Steerpike
LQ Newbie
 
Registered: Nov 2004
Location: Walnut Creek, CA
Posts: 29

Rep: Reputation: 15
In my case, I got my integrated broadcom chip to work in roughly the same way as you (ndiswrapper, etc) under suse 9.2 pro, but, it always starts up on 'first access', not on boot. I always see the failure message during boot up for wlan0. But all I have to do is issue 'ifconfig wlan0 up' and everything is fine. Is yours now starting up fine during boot?

BTW - you say you have a 'WMP54G' card from linksys ... but you are loading the broadcom driver. I'm surprised to see that linksys are using broadcom chipsets! Obviously, it's working so it must be true!
 
Old 12-18-2004, 03:22 PM   #7
d3viant
Member
 
Registered: Jun 2004
Distribution: SUSE 10.0, Fedora Core 4
Posts: 72

Rep: Reputation: 15
Dependent on your distro, you can tell the kernel to load modules on startup. Your problem here is that ndiswrapper isnt loaded when linux tries to look for a network card, which cant be found without ndiswrapper. I'm not sure exactly what it is for suse, but for mandrake you can add "ndiswrapper" to /etc/modules to get it to load on startup before it looks for a network. This will allow linux to then setup the card on its own.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ndiswrapper installed driver installed, hardware present, but modprobe doesn't likeit Flukey Linux - Hardware 1 04-14-2007 11:22 AM
Wireless network problems, ndiswrapper installed will not create wlan0 jackuss_169 Linux - Wireless Networking 6 08-14-2006 11:29 AM
ndiswrapper driver and hardware present but no wlan0 OneSeventeen Linux - Laptop and Netbook 5 07-28-2005 11:03 AM
No wlan0 present after modprobe ndiswrapper jmarcum Linux - Wireless Networking 3 06-01-2004 09:49 AM
ndiswrapper: wlan0 not present Ian Linux - Wireless Networking 1 04-07-2004 06:24 PM


All times are GMT -5. The time now is 02:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration