LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 05-04-2007, 11:02 PM   #1
jerrylu
LQ Newbie
 
Registered: Feb 2007
Location: Australia
Distribution: SLED and opensuse
Posts: 14

Rep: Reputation: 0
My laptop won't turn it self off after shutdown.


My laptop won't turn off after i pressed shut down. The computer is still running with the shut down spash screen frozen. Please help. I am running SLED 10.
 
Old 05-05-2007, 12:09 AM   #2
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Sounds like an ACPI problem. Without it, the system will just come to a halt but it won't actually power down your hardware. Weird, this should be enabled by default. Did you uncheck certain items when you installed?

I suggest you go to System > Administration > yast and check whether there are any ACPI packages to install.
 
Old 05-05-2007, 03:11 AM   #3
jerrylu
LQ Newbie
 
Registered: Feb 2007
Location: Australia
Distribution: SLED and opensuse
Posts: 14

Original Poster
Rep: Reputation: 0
All the ACPI packages have been installed already. Is there anything else i could do, please?
 
Old 05-05-2007, 03:25 AM   #4
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Could you try running the command below from the terminal?

shutdown --poweroff now
 
Old 05-05-2007, 03:32 AM   #5
jerrylu
LQ Newbie
 
Registered: Feb 2007
Location: Australia
Distribution: SLED and opensuse
Posts: 14

Original Poster
Rep: Reputation: 0
I got this after typing the command, which one should i choose?

linux-tuvz:/home/jerry # shutdown --poweroff now
shutdown: invalid option -- -
Usage: shutdown [-akrhHPfnc] [-t secs] time [warning message]
-a: use /etc/shutdown.allow
-k: don't really shutdown, only warn.
-r: reboot after shutdown.
-h: halt after shutdown.
-P: halt action is to turn off power.
-H: halt action is to just halt.
-f: do a 'fast' reboot (skip fsck).
-F: Force fsck on reboot.
-n: do not go through "init" but go down real fast.
-z: shutdown using software suspend.
-c: cancel a running shutdown.
-t secs: delay between warning and kill signal.
** the "time" argument is mandatory! (try "now") **
 
Old 05-05-2007, 03:35 AM   #6
jerrylu
LQ Newbie
 
Registered: Feb 2007
Location: Australia
Distribution: SLED and opensuse
Posts: 14

Original Poster
Rep: Reputation: 0
double post, sorry

Last edited by jerrylu; 05-05-2007 at 03:36 AM.
 
Old 05-05-2007, 04:09 AM   #7
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
shutdown -P now
 
Old 05-05-2007, 05:10 AM   #8
jerrylu
LQ Newbie
 
Registered: Feb 2007
Location: Australia
Distribution: SLED and opensuse
Posts: 14

Original Poster
Rep: Reputation: 0
It still does not work. The only thing that it has done is gotten me into text mode. Also tried this command:
shutdown -P now
and it still does not work. Please help.
 
Old 05-05-2007, 05:32 AM   #9
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Hmm, is that a fresh install, did you recently update/upgrade anything? This is really beginning to sound as if the kernel has no ACPI/APM support...
 
Old 05-05-2007, 05:41 AM   #10
jerrylu
LQ Newbie
 
Registered: Feb 2007
Location: Australia
Distribution: SLED and opensuse
Posts: 14

Original Poster
Rep: Reputation: 0
It was a fresh install.
 
Old 05-05-2007, 05:48 AM   #11
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Mmm, maybe there is some hidden error. Could you issue this command, as root:

cat /var/log/dmesg | grep Error >> /home/[username]/error

This will scan for any error messages and print them to an "error" file in your home directory. If you post that file, we may find out what is going wrong.

btw, you may also want to check your BIOS and make sure that ACPI is enabled. Of course, if you were running something else before SLED and powering down was no problem, then obviously this is not the problem.

Last edited by jay73; 05-05-2007 at 05:51 AM.
 
Old 05-05-2007, 06:03 AM   #12
jerrylu
LQ Newbie
 
Registered: Feb 2007
Location: Australia
Distribution: SLED and opensuse
Posts: 14

Original Poster
Rep: Reputation: 0
sorry but i got this error:
cat: /var/log/dmesg: No such file or directory

And i my system is a dual boot system and Windows XP can shutdown properly.
 
Old 05-05-2007, 06:35 AM   #13
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Huh, so Suse hasn't got /var/log/dmesg now? OK, if the sytem says so, that must be correct. I would suggest that - providing you haven't done so yet - you check whether there are any updates to be made. It's quiet often that a system has some bugs which are resolved only by an update.

Give it a try and post back. I'll get back to you as soon as possible (some other business to attend to right now).
 
Old 05-06-2007, 11:01 AM   #14
auxsvr
Member
 
Registered: Dec 2006
Distribution: openSUSE 10.3
Posts: 260

Rep: Reputation: 30
You can type dmesg | less or less /var/log/messages to see the kernel and system log. Could you give a hardware description?
 
Old 05-09-2007, 04:43 AM   #15
jerrylu
LQ Newbie
 
Registered: Feb 2007
Location: Australia
Distribution: SLED and opensuse
Posts: 14

Original Poster
Rep: Reputation: 0
I have installed updates, but it hasn't fixed the problem.
My hardware:
BenQ Joybook S73G
1.66 GHz Core Duo
ATI Mobility Radeon x1600 512mb
80 GB hard drive
DVD-RAM burner
OS: Windows XP home edition and SLED 10
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
turn off linux /shutdown computer xprometeus Linux - General 9 09-25-2010 03:18 PM
Shutdown doesn't turn pc off - Debian Testing doraimom Debian 15 07-25-2007 01:45 PM
Compaq doesn't turn off after shutdown jhwhite Linux - Laptop and Netbook 17 11-03-2005 09:26 PM
How to turn off verbose on shutdown Khepri Linux - Newbie 4 08-11-2005 07:08 AM
Mandrake 9.2 does not turn off power at shutdown dancro Mandriva 12 03-19-2004 07:41 AM


All times are GMT -5. The time now is 08:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration