LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 03-15-2008, 03:33 PM   #1
RLH1919
Member
 
Registered: Dec 2007
Location: Charleston, South Carolina USA
Distribution: Slackware 13 Ubuntu RHEL 5
Posts: 50

Rep: Reputation: 15
Multi Media Player for Linux Enterprise Desktop 10


I am trying to get totem to play wma, wmv, and other files but it gives me the error that I do not have a decoder installed to handle this file. You might need to install the necessary plugins.
I have tried installing xine, gstreamer, upgrading totem, installing the latest version of totem, and have been unsuccessful. I have tried several tutorials to fix the problem and have been unsuccessful. Does anybody know of a simple solution or tutorial that I could use? I basically spent all day trying solutions that I've googled and haven't found anything that works.
 
Old 03-15-2008, 03:41 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,531

Rep: Reputation: 178Reputation: 178
I had similar problems with totem and I switched to mplayer which works fine.

-------------------
Steve Stites
 
Old 03-15-2008, 04:04 PM   #3
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
You need to install gstreamer-plugins-bad, gstreamer-plugins-bad-extras, gstreamer-plugins-ugly and possiblly gstreamer-ffmpeg.

Last edited by reddazz; 03-15-2008 at 04:06 PM.
 
Old 03-15-2008, 05:30 PM   #4
RLH1919
Member
 
Registered: Dec 2007
Location: Charleston, South Carolina USA
Distribution: Slackware 13 Ubuntu RHEL 5
Posts: 50

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by reddazz View Post
You need to install gstreamer-plugins-bad, gstreamer-plugins-bad-extras, gstreamer-plugins-ugly and possiblly gstreamer-ffmpeg.
Any idea where I can find those? I've looked and can't seem to find the right version. (i586)
 
Old 03-15-2008, 05:56 PM   #5
RLH1919
Member
 
Registered: Dec 2007
Location: Charleston, South Carolina USA
Distribution: Slackware 13 Ubuntu RHEL 5
Posts: 50

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by reddazz View Post
You need to install gstreamer-plugins-bad, gstreamer-plugins-bad-extras, gstreamer-plugins-ugly and possiblly gstreamer-ffmpeg.
When I try to installgstreamer-plugins-bad I get the following error:

warning: gstreamer010-plugins-bad-0.10.6-42.pm.1.i586.rpm: Header V3 DSA signature: NOKEY, key ID 9a795806
error: Failed dependencies:
amrwb is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
faac is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
faad2 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
gstreamer010 >= 0.10.17 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
ladspa is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
soundtouch is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
swfdec >= 0.3.6 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
xvid is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libBPM.so.0 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libSoundTouch.so.0 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libamrwb.so.3 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libcdaudio.so.1 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libdca.so.0 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libdivxdecore.so.0 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libdivxencore.so.0 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libfaac.so.0 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libfaad.so.0 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libgstpbutils-0.10.so.0 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libgstsdp-0.10.so.0 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libmms.so.0 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libmpcdec.so.3 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libswfdec-0.3.so.0 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libx264.so.57 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
libxvidcore.so.4 is needed by gstreamer010-plugins-bad-0.10.6-42.pm.1.i586
 
Old 03-15-2008, 07:37 PM   #6
RLH1919
Member
 
Registered: Dec 2007
Location: Charleston, South Carolina USA
Distribution: Slackware 13 Ubuntu RHEL 5
Posts: 50

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by jailbait View Post
I had similar problems with totem and I switched to mplayer which works fine.

-------------------
Steve Stites
I installed mplayer but when I go to open a an mpg or wmv file it doesn't respond or play the file. mplayer opens up but nothing happens, no error etc. I guess I'm missing something? Any ideas?
I found a cool way to update software with yast from another forum:

Open the control center.
Click YaST modules
Click Software
Click Change Installation Source
Click Add
Select http
Put packman.iu-bremen.de in the site field
Put suse/9.1 in the path field
Click OK

Now simply click on Install and Remove Software and the entire packman library is now listed.

Doing this turns an Mplayer installation into a 10 second affair. Additionally, packman has binaries for just about everything else you could possibly want.
But when I try to install the browser plugin for Netscape/Mozilla it bombs with no errors, the window closes and nothing happens other than it not installing.
 
Old 03-15-2008, 09:23 PM   #7
RLH1919
Member
 
Registered: Dec 2007
Location: Charleston, South Carolina USA
Distribution: Slackware 13 Ubuntu RHEL 5
Posts: 50

Original Poster
Rep: Reputation: 15
Well I have installed and tried mplayer, smplayer, movie player,kaffeine, kmplayer,totem, xine, gstreamer, various plugins and win32 codecs and I couldn't any of them to play wmv or mpg files.
 
Old 03-16-2008, 06:36 AM   #8
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
To install the gstreamer plugins, setup the packman repository for SUSE 10.1 (it should be compatible with SLED 10). To do this, go to YAST -> Software -> Software Repositories. Select the option to add a repository -> media type: http -> Repository Name: Packman -> Server Name: ftp.uni-erlangen.de -> Directory on Server -> suse/10.1. After that run YAST -Software -> Software management and search for the gstreamer plugins you wish to install.
 
Old 03-16-2008, 09:50 AM   #9
RLH1919
Member
 
Registered: Dec 2007
Location: Charleston, South Carolina USA
Distribution: Slackware 13 Ubuntu RHEL 5
Posts: 50

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by reddazz View Post
To install the gstreamer plugins, setup the packman repository for SUSE 10.1 (it should be compatible with SLED 10). To do this, go to YAST -> Software -> Software Repositories. Select the option to add a repository -> media type: http -> Repository Name: Packman -> Server Name: ftp.uni-erlangen.de -> Directory on Server -> suse/10.1. After that run YAST -Software -> Software management and search for the gstreamer plugins you wish to install.
Thanks Reddazz that fixed it. I can play the wmv files in my Mozilla browser and off a disc. My sound isn't working now though. I checked it and it said it wasn't enabled in the config, I have ALSA. I'm going to try and see if I can get that working now. Thanks again, appreciate the help.
 
  


Reply

Tags
media, player, totem, wma, wmv


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Hack Your Media Player - Neuros OSD Open Source Media Player LXer Syndicated Linux News 0 01-21-2008 05:40 AM
media player for redhat enterprise linux 5 bhupathi2007 Linux - General 2 05-19-2007 07:51 PM
Default Media Player Not Playing Windows Media Player Files kenlitting Suse/Novell 2 11-29-2006 11:05 AM
Multi Media Player Wanted! Zeriph Linux - Newbie 5 07-26-2006 03:33 PM
How do you change card# of multi multi-media cards. Nichole_knc Slackware 3 12-01-2004 12:49 PM


All times are GMT -5. The time now is 03:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration