LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Mp3 Audio Decoder plugin not found (K3b CD/DVD Kreator) (http://www.linuxquestions.org/questions/suse-novell-60/mp3-audio-decoder-plugin-not-found-k3b-cd-dvd-kreator-555238/)

suse2166 05-19-2007 05:01 PM

Mp3 Audio Decoder plugin not found (K3b CD/DVD Kreator)
 
To whom it may concern

I keep getting this error message every time I open K3b CD/DVD Burning kreator .. but MAD Mp3 decoding is install for K3b & Lame is install on my machine ..

I uninstall it and reinstall with my Smart Package Manager ... I am still getting this error message on Suse 10.2 ...

Help ... This is the Error message.. Thanks ..


Error message: Mp3 Audio Decoder plugin not found.
K3b could not load or find the Mp3 decoder plugin. This means that you will not be able to create Audio CDs from Mp3 files. Many Linux distributions do not include Mp3 support for legal reasons.
Solution: To enable Mp3 support, please install the MAD Mp3 decoding library as well as the K3b MAD Mp3 decoder plugin (the latter may already be installed but not functional due to the missing libmad). Some distributions allow installation of Mp3 support via an online update tool (i.e. SuSE's YOU).

google01103 05-19-2007 06:24 PM

I don't what version of k3b you're using but the very latest uses a seperate codec file, k3b-codecs-1.0.1-6.1.rpm. This of course is available from Packman

which contains:1.0.1-6.1
smiley@circus:~/MyTemp> rpm -ql k3b-codecs1.0.1-6.1
smiley@circus:~/MyTemp> rpm -ql k3b-codecs
/opt/kde3/lib64/kde3/libk3bffmpegdecoder.la
/opt/kde3/lib64/kde3/libk3bffmpegdecoder.so
/opt/kde3/lib64/kde3/libk3blameencoder.la
/opt/kde3/lib64/kde3/libk3blameencoder.so
/opt/kde3/lib64/kde3/libk3bmaddecoder.la
/opt/kde3/lib64/kde3/libk3bmaddecoder.so
/opt/kde3/share/apps/k3b/plugins/k3bffmpegdecoder.plugin
/opt/kde3/share/apps/k3b/plugins/k3blameencoder.plugin
/opt/kde3/share/apps/k3b/plugins/k3bmaddecoder.plugin

google01103 05-19-2007 06:25 PM

I don't what version of k3b you're using but the very latest uses a seperate codec file, k3b-codecs-1.0.1-6.1.rpm. This of course is available from Packman

which contains:
/opt/kde3/lib64/kde3/libk3bffmpegdecoder.la
/opt/kde3/lib64/kde3/libk3bffmpegdecoder.so
/opt/kde3/lib64/kde3/libk3blameencoder.la
/opt/kde3/lib64/kde3/libk3blameencoder.so
/opt/kde3/lib64/kde3/libk3bmaddecoder.la
/opt/kde3/lib64/kde3/libk3bmaddecoder.so
/opt/kde3/share/apps/k3b/plugins/k3bffmpegdecoder.plugin
/opt/kde3/share/apps/k3b/plugins/k3blameencoder.plugin
/opt/kde3/share/apps/k3b/plugins/k3bmaddecoder.plugin

suse2166 05-19-2007 06:41 PM

Thanks Google1103

You are correct ... I was missing the k3b-codecs-1.0.1-6.1.rpm on my machine.
I install it and K3b CD/DVD Kreator is working fine with no problem

thanks very much for your help ..

uludur 03-31-2009 04:56 PM

Suse 11.0 mit gleichen Problem gelöst
 
I got the same error message:
Clever as I am I installed the two packages
kde4-k3b and the k3b package. After deleting
the unnessecary kde4-k3b package the
error message disappeared.
Perhaps it may be helpful for someone else


All times are GMT -5. The time now is 12:12 AM.