LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 02-08-2006, 11:37 AM   #1
Sheesh
Member
 
Registered: Dec 2005
Location: Ontario, Canada
Distribution: Suse 10.0 Evaluation
Posts: 31

Rep: Reputation: 15
Mouse scrolls down but not up


I need a little help with the scroll wheel on my mouse. It used to scroll up and down, but now only scrolls down. I tried it on another system and it works fine. I also booted into Windows on this computer and it works fine there as well. I just lost the ability to scroll up for some reason.

The mouse is a Microsoft 5-Button Mouse with IntelliEye (USB). I tried to change the mouse in SaX2, but that did nothing to solve this problem.
 
Old 02-08-2006, 02:36 PM   #2
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 162Reputation: 162
I'm assuming you're using X (I haven't used SaX2) so can you post the InputDevice section for your mouse from /etc/X11/xorg.conf please? Hopefully, it's a misconfigured setting - have you changed your settings recently? The required settings vary depending on your mouse type, but here's mine:
Code:
Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "ImPS/2"
    Option         "Device" "/dev/mouse"
    Option         "ZAxisMapping" "4 5"
    Option         "Emulate3Buttons" "yes"
EndSection
 
Old 02-08-2006, 06:14 PM   #3
Sheesh
Member
 
Registered: Dec 2005
Location: Ontario, Canada
Distribution: Suse 10.0 Evaluation
Posts: 31

Original Poster
Rep: Reputation: 15
This is what I have right now. I didn't change anything that I know of, it just stopped working after a restart.

Code:
Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "7"
  Option       "Device" "/dev/input/mice"
  Option       "Emulate3Buttons" "on"
  Option       "EmulateWheel" "on"
  Option       "EmulateWheelButton" "4"
  Option       "Name" "Microsoft 5-Button Mouse with IntelliEye(TM)"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
 
Old 02-08-2006, 07:35 PM   #4
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Turn off emulate 3 buttons(delete or comment out that line.)

Turn off emulate wheel.

you aren't emulating either, you actually have them, emulation only hampers your actual buttons/wheel.
 
Old 02-08-2006, 08:16 PM   #5
Sheesh
Member
 
Registered: Dec 2005
Location: Ontario, Canada
Distribution: Suse 10.0 Evaluation
Posts: 31

Original Poster
Rep: Reputation: 15
Ok this is what I have. I am going to restart to see if it helps.
Code:
Section "InputDevice"
  Driver       "mouse"
  Identifier   "Mouse[1]"
  Option       "Buttons" "7"
  Option       "Device" "/dev/input/mice"
  Option       "Name" "Microsoft 5-Button Mouse with IntelliEye(TM)"
  Option       "Protocol" "explorerps/2"
  Option       "Vendor" "Sysp"
  Option       "ZAxisMapping" "4 5"
EndSection
 
Old 02-08-2006, 08:54 PM   #6
Sheesh
Member
 
Registered: Dec 2005
Location: Ontario, Canada
Distribution: Suse 10.0 Evaluation
Posts: 31

Original Poster
Rep: Reputation: 15
HELP!

Ever since I restarted my system, I can't access my keyboard or mouse. It works for the first part of the startup, but once it loads the system files and configurations I have no mouse or keyboard. The Windows key will exit to the command prompt, and then I have full use of the keyboard again, but I have no idea what I can do to fix this.

Please help. I am in Windows. (shudder)
 
Old 02-08-2006, 09:31 PM   #7
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Okay, now I am confused... you can try this... but I have to be honest... I don't get it. That should be working.
http://www.cosmicpothole.com/Linux/mouse.php
 
Old 02-08-2006, 11:25 PM   #8
Sheesh
Member
 
Registered: Dec 2005
Location: Ontario, Canada
Distribution: Suse 10.0 Evaluation
Posts: 31

Original Poster
Rep: Reputation: 15
I can't get my system to work anymore. The keyboard will not type characters, but it will register [Ctrl][Alt][Delete] and the Windows buttons. The mouse will not move at all and the buttons don't appear to do anything. The light is on, but doesn't get brighter or dim when not in use.
 
Old 02-09-2006, 12:01 AM   #9
Sheesh
Member
 
Registered: Dec 2005
Location: Ontario, Canada
Distribution: Suse 10.0 Evaluation
Posts: 31

Original Poster
Rep: Reputation: 15
First off I want to say that I am back in Linux again. I ended up going into root, did an init 1 and edited the xorg.conf file. After I did that I typed in SaX2 and entered the program. I was able to select and change options and save. I rebooted and now have my keyboard and mouse with the up and down scroll working again.
 
Old 02-09-2006, 02:48 AM   #10
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Milwaukee, WI
Distribution: Mint
Posts: 6,642

Rep: Reputation: 69
Nice work Sheesh, and thanks for posting back with the solution that worked for you!
 
Old 02-09-2006, 01:27 PM   #11
Sheesh
Member
 
Registered: Dec 2005
Location: Ontario, Canada
Distribution: Suse 10.0 Evaluation
Posts: 31

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by J.W.
Nice work Sheesh, and thanks for posting back with the solution that worked for you!
No problem! I got a little help from gilead and RedShirt and pointed me in the right direction. I just had to figure out a little extra on my own to finish it up. If anyone else can benefit from my post then I will be very happy about that as well. We are all here to help each other out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to make second wheel scrolls horizontally superandrzej Slackware 6 05-30-2005 11:14 PM
mouse scrolls horizontal instead of vert crache Linux - Hardware 5 02-25-2005 09:56 AM
Suse 9.2 : How to change amount mouse wheel scrolls by? timko Linux - Hardware 5 02-16-2005 05:02 AM
KDE 3.3.2 - Mouse Wheel Only Scrolls in KDE Apps mac57 Linux - Software 0 01-19-2005 10:29 AM
screen scrolls too low. rojo Slackware 4 01-24-2003 12:12 PM


All times are GMT -5. The time now is 07:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration