LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Missing Packman repository for 10.0 (http://www.linuxquestions.org/questions/suse-novell-60/missing-packman-repository-for-10-0-a-527214/)

agentchange 02-10-2007 12:00 AM

Missing Packman repository for 10.0
 
It looks like I missed a couple of automatic updates, but only from the Packman repository. They are supposed to automatically update, right, or do only the Opensuse repositories automatically update?

I have been having problems with Mplayer playing some things and I just now discovered that there was a newer version of both MPlayer and win32codec that were probably accessible back when my Packman repository was still working, but somehow never got updated. At some time around 6 months ago, Yast stopped reading that as a valid installation source (the address listed in The Gem Report?), probably when they changed their server to unixheads. The thing is that these two newer versions only existed on that Packman website, not on Opensuse. I have deleted that installation source in Yast, but after doing the search again, have found that Packman was the only repository that had those updated versions.

I'm not sure if that will even fix my Mplayer issue since Opensuse is supposed to have the latest, greatest anyway ... right? I have tried updateing the Packman installation source in Yast with the new information listed in Opensuse, but for some reason it just won't work.


This is what Opensuse says:

Quote:

Packman

Packman offers various additional packages for SUSE Linux. Please use a mirror if possible:

To import the GnuPG key issue the following command as root:

rpm --import http://packman.unixheads.com/suse/10...y-1abd1afb.asc

Type - rpm-md/repomd

Protocol - HTTP
Server name - packman.iu-bremen.de
Directories - suse/10.0
- suse/10.1
- suse/10.2/
Mirrors - Australia Belgium Germany Germany Germany Germany Romania USA USA

So I plugged in a Packman installation source in Yast, as follows:

Protocol - HTTP
Server - packman.unixheads.com
Directory - suse/10.0/gpg-pubkey-1abd1afb.asc

But it says,

Quote:


Unable to create installation source
from URL 'http://packman.unixheads.com/suse/10.0/gpg-pubkey-1abd1afb.asc'
Details:
ERROR(InstSrc:E_no_instrc_on_media)
Try again?
Does this mean anything to anybody or is just back to the drawing board? I already ran the command, as stated. Does this have any effect on Yast, or does it only affect command-line oriented updates? (Obviously, it has no effect on Yast.)

rjwilmsi 02-10-2007 04:07 AM

What happens if you enter the directory as suse/10.0/ ?

agentchange 02-10-2007 05:36 AM

I made that change.

rjwilmsi 02-10-2007 05:57 AM

Okay, did it work?

agentchange 02-10-2007 06:01 AM

No, I made that change in my initial attempt, as depicted in the second quote, and it didn't work.

rjwilmsi 02-10-2007 06:05 AM

In your second quote the url is 'http://packman.unixheads.com/suse/10.0/gpg-pubkey-1abd1afb.asc'

So, have you tried this:

Protocol - HTTP
Server - packman.unixheads.com
Directory - suse/10.0/

agentchange 02-10-2007 11:07 AM

Now I see. Thanks.


All times are GMT -5. The time now is 03:47 AM.