LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Master Volume Control Doesn't work, only PCM does (http://www.linuxquestions.org/questions/suse-novell-60/master-volume-control-doesnt-work-only-pcm-does-461609/)

jpneron 07-06-2006 04:35 PM

Master Volume Control Doesn't work, only PCM does
 
Hi,

I've got an annoying problem with the 'kmix' sound control. The Master Control does nothing, but the PCM volume control works perfectly. I can adjust the volume, mute, and it all works as it should with the PCM slider. I've tried kmix, kamix and gnome-alsamixer, and they all do the same thing.

I've configured my multimedia keyboard so that I can control the sound, but since it only controls the Master volume (which does nothing), it's pretty well useless.

I'm currently running KDE on SuSE 10.1, but this problem probably existed in 10, and maybe even 9.x, I just didn't care about it back then.

I don't really care if I get the master control to work, what I really want is to be able to control/mute the volume from the keyboard. If there's a way to 'slave' the PCM to the Master, or something like that, that would do the trick. Or, if there's another volume control out there where I can config the keyboard shortcuts. 'kmix' is sooo close, as the mute, vol up/down keyboard shortcuts work, it's just that they're controlling the Master volume, which does nothing. I'd like them to control the PCM volume instead.

Here's my config:
Sound Driver 3.8.1a-980706 (ALSA V1.0.11rc3 emulation code)
Kernel: 2.6.16.13-4-default
Installed driver: Type 10 ALSA emulation
card config: Intel 82801DB-ICH4 with AD1981A at 0xfe300400, irq 209
Audio Device: Intel 82801DB-ICH4 (DUPLEX)
Synth & Midi devices NOT ENABLED IN CONFIG
Mixer: 0: Analog Devices AD1981A

All suggestions appreciated.

Thanks.

Jean

Brian1 07-06-2006 05:50 PM

Check out this post. It should get you started. Look at the scripts I wrote and then you can edit /etc/X11/Xmodmap to map keys to whatever. Or check out xbindkeys to map to scripts or whatever again. Also can be done from the Control Center from KDE.

http://www.linuxquestions.org/questi...865#post498865

Instead of using -v for master volume you use -w for the pcm channel. You can get that from the command ' man aumix '.

Brian1

jpneron 07-07-2006 09:57 AM

Thanks for the tip, but I found a much easier way to do it. Don't know why/how I didn't notice this before, but when I right click 'kmix', there's an option to 'Select Master Channel'. I did this, and selected PCM as my master channel. I had already mapped my multimedia keys and configured them in 'kmix', so once I did that, everything works perfectly!

Duh!

Thanks.

Jean

megaprog 11-11-2008 08:53 AM

I had the same problem on my Debian Etch, and now It works like a charm, right click - select master channel, lol, funny solution, but It's what a needed.


All times are GMT -5. The time now is 03:23 PM.