LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 09-17-2006, 03:43 PM   #1
sporks
Member
 
Registered: Dec 2004
Location: Indonesia
Distribution: Slackware
Posts: 211

Rep: Reputation: 30
Low Disk Space - KDE Daemon keeps popping up?


I keep getting a message that I'm running out of space on my home partition (11% full for all users). KDE seems to think that I've got -34% space free on /home and I need to free space so it keeps popping up a notification window.

I've not enabled quotas on this computer that I knew of.

What the heck is going on? How do I turn this thing off?
 
Old 09-17-2006, 10:05 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
You have somehow enabled a disk space monitor. Maybe KDiskFree. There are two things you can do. First is to prevent it from running when you log in. The other is to stop it from creating a warning window when a disk gets full. Both of these are configurable within the KDiskFree application.

You probably have a KDiskFree icon on your task bar. Right click, open the application window, click 'Settings", click "Configure KDiskFree" and make the changes.

If you can't find the icon then you can open a terminal window and run it from the command line. The executable's name is kdf. So you would open a terminal window and type kdf at the prompt and press the enter key. That will open a KDiskFree window. Then follow the steps listed above.
 
Old 09-17-2006, 10:57 PM   #3
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Rep: Reputation: 30
Or use the du command.. to find where your disk usage is.
 
Old 09-18-2006, 01:59 AM   #4
BDHamp
Member
 
Registered: Mar 2005
Distribution: Ubuntu 9.10, Mint 8, Slackware 12
Posts: 105

Rep: Reputation: 16
I started getting this too as of tonight, after doing an update of KDE to the latest releases. I have KwikDisk running, but then I've had it running for a long time.

My /home partition is 40% full. Using du reports 110GB used on a 250GB partition. The popup reports -9% free space available. I have yet to start diagnosing the problem and thought I would check here to see if any others are experiencing it.

Having it start happening after an full KDE upgrade makes me suspicious something was introduced during that upgrade that is resulting in an improper report of free space or a quote imposed I did not desire. It's late, so I'll look into this more tomorrow, but if anyone has a suggestion in the mean time, I'd be most greatful.
 
Old 09-18-2006, 03:40 AM   #5
onjoo
Member
 
Registered: Jan 2005
Location: Finland
Distribution: Suse 10, Suse-factory , RHEL4, SLES9, SLED10
Posts: 380

Rep: Reputation: 30
Quote:
Originally Posted by BDHamp
I started getting this too as of tonight, after doing an update of KDE to the latest releases.
Please report the bug @ https://bugzilla.novell.com
 
Old 09-18-2006, 05:34 AM   #6
onjoo
Member
 
Registered: Jan 2005
Location: Finland
Distribution: Suse 10, Suse-factory , RHEL4, SLES9, SLED10
Posts: 380

Rep: Reputation: 30
Actually its already reported in bugzilla, but there is no real answer or patch available.

https://bugzilla.novell.com/show_bug.cgi?id=206376
 
Old 09-18-2006, 09:42 AM   #7
sporks
Member
 
Registered: Dec 2004
Location: Indonesia
Distribution: Slackware
Posts: 211

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by BDHamp
I started getting this too as of tonight, after doing an update of KDE to the latest releases. I have KwikDisk running, but then I've had it running for a long time.

My /home partition is 40% full. Using du reports 110GB used on a 250GB partition. The popup reports -9% free space available. I have yet to start diagnosing the problem and thought I would check here to see if any others are experiencing it.

Having it start happening after an full KDE upgrade makes me suspicious something was introduced during that upgrade that is resulting in an improper report of free space or a quote imposed I did not desire. It's late, so I'll look into this more tomorrow, but if anyone has a suggestion in the mean time, I'd be most greatful.
Ok, then I'm not crazy. I ran an upgrade and it showed up. I didn't change any settings or enable KwikDisk or whatever.

For the record, it's only on my 64 bit machine, my 686 laptop is fine.

*edit* Just looked at Bugzilla, guess I'll wait for the next RPM upgrade.

Thank you all.

Last edited by sporks; 09-18-2006 at 09:43 AM.
 
Old 09-18-2006, 11:45 PM   #8
BDHamp
Member
 
Registered: Mar 2005
Distribution: Ubuntu 9.10, Mint 8, Slackware 12
Posts: 105

Rep: Reputation: 16
This is maddening. I came home to a hundred iterations of that blasted notification window.

I know, I know ... growing pains and all, but this is very nearly making KDE unusable, or at least so obnoxious that I'd rather not.

And I'm not real clear on this feature either. I don't want a daemon running, constantly checking by drive space, and popping up notices to me. I take care of that myself with scripts, thanks, and I want it turned off. I am assuming when this is fixed some sort of "don't ever bug me again with this stuff" option will be there.

Sorry ... no helpful content I know, just venting. I'm trying to work on something (and thus don't have the time at the moment to try to downgrade everything), and these popups are keeping me from being able to concentrate. It's almost Windoze-like in its obnoxiousness.

I shut up now.
 
Old 09-19-2006, 10:04 AM   #9
Gnartis
LQ Newbie
 
Registered: Sep 2006
Posts: 2

Rep: Reputation: 0
I've been experiencing this infuriating problem as well. One word of advice: don't click the options of "Open Konqueror" and "never show me this dialog again". This will result in Kongueror opening for every "low disk space" event and filling up your desktop with hundreds of Konqueror file managers.

I haven't yet found where this setting is stored but do know that it is user based.
 
Old 09-19-2006, 10:06 AM   #10
sporks
Member
 
Registered: Dec 2004
Location: Indonesia
Distribution: Slackware
Posts: 211

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Gnartis
I've been experiencing this infuriating problem as well. One word of advice: don't click the options of "Open Konqueror" and "never show me this dialog again". This will result in Kongueror opening for every "low disk space" event and filling up your desktop with hundreds of Konqueror file managers.

I haven't yet found where this setting is stored but do know that it is user based.
:groan: I made the same mistake. I thought it wouldn't ask me if I wanted to free disk space. Not that it wouldn't ask me if I wanted to open Konqueror and just open Konqueror all the time.
 
Old 09-19-2006, 09:38 PM   #11
BDHamp
Member
 
Registered: Mar 2005
Distribution: Ubuntu 9.10, Mint 8, Slackware 12
Posts: 105

Rep: Reputation: 16
Quote:
Originally Posted by Gnartis
I've been experiencing this infuriating problem as well. One word of advice: don't click the options of "Open Konqueror" and "never show me this dialog again". This will result in Kongueror opening for every "low disk space" event and filling up your desktop with hundreds of Konqueror file managers.

I haven't yet found where this setting is stored but do know that it is user based.
If you find out, let me know, because I've already made the mistake of doing this.

I'm curious ... Bugzilla reports that the bug is resolved. Okay, perhaps I'm dense, but it's not resolved in anything I can see. There's not a more recent update of any of the involved RPMs. I've redownloaded those RPMs upon taking the advice to use the "recompiled" RPM, and this did exactly nothing to fix the issue.

I wouldn't be so irritated if I weren't in the midst of hell week without any real time on my hands to run through this and look for other options. But anyway ...
 
Old 09-20-2006, 09:20 AM   #12
Gnartis
LQ Newbie
 
Registered: Sep 2006
Posts: 2

Rep: Reputation: 0
The setting appears to be under:

/home/user_xyz/.kde/share/config/kdedrc
[Notification Messages]

I had to restart KDE for the setting to go into effect.
 
Old 09-20-2006, 12:45 PM   #13
PerfectReign
Member
 
Registered: Apr 2005
Location: Los Angeles
Distribution: openSUSE / Ubuntu
Posts: 294

Rep: Reputation: 33
Funny I feel like I've posted this before....

This is a bug with KDE 3.5.4 (I'm on 3.5.1 and haven't seen it.) You can see the bug report here:

http://bugs.kde.org/show_bug.cgi?id=134081

Supposedly there's a fix on the way.
 
Old 09-21-2006, 09:29 AM   #14
sporks
Member
 
Registered: Dec 2004
Location: Indonesia
Distribution: Slackware
Posts: 211

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by PerfectReign
Funny....
No, it's not funny, it's danged irritating to have this thing keep popping up.

I'll have to check out the user settings "fix" since I've not seen one come with an update.

Last edited by sporks; 09-21-2006 at 09:30 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Low disk space in /var wuqso Linux - General 2 05-22-2006 10:11 PM
low disk space ahmed gamal Slackware 3 03-21-2006 02:32 PM
Low disk space problem Maverick1182 Linux - Newbie 3 08-07-2005 04:14 AM
E-mail notification of low disk space Hypocrite Linux - General 2 11-10-2004 02:27 PM
Low disk space??? kevinlyfellow Linux - General 6 11-12-2003 02:37 PM


All times are GMT -5. The time now is 05:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration