LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 11-21-2007, 02:37 AM   #1
tpe
Member
 
Registered: Oct 2004
Location: Athens, Greece
Distribution: Suse Linux
Posts: 98

Rep: Reputation: 16
Question KIO svn questions


Dear all,
Under opoenSuse 10.1, I run kdesvn 0.14 over KDE 3.5.8. I have a number of repositories under /srv/svn/repos directory and the svnserve up and running. snvserve configuration was completed by YAST.
All repositories have been created by kdesvn. From kdesvn I can open and work with the repositories only by local access (file:///).

Now, let see the problem:
When I enter svn://localhost in the address bar of Konqueror, or in general in any open dialog of any KDE application, I receive an error message:

Code:
An error occurred while loading svn://localhost/:
No repository found in 'svn://localhost'
However, when I enter the repository path (eg XML), the repository is presented. For example:
svn://localhost/XML will result:
Code:
branches
tags
trunc
Now, the repositories are under /srv/svn/repos directory. That directory contains:

Code:
ls -l
total 0
drwxr-xr-x 7 svn svn 224 Jan 19  2007 Daemon
drwxr-xr-x 7 svn svn 224 Oct  5 12:28 various
drwxr-xr-x 7 svn svn 224 Oct  8 09:46 XML
Under (eg) XML directory, the repository is:
Code:
drwxrwxr-x+ 2 svn svn  48 Oct  8 09:46 dav
drwxrwxr-x+ 2 svn svn 104 Oct  8 09:46 locks
drwxrwxr-x+ 2 svn svn 360 Oct  8 09:46 hooks
-r--r--r--+ 1 svn svn   2 Oct  8 09:46 format
drwxrwxr-x+ 2 svn svn 128 Oct  8 09:46 conf
-rw-rw-r--+ 1 svn svn 229 Oct  8 09:46 README.txt
drwxrwsr-x+ 6 svn svn 280 Nov 20 13:15 db
The issue is that I cannot browse the repositories, thus, I cannot use them with my quanta projects. The /srv/svn/repos directory does not contain any svn information (as you have already see). It have only the repositories directories.

Did I missed something during the repositories creation? From Windows clients (like for example RapidSVN) none can access the repositories in general.

Any help would be appreciated.
Peter
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
anon svn read-only over apache: '.svn/entries': No such file hedpe Linux - Software 2 04-29-2009 05:31 AM
siduxcc and kio-sidux craigevil Debian 6 09-07-2007 07:54 AM
KDE 3.5.6 doesn't start (problem with Kio aleksanteri Linux From Scratch 0 06-24-2007 08:03 AM
KDE Kio slave powadha Debian 12 04-27-2006 01:04 AM
kfile and kio srivas Linux - Newbie 0 11-28-2003 07:25 AM


All times are GMT -5. The time now is 01:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration