LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 10-19-2005, 12:42 PM   #1
CUCPSC_Geek
LQ Newbie
 
Registered: Sep 2005
Location: South Carolina
Distribution: SuSE 9.3
Posts: 8

Rep: Reputation: 0
Kernel Upgrades for SuSE 10.0


I recently upgraded from 9.3 to 10.0, and overall I am very happy with 10.0. I have noticed though that the kernel is much slower than the one used in 9.3. The 2.6.11 seems to be much faster in just about everything, at least from my testing.

I have talked to many people, and it seems to be a problem with the 2.6.13-15 kernel and ATi powered video. I upgraded my ATi drivers to the newer versions, and it didn't improve much.

Does anyone know of a different kernel I can try, short of getting a vanilla kernel and pulling my hair out. Or does anyone have any clues on what the slowdown is if it isn't kernel related?

* I d/l'd a project kernel from SuSE ftp, and it made the system scream, but I can't find source for it...so installing and reconfiguring becomes a real PITA.

Thanks guys
 
Old 10-19-2005, 01:20 PM   #2
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
CUCPSC_Geek,

Silly question but you mentioned you are using the "Powered by ATI" drivers, which presumably indicates the proprietary driver and not the open source one. You need to recompile the kernel with agpgart off - this is in the install instructions on ATI's web site. I ran into a similar problem on a machine I just configured yesterday - recompiling the kernel (AGAIN) with that option disabled resulted in a reduction of CPU utilization AND a tenfold(!) increase in FPS when running glxgears.
 
Old 10-19-2005, 05:45 PM   #3
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
You got your FPS to increase by 10 thousand times!? That is REALLY impressive... I can even get my ATI card to have 3d acceleration, how did you do that part?

And as a newbie, how do I recompile the kernel with agpart off?
 
Old 10-19-2005, 07:37 PM   #4
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
tenfold = 10 times

Went from 300fps to over 3,000fps.

As far as the basics on recompiling the kernel are concerned, use the search link above.

Regarding AGPGART:

Run menuconfig (see the many various existing threads covering kernel compiling) and go to:

Code:
Device Drivers -> Character Devices -> /dev/agpgart (AGP Support) -> < >   ATI Radeon
Make sure that ATI Radeon does NOT have "M" or "*" in it; it should be blank.

Last edited by KimVette; 10-19-2005 at 07:41 PM.
 
Old 10-19-2005, 11:12 PM   #5
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Definitionally fold means 1000 times. I know common usage has kind of forgotten that, but call me a traditionalist. So 10 fold, is 10,000 times.

I will look into recompiling the kernel and agpgart, but I will have to wait till the weekend when I have some more time.

Will this agpgart get the 3d acceleration working as well? Is that the hidden trick?
 
Old 10-20-2005, 08:44 AM   #6
CUCPSC_Geek
LQ Newbie
 
Registered: Sep 2005
Location: South Carolina
Distribution: SuSE 9.3
Posts: 8

Original Poster
Rep: Reputation: 0
I recompiled the kernel last night...and nothing really changed. My FPS increased a little bit, but overall it was still slow. I honestly think it's just the kernel itself. I downloaded a vanilla kernel from kernel.org, and spent some time getting it to work...and bam, it's back to being lightning fast, no more dragginess, and once again I am pleased.

Thanks for the help though, I wish it would have been that easy.
 
Old 10-20-2005, 10:57 AM   #7
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
2 entries found for tenfold.

tenfold

\Ten"fold`\, a. & adv. In tens; consisting of ten in one; ten times repeated.

The grisly Terror . . . grew tenfold More dreadful and deform. --Milton.

Source: Webster's Revised Unabridged Dictionary, 1996, 1998 MICRA, Inc.

tenfold

adj : containing ten or ten parts [syn: denary] adv : by ten times as much; "the population increased tenfold"
 
Old 10-24-2005, 10:44 PM   #8
glussier
Member
 
Registered: Jul 2005
Location: Montreal, Qc, Canada
Distribution: Fedora Core 5/6 Slackware 10.1/11
Posts: 120

Rep: Reputation: 15
Quote:
Originally posted by CUCPSC_Geek
I recompiled the kernel last night...and nothing really changed. My FPS increased a little bit, but overall it was still slow. I honestly think it's just the kernel itself. I downloaded a vanilla kernel from kernel.org, and spent some time getting it to work...and bam, it's back to being lightning fast, no more dragginess, and once again I am pleased.

Thanks for the help though, I wish it would have been that easy.
You didn't have to recompile your kernel. The reason 3d is not working for you is that you may have forgotten to enable posix memory in the /etc/fstab. To do this add the line tmpfs /dev/shm tmpfs defaults 0 0 in the /etc/fstab file.
 
Old 10-26-2005, 08:48 AM   #9
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
I added that line, exactly as you wrote it, to my fstab.

It did nothing at all, I still have no 3d acceleration.
 
Old 10-26-2005, 10:05 AM   #10
CUCPSC_Geek
LQ Newbie
 
Registered: Sep 2005
Location: South Carolina
Distribution: SuSE 9.3
Posts: 8

Original Poster
Rep: Reputation: 0
Mine already that enabled, as I thought that was the problem. I had 3D working with no problems on the default kernel, but it was slower than should have been. For instance in glxgears, I was getting only around 1800FPS.

Once I switched to the vanilla kernel, pulled my optimizations, and enabled 3D....I'm getting my usual 3500-4000FPS.
 
Old 10-26-2005, 10:28 AM   #11
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
If it improves speed so massively in general too, maybe I will try going to a vanilla kernel too, which one did you go to that works so cleanly? And you mentioned you had some issues that took overcoming, anything that wasn't too intuitively obvious to a newb like me? Just following instructions from somewhere?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
alsa and kernel upgrades linuxhippy Slackware 7 04-06-2005 07:03 PM
Question about Suse Upgrades Paul Fox Suse/Novell 1 11-28-2004 05:30 AM
SUSE Linux, kernel upgrades and VT8237 chipsets... Sslaxx Suse/Novell 0 11-10-2004 06:17 AM
SuSE upgrades James McGee Linux - Software 2 08-21-2004 06:44 PM
Kernel upgrades... Pyroknight Linux - General 4 02-07-2003 01:38 PM


All times are GMT -5. The time now is 09:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration