LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 04-14-2005, 09:47 AM   #1
asamma
LQ Newbie
 
Registered: Apr 2005
Posts: 7

Rep: Reputation: 0
kernel update in suse 9.2


hello everybody!
i am new to linux. i have installed suse 9.2
some time ago i tried to use apt-synaptic to update programs, because i saw that yast didn't update many of them (for example from kde 3.3 to 3.4). using synaptic also updated the kernel (i marked all updates). after that i couldn't boot: kernel panic.
for that time i installed all again. i tried again because i wasn't sure of what was happening. same thing but this time i found out how to boot starting from the installation dvd (run installed version), and i downgraded everthing. it worked. so i started to look in the web for similar problems and i found the mk_initrd thing.
but continuing readin i understood (wrong?) that yast2 runs it automatically.
so i used synaptic only to download the packages and after i installed them with yast2. it ran suseconfig but it all happened again!! kernel panic....
so, does suseconfig (or anyway yast2) run mk_initrd? is this the problem?
thanks!

 
Old 04-14-2005, 10:46 AM   #2
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
what is the error you are getting?
 
Old 04-14-2005, 10:51 AM   #3
asamma
LQ Newbie
 
Registered: Apr 2005
Posts: 7

Original Poster
Rep: Reputation: 0
i can tell the exact message when i get back home in a couple of hourse but it's almost this:
kernel panic
can't resync .....
try to kill init

so, usually yast2 should run the mkinitrd for me?
thanx
 
Old 04-14-2005, 01:48 PM   #4
asamma
LQ Newbie
 
Registered: Apr 2005
Posts: 7

Original Poster
Rep: Reputation: 0
ok, here's the error:
/bin/udev_volume_id: notfound
:= notfound

umount2:device or resource is busy
kernel panic - not syncing: attempted to kill init!

i ran the installed system starting from the installation dvd and did from the terminal (as root) mkinitrd.
no errors, but as i rebooted i got the same problem.

what can i try still?
thank you
 
Old 04-14-2005, 10:45 PM   #5
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
what you can try?
well, get vanilla, add FS and hard disk info to the kernel and ignore initrd completely (remove initrd info from GRUB/LILO). It looks like SuSE has some problems (you are not the only one, people complains about this issue).
 
Old 04-15-2005, 03:01 AM   #6
asamma
LQ Newbie
 
Registered: Apr 2005
Posts: 7

Original Poster
Rep: Reputation: 0
hi,
it seems we are in different time zones..i'm in italy.
sorry, but to me vanilla FS and putting hard disk information to the kernel means almost nothing, i'm new to linux!
thanks
bye!
 
Old 04-15-2005, 11:07 AM   #7
tumbelo
Member
 
Registered: Mar 2005
Distribution: Suse 9.3, Kubuntu Hoary, Slackware 10.1
Posts: 66

Rep: Reputation: 15
I almost killed my system trying to compile a new kernel (yes, I kept my old one but somehow it got crippled in the action, too) and I got the exact same message except for this:

umount2:device or resource is busy

But remove initrd from GRUB, you say? I assume you meant removing the line in bold. Correct me if I'm mistaken. Doesn't that stop the whole loading of kernel, making it irrelevant if the FS support is built-in? At least it did when I played with the settings.

###Don't change this comment - YaST2 identifier: Original name: linux###
title SUSE LINUX 9.2
kernel (hd0,3)/boot/vmlinuz root=/dev/hda4 vga=0x31a selinux=0 splash=silent resume=/dev/hda3 desktop elevator=as showopts
initrd (hd0,3)/boot/initrd
 
Old 04-15-2005, 01:02 PM   #8
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
The only point to use initrd is to allow loading modules (FS or SCSI) before actuall kernel will boot.
To load modules you need to boot kernel first. In case of SCSI or FS you will need these first and that is why you need initrd. If you build FS and disk into kernel, there is no need for initrd (with exception of splash)
I don't have it, even I removed it from kernel options, but FS and disk is in the kernel. It boots fine.

So to you need to make changes before you will remove initrd.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
update kernel in suse 9.2 asamma Linux - Newbie 3 04-15-2005 04:02 PM
update kernel in Suse 9.2? raynet Suse/Novell 1 03-01-2005 10:01 PM
How to Update Kernel in SuSE 9.1 Spradlin Suse/Novell 3 12-25-2004 05:45 PM
kernel update for SuSE 9.0 thk33 Linux - Software 5 11-15-2004 05:19 AM
How to update kernel on SuSE 8.2? THX1138 Linux - Software 4 02-15-2004 12:56 AM


All times are GMT -5. The time now is 09:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration