LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 11-29-2005, 04:39 PM   #1
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Rep: Reputation: 30
KDE3.5 Upgrade kdebindings-python dependency errors - FIXED


I wanted to know if anyone else received these errors?

#### YaST2 conflicts list - generated 2005-11-29 13:33:32 ####

kdebindings3-python 3.5.0-7 conflict
Unresolved Requirements:
kdebindings3-python requires python-qt = 3.5.0-7
Conflict Resolution:
( ) Do Not Update kdebindings3-python
( ) Ignore Conflict and Risk System Inconsistencies
python-qt not available
Required by:
kdebindings3-python requires python-qt = 3.5.0-7
Conflict Resolution:
( ) Remove All 2 Referring Packages
Delete kdebindings3-python
Delete hplip
( ) Ignore Conflict and Risk System Inconsistencies

#### YaST2 conflicts list END ###


I am not sure, but I would imagine the python package would include python-qt = 3.5.0-7 in the package if it was needed.

Or is it being caused by hplip which is the HP Printing and Scanning software.

Should I just ignore? I have all other parts of 3.5 installed.

Last edited by EclipseAgent; 12-01-2005 at 12:46 PM.
 
Old 11-29-2005, 05:26 PM   #2
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Ok, so I un-installed hplip, and that seemed to actually un-install kdebindings3-python.

Currently I am installing kdebindings3 and will then try to see if I can install kdebindings3-python

If not, then I will try to re-install the hplip and if not.. i'll just figure it out later, or if any one has also received this dependency error.

I am still baffled by it, because the kdebindings3-python for KDE 3.5RC1 installed fine, but it did not have the required python-qt portion, so hopefully that is in the kdebindings3 package.
 
Old 11-29-2005, 05:40 PM   #3
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Ok, verified that it is the hplip package that causes the error.

Next question.. what are the kdebinding3 packages for?

Yeah yeah, i'll google it.
 
Old 11-29-2005, 06:08 PM   #4
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Ok, for anyone following this, I have to revert back, I installed the kdebindings3-python package, ignoring errors, but I was unable to run the superkaramba configure theme because it said I needed PyQT (guess the PyQT from the 3.5.0-7 package didn't install correctly).

What a pain in the ass..

So I am going to install hplip and kdebindings3 from the SuSE 10 cd and see if it will then let me upgrade (since I did do some supplementary upgrades of KDE).
 
Old 11-29-2005, 07:12 PM   #5
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Ok, so I was able to get kdebindings3-python to work, I had to remove uplip, and kdebindings3-python (current version installed, 3.5.0-rc1 or something).

But when I tried to configure the theme in the Aero AIO SuperKaramba it said I needed PyQt which is supposed to be a part of the kdebindings3-python package.

Can anyone help? I just removed hplip and kdebindings3-python again..
 
Old 11-30-2005, 01:37 AM   #6
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
I know no one is reading this, but this is how I had to fix it.

I downgraded kdebindings3-python to 3.4.2-8
and qscintilla to 1.61-5 both from the SuSE 10 CD.

If you check the change log for kdebindings3-python you will see that on Nov 24th they split the python-qt from the package, so why is it still required for the install? and how can you get it?

Now I can actually configure my Aero AIO theme in SuperKaramba (woohoo)

Last edited by EclipseAgent; 11-30-2005 at 01:38 AM.
 
Old 11-30-2005, 09:34 AM   #7
rgbrock1
Member
 
Registered: Sep 2004
Location: Connecticut
Distribution: SUSE 10, Mandriva
Posts: 70

Rep: Reputation: 15
EclipseAgent:

Great tutorial which you obviously figured out on your own, no thanks to anyone on this forum. So, can you give a brief overview on what you did to upgrade to KDE v3.5?
Thanks.
 
Old 11-30-2005, 10:42 AM   #8
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by rgbrock1
EclipseAgent:

Great tutorial which you obviously figured out on your own, no thanks to anyone on this forum. So, can you give a brief overview on what you did to upgrade to KDE v3.5?
Thanks.
Thanks rgbrock1,

I didn't think anyone read this, I was using it more as a notebook to revert what i've changed (bwahahha, jk, that just made me feel better about no replies).

I did however see that the kdebindings3-python package was upgraded to 3.5.0-8 from 3.5.0-7 yesterday, but have not yet tried to see if the python-qt has been removed from required or if it works at all.

Currently I have kdebindings3-python 3.4.2-8 and have upgraded everything for KDE to 3.5.0- except the bindings package.

I did all the installs using YaST, and also tried to python package via the RPM and still a no-go.

Now to try to upgrade FROM 3.4.2 to 3.5.0-8 instead of 3.5.0-rc1 to 3.5.0-8 since the RC1 package did not need the python-qt.
 
Old 11-30-2005, 01:23 PM   #9
pilotgi
Member
 
Registered: Apr 2002
Location: ks
Distribution: openSUSE 12.2 64 bit
Posts: 488

Rep: Reputation: 32
I read your thread too. I got the same error about python-qt. I currently have kdebindings3-python-3.5.0-5 installed which is from a few days ago when 3.5 was still a release candidate. The newest version from the gold release is 3.5.0-8 and is identical to 3.5.0-5 until you get to several qt.so files that are missing in the newest version. I don't know if this is a mistake that will be fixed shortly or if they did it on purpose. These things can happen when you're one of the first adopters, you animal.

I just selected "don't upgrade" for the kdebindings3-python package and left it at version 3.5.0-5. I haven't done anything with superkaramba so I don't know if I have the same problems as you. So far, everything with KDE 3.5 is working fine for me but I'm going to keep checking the mirrors for the next week or so to see if the kdebindings package is upgraded/fixed.

Edit: I just reread the last line from you post above and wanted to point out that it isn't that the release candidate didn't need python-qt. The problem is the final version (3.5.0-8) is missing the qt files, which is why you got the dependency error.

Last edited by pilotgi; 11-30-2005 at 01:28 PM.
 
Old 11-30-2005, 01:28 PM   #10
mewt
LQ Newbie
 
Registered: Mar 2005
Distribution: Fedora Core 4
Posts: 28

Rep: Reputation: 15
Isnt there an rpm for python-qt package since i uninstalled it while trying to upgrade to kde 3.5 and now superkaramba wont work but i cant find a way to install python-qt >3.5.something

thanks
 
Old 11-30-2005, 02:04 PM   #11
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by mewt
Isnt there an rpm for python-qt package since i uninstalled it while trying to upgrade to kde 3.5 and now superkaramba wont work but i cant find a way to install python-qt >3.5.something

thanks
The reason you can't find it is because if you check the change log of kdepython3-python you will see after the RC1 release, on Nov 24th you will see that they stripped python-qt although it is still marked as "required" in the dependincies.

As for being able to use SuperKaramba again, you need to remove kdebindings3-python,

remove the hplip (if installed) then go to installation sources and disable the KDE 3.5 Supp source and enable the SuSE 10 cd source (if disabled like I had mine).

Install the kdebindings3-python 3.4.2-8 from the SuSE CD, it may ask you to downgrade another package, go ahead and say yes.

Once done, you can use your SuperKaramba again since PyQT is back (also if you read the 3.5.0-8 check where it says obsoletes, for some reason it says it obsoletes PyQt, PyKDE and a few others).
 
Old 11-30-2005, 06:10 PM   #12
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by pilotgi
Edit: I just reread the last line from you post above and wanted to point out that it isn't that the release candidate didn't need python-qt. The problem is the final version (3.5.0-8) is missing the qt files, which is why you got the dependency error.
Intrested you say that, because I too noticed the missing files, BUT if you check the "required" in 3.5.0-5 and 3.5.0-8 you will notice that under the "required" section 3.5.0-5 did not require any version of python-qt
 
Old 12-01-2005, 11:33 AM   #13
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
ok, I know everyone is sick of me now. But the problem is with the SuSE RPM Package and not kdebindings3-python

Just to let you all know. I am going to try to email novell and tell them about the problem, then also try to find a working package, either from source or RPM.
 
Old 12-01-2005, 12:47 PM   #14
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
Again, to all that are following this, I just got this back from the Novell Bugzilla:

coolo@suse.de changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEW |RESOLVED
Resolution| |FIXED

------- Comment #1 from coolo@suse.de 2005-12-01 10:44 MST -------
the package will be synced out later.

Woohoo, they fixed the package and will be avaliable for sync from YaST later.
 
Old 12-02-2005, 10:47 AM   #15
EclipseAgent
Member
 
Registered: Oct 2005
Location: California
Distribution: SLED 10, openSuSE 10.2, Ubuntu Drapper
Posts: 713

Original Poster
Rep: Reputation: 30
I checked today and Novell has updated the package for python-qt, kdebindings3-python and qscintilla.

Woohoo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kde3.4 exit errors davidsrsb Slackware 2 04-24-2005 03:43 AM
Python dependency problem in SuSE 9.1? oxbloodoi Linux - Newbie 2 10-19-2004 10:55 PM
gDesklets Python dependency issues aresnomad Linux - Newbie 2 06-28-2004 07:16 PM
Swaret upgrade from 9.1 to 10 dependency errors zez Linux - Software 0 06-28-2004 12:41 AM
kde2 to kde3 on mandrake rpm dependency problems antken Linux - General 4 01-02-2003 08:25 AM


All times are GMT -5. The time now is 06:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration