LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 07-28-2005, 04:08 PM   #1
oily_rags
Member
 
Registered: Sep 2004
Posts: 128

Rep: Reputation: 15
kde no longer loading with user account


Hello, i'm having a problem where my regular user account will no load into kde, unless I do failsafe and type start kde from the failsafe console. After that kde loads normally and seems to work fine, other than the fact that if I close the failsafe window kde dies. This problem has happened last week, to get around it I created a new user account, now it has returned with my new user account. I don't know what to do from here. Inn the xsessions-errors file I see this output


/etc/X11/xim: Checking wether an input method should be started.
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale en_US.UTF-8 ...
There is no default input method for the current locale.
startkde: Starting up...
kbuildsycoca running...
kdecore (KLibLoader): WARNING: KLibrary: /opt/kde3/lib/kde3/kcm_kdnssd.so: undefined symbol: init_kdnssd
libhal.c 911 : Error sending msg: No property info.category on device with id /org/freedesktop/Hal/devices/ide_0_0
libhal.c 911 : Error sending msg: No property info.category on device with id /org/freedesktop/Hal/devices/ide_0_0
libhal.c 1205 : Error sending msg: No property volume.disc.has_audio on device with id /org/freedesktop/Hal/devices/block_3_3
libhal.c 911 : Error sending msg: No property info.category on device with id /org/freedesktop/Hal/devices/ide_1_0
kdecore (KLibLoader): WARNING: KLibrary: /opt/kde3/lib/kde3/kpfpropertiesdialog.so: undefined symbol: init_kpfpropertiesdialog
kdecore (KLibLoader): WARNING: The library kpfpropertiesdialog does not offer an init_kpfpropertiesdialog function.
kio (KIOConnection): ERROR: Could not write data
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
kio (KIOConnection): ERROR: Header read failed, errno=104
kio (KIOConnection): ERROR: Header has invalid size (-1)
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 7
Minor opcode: 0
Resource id: 0x1c00007
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 6
Minor opcode: 0
Resource id: 0x1c00007
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 7
Minor opcode: 0
Resource id: 0x1e00007
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 6
Minor opcode: 0
Resource id: 0x1e00007
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 7
Minor opcode: 0
Resource id: 0x2200013
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 6
Minor opcode: 0
Resource id: 0x2200013
ksmserver: WARNING: SmsDie timeout, client kmix(10d0e2686c000112198711200000068440016)
startkde: Shutting down...
klauncher: Exiting on signal 1
KWrited - Listening on Device /dev/pts/0
startkde: Running shutdown scripts...
startkde: Done.


Any help would be appreciated, thanks in advance
 
Old 07-28-2005, 05:00 PM   #2
oily_rags
Member
 
Registered: Sep 2004
Posts: 128

Original Poster
Rep: Reputation: 15
I should add that i'm using suse 9.3, I don't know if this makes a difference but I am using a /boot partition for my hard drive. I mention it because before I reinstalled suse recently I didn't use one, the new drive I bought was much larger and the full size could not be read by my bios, so I use a /boot partition. This problem never occured when I had suse 9.3 running on my old hard drive.
 
Old 07-28-2005, 07:59 PM   #3
oily_rags
Member
 
Registered: Sep 2004
Posts: 128

Original Poster
Rep: Reputation: 15
I will add further that not only kde is affected, other desktop environments won't start either. It feels like the process that starts the desktop is not working, I have to go in failsafe and do start kde. I asked many people and googled the problem but still could not come up with an explanation. Again, if anyone has any ideas it will be greately appreciated. Thanks
 
Old 08-20-2005, 01:52 AM   #4
dnadave
LQ Newbie
 
Registered: Aug 2005
Location: Seattle
Posts: 3

Rep: Reputation: 0
I'm having the same problem. Logged in OK at work this morning. Used YAST on my SuSE 9.3 laptop to install some version control software. Logged out and went home. Saw the normal login screen when I booted up at the house and then saw my kde background with an xterm in the corner. Nothing else...

My default login starts up no console, or konsole, or xterm. I have checked all of the kdm, xdm, X* files and none have been modified today. I'm at my wits end trying to figure out who or what screwed up my laptop (and wring their neck when I do).

ANYONE have ANY ideas??!!??

Dave H
 
Old 08-20-2005, 07:45 PM   #5
oily_rags
Member
 
Registered: Sep 2004
Posts: 128

Original Poster
Rep: Reputation: 15
Hey dnadave it's good to finally hear from someone with the same problem, I think we have run into a problem that affects like 1 in 1000 users or something. I asked here, I asked many times on irc.freenode.com on the channel #suse and #linux and #kde for help, but nobody seems able to help or explain why this happened. I sorta gave up and just log into kde through the failsafe console now, I don't mind but it would be nice to resolve this problem. Everyone seems clueless.
 
Old 08-25-2005, 07:05 PM   #6
CBIHP
LQ Newbie
 
Registered: Aug 2005
Posts: 3

Rep: Reputation: 0
Looks like I'm having the same problem... I'm also a Linux newbie

I completed a SuSE 9.3 installation yesterday (DELL Precision 360, Dual-boot (XP/SuSE)). Mainly I've been logged in as root getting the system configured. Set up the display successfully; was setting up the network. All was fine until I restarted (gracefully) the computer. After that I lost the GUI for both my root and user login.

My .xsessions-errors file has the same complaint:

/etc/X11/xim: Checking wether an input method should be started.
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale en_US.UTF-8 ...
There is no default input method for the current locale.
 
Old 08-27-2005, 07:39 PM   #7
jamie1911
LQ Newbie
 
Registered: Aug 2005
Distribution: slackware
Posts: 2

Rep: Reputation: 0
you might want to try and log in safe mode and use console to point to /etc/sysconfig/windowmanager. edit the file and see if the DEFAULT_WM="kde"
also view the /etc/sysconfig/displaymanager and make sure DISPLAYMANGER="kdm"
now keep in mind this is for KDE if you want gnome it tells you in the config file which one to chose.


-----------EXAMPLE windowmanager config---------------------
# Here you can set the default window manager (kde, fvwm, ...)
# changes here require at least a re-login
DEFAULT_WM="kde"

-----------EXAMPLE displaymanger config--------------------------------------
# Here you can set the default Display manager (kdm/xdm/gdm/wdm/console).
# all changes in this file require a restart of the displaymanager
#
DISPLAYMANAGER="kdm"
 
Old 08-27-2005, 08:33 PM   #8
oily_rags
Member
 
Registered: Sep 2004
Posts: 128

Original Poster
Rep: Reputation: 15
Hello Jamie1911

I checked your suggestion and kde was already set as the default window manager, so that's not the problem. Thanks though.
 
Old 08-29-2005, 12:59 PM   #9
CBIHP
LQ Newbie
 
Registered: Aug 2005
Posts: 3

Rep: Reputation: 0
On Friday I let the installation CD's walk me through a system repair. It found some files it didn't like (sorry, I didn't note which they were). I let it do it's thing but the GUI still wouldn't start.

Today, Jamie1911's suggestion restored my GUI. Note: DEAFULT_WM was set to "twm". DISPLAYMANAGER wa set to "wdm"

Thanks!!!
 
Old 08-29-2005, 10:15 PM   #10
jamie1911
LQ Newbie
 
Registered: Aug 2005
Distribution: slackware
Posts: 2

Rep: Reputation: 0
It looks as if something maybe is wrong with your X Config, maybe wrong video driver, try typing
SaX2 in the console of safemode or regular to see if you can change your video settings to something different.
 
Old 09-01-2005, 03:03 AM   #11
twitch89
LQ Newbie
 
Registered: Jul 2005
Distribution: suse 9.3
Posts: 6

Rep: Reputation: 0
same problem here too... getting a bit annoying and i kinda don't want to format since i only just installed... any help will be muchly apreciated!

happened to me when i restarted after installing a few new themes for kde

Last edited by twitch89; 09-01-2005 at 03:08 AM.
 
Old 09-01-2005, 08:52 PM   #12
dreakon
Member
 
Registered: Nov 2004
Posts: 101

Rep: Reputation: 15
1 in 1000 users my arse, it seems that this issue is actually quite common. It happened to me like 5 times already, Ive given up reinstalling suse I just grit my teeth and deal with it now. I noticed it happens shortly after installing my NVidia Driver. I too would really like a solution, or at least know what Im doing to screw up my system. I dont know about anyone else but it also affects my ability to halt my system from KDE, I have to end session and then halt.
 
Old 09-02-2005, 08:20 AM   #13
adriaticnyc
LQ Newbie
 
Registered: Jul 2004
Location: NYC
Distribution: Red Hat Linux Professional Version 9 & Red Hat Linux ES Workstation 3
Posts: 2

Rep: Reputation: 0
My experience with SuSE 9.3 Pro is exactly behaving the same way - boot up, signin and then I have to manipulate xTERM to get into KDE.

I am not updating 9.3 Pro on my Compaq EVO D510U desktop! 9.2 is still acting normally here.

I am running 9.3 Pro (one of the early installers in April 2005) on a Compaq EVO N800V notebook running with 1GB RAM and a 60GB partitioned Hitachi 7200 RPM hard drive with 8MB Bufferspace.

I wonder what the Novell site would say about this?

Has anybody configured a script that automatically configures past xTERM and gets into KDE?

Mary W in NYC
adriaticnyc
adriaticnyc@yahoo.com
 
Old 09-05-2005, 03:11 PM   #14
oily_rags
Member
 
Registered: Sep 2004
Posts: 128

Original Poster
Rep: Reputation: 15
Well, I think I finally found an answer, someone pointed me to this website http://forums.suselinuxsupport.de/lo...hp/t15219.html and it clearly fits the problem I was having. Basically ymessenger is the sorce of this problem as it contains a bug! I never expected ymessenger to be at fault but this guys symptoms exactly mirror mine.
 
Old 09-05-2005, 03:27 PM   #15
oily_rags
Member
 
Registered: Sep 2004
Posts: 128

Original Poster
Rep: Reputation: 15
ok this problem is CONFIRMED FIXED! I removed ymessenger from my system and deleted the .xinitrc file from my user account home directory and now everything runs perfectly! I no longer need to use failsafe mode to get in.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
system account or user account??? yenonn Linux - Newbie 6 05-10-2006 08:49 PM
can't login my user account/KDE from boot MI3GTO Mandriva 1 02-27-2005 04:11 PM
How to setup KDE 3.3 with user account digiplaya Linux - Software 3 08-31-2004 06:49 PM
Can no longer start kde as a normal user J_Szucs Linux - Software 4 03-15-2004 09:04 AM
Normal user account cannot start KDE tagit Linux - Newbie 2 12-22-2003 05:36 PM


All times are GMT -5. The time now is 03:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration