LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 05-05-2007, 10:36 AM   #1
jdmcdaniel3
Member
 
Registered: Jan 2006
Location: Austin
Distribution: openSUSE 11.2
Posts: 167

Rep: Reputation: 31
Lightbulb KDE Error "Conversation with su failed" SuSE 10.2 Fix


The other day I upgraded my kernel software and after the upgrade I had a new problem. For some reason I was unable to run Yast2 or konqueror using the --profile filemanagement option, both of which require you enter the root password. I downgraded the kernel back to my orginal version, but the problem still was present. When you would enter your root password in KDE, which uses KDESU as I understand it, you would get an error that read "Conversation with su failed" and the command would not work. I searched the net high and low and finally found the following fix.

You need to edit the file /opt/kde3/share/config/kdeglobals as a root user and add the following line at the end of the file and save it:

[super-user-command]
super-user-command=su

Once I added these two lines, all was back to normal. I would like to know if anyone else has had the same error message "Conversation with su failed" when using KDE and what you did to fix the problem.

Thank You,
 
Old 05-08-2007, 05:02 AM   #2
mista2
LQ Newbie
 
Registered: Oct 2005
Location: Wellington New Zealand
Distribution: SuSe Linux 9.3 pro and SLES9
Posts: 2

Rep: Reputation: 0
Login with kdesu failed

Quote:
Originally Posted by jdmcdaniel3
The other day I upgraded my kernel software and after the upgrade I had a new problem. For some reason I was unable to run Yast2 or konqueror using the --profile filemanagement option, both of which require you enter the root password. I downgraded the kernel back to my orginal version, but the problem still was present. When you would enter your root password in KDE, which uses KDESU as I understand it, you would get an error that read "Conversation with su failed" and the command would not work. I searched the net high and low and finally found the following fix.

You need to edit the file /opt/kde3/share/config/kdeglobals as a root user and add the following line at the end of the file and save it:

[super-user-command]
super-user-command=su

Once I added these two lines, all was back to normal. I would like to know if anyone else has had the same error message "Conversation with su failed" when using KDE and what you did to fix the problem.

Thank You,
Thanks, this worked a charm for me too. Mine broke when I used yast to edit the sudo config to set a couple of commands to act more like ubuntu, to use my users password rather than root for mounting remote shares. I removed my changes using yast, but the problem did not go away. The sudoers file looked OK too so I was stumped as to why it wasn't working. Annoying as I was just trying to show a fellow Windows admin why sudo was better than vista's UAC (much more flexible).
 
Old 05-09-2007, 07:45 AM   #3
cormack
Member
 
Registered: Oct 2005
Location: Scotland, UK
Distribution: Kubuntu 9.10, ubuntu 8.04.2 server
Posts: 156

Rep: Reputation: 30
^^ Thanks, it happened on my desktop, and didnt have time to research it so i just reinstalled. I didnt do any kernel updates or anything though, so does anyone have any ideas of what caused this? Its not happened on my friends desktop or my server yet. So is it just a matter of time?

Thanks
ryan
 
Old 05-10-2007, 12:55 AM   #4
vonneagut
LQ Newbie
 
Registered: May 2007
Posts: 1

Rep: Reputation: 0
Thumbs up same old problem i guess.

thanks for the info, kdeglobals worked like a charm. was quite painful logging in as root every time i needed to use yast.
 
Old 05-24-2007, 06:20 AM   #5
hcgrant
Member
 
Registered: Feb 2004
Location: UK Hertfordshire
Distribution: Opensuse 12.2 plus Macs and a Vista and two little RaspberryPi
Posts: 44

Rep: Reputation: 15
Smile

Thanks James
I got pointed to your good work by mmn357157
My problem was v.sim .. see http://www.linuxquestions.org/questi....php?p=2761387
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FIX: wine error "No Program Start Menu Found" JackSmith Linux - Games 3 07-02-2009 10:38 PM
Fatal error @ "fopen(stage1.c:383) failed: ) I/O error". Tripitaka Linux - Newbie 7 02-05-2006 05:50 AM
Disable or fix "Switch User" in KDE? whysyn Linux - Software 1 01-06-2006 04:03 PM
Suse 9.2 -KDE boot error "re: io-slave" jtheb Suse/Novell 3 02-22-2005 10:47 PM
How do I fix a "Grub read error"?? Tiyogi Linux - Newbie 1 06-02-2004 08:55 AM


All times are GMT -5. The time now is 11:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration