LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 08-20-2005, 12:42 PM   #1
EchoWarrior
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Gentoo 2006.0, Debian 3.1r0
Posts: 60

Rep: Reputation: 15
ISO mounting problems..


Hi there

Im trying to mount .iso file to Linux. I use command
mount -t iso9660 -o loop /home/echowarrior/StarCraft/Starcraft.iso /mnt/iso

But I get
mount: wrong fs type, bad option, bad superblock on /dev/loop0,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Is there something wrong on my command or what?

Thanks for everyone who answers
 
Old 08-20-2005, 12:44 PM   #2
PenguinPwrdBox
Member
 
Registered: Oct 2003
Location: /illinois/chicago
Distribution: Slackware/Gentoo/FC/RHEL
Posts: 568

Rep: Reputation: 30
do not use -t iso9660.

Simply:

mount -o loop /home/echowarrior/StarCraft/Starcraft.iso /mnt/iso
 
Old 08-20-2005, 12:45 PM   #3
EchoWarrior
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Gentoo 2006.0, Debian 3.1r0
Posts: 60

Original Poster
Rep: Reputation: 15
It says now
mount: you must specify the filesystem type
 
Old 08-20-2005, 12:48 PM   #4
PenguinPwrdBox
Member
 
Registered: Oct 2003
Location: /illinois/chicago
Distribution: Slackware/Gentoo/FC/RHEL
Posts: 568

Rep: Reputation: 30
Odd.
Try:
mount -t auto /home/echowarrior/StarCraft/StarCraft.iso /mnt/iso -o loop
 
Old 08-20-2005, 12:49 PM   #5
EchoWarrior
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Gentoo 2006.0, Debian 3.1r0
Posts: 60

Original Poster
Rep: Reputation: 15
Hmmh... It still says that i must specify a filesystem type..
 
Old 08-20-2005, 12:53 PM   #6
PenguinPwrdBox
Member
 
Registered: Oct 2003
Location: /illinois/chicago
Distribution: Slackware/Gentoo/FC/RHEL
Posts: 568

Rep: Reputation: 30
What do you get when you run:
file /home/echwarrior/StarCraft/StarCraft.iso
?
 
Old 08-20-2005, 12:54 PM   #7
EchoWarrior
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Gentoo 2006.0, Debian 3.1r0
Posts: 60

Original Poster
Rep: Reputation: 15
What you mean run? In console with ./Starcraft.iso or what?
 
Old 08-20-2005, 12:58 PM   #8
EchoWarrior
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Gentoo 2006.0, Debian 3.1r0
Posts: 60

Original Poster
Rep: Reputation: 15
When I run it from Konqueror, it opens in k3b wich says it isn't usable image.. I have converted it from img to iso
 
Old 08-20-2005, 12:59 PM   #9
PenguinPwrdBox
Member
 
Registered: Oct 2003
Location: /illinois/chicago
Distribution: Slackware/Gentoo/FC/RHEL
Posts: 568

Rep: Reputation: 30
I would say you have a bad .iso.
when I mean run - what happens when you type that command in a terminal?

Why not just mount -o loop the .img file?
 
Old 08-20-2005, 01:04 PM   #10
EchoWarrior
Member
 
Registered: Aug 2005
Location: Finland
Distribution: Gentoo 2006.0, Debian 3.1r0
Posts: 60

Original Poster
Rep: Reputation: 15
Yeah. It is just bad image because I can mount my Kylix 3.0 image...

Well thank you anyway
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems mounting an image .iso kroy Linux - Software 5 04-11-2005 10:15 AM
Gentoo. Problems with the loop device when mounting an iso file Snerkel Linux - Software 4 11-26-2004 03:34 PM
Gentoo. Problems mounting an iso file Snerkel Linux - Distributions 2 11-26-2004 03:32 PM
problems mounting and unmounting iso images. Snerkel Linux - Software 5 08-21-2004 06:57 PM
having problems when mounting an iso on the hard drive k0ljat Linux - Software 2 05-17-2003 01:08 AM


All times are GMT -5. The time now is 07:46 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration