LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 08-12-2007, 05:25 PM   #1
DoctorWynn
Member
 
Registered: Nov 2005
Distribution: OpenSuSe 10.1
Posts: 63

Rep: Reputation: 15
Internet connection via router & cable modem


Ok, I've had this problem before, but I can't find any info on it after hours of searching. When I installed Suse 10.2, my internet connection no longer worked. Someone told me a simple fix, which I can not for the life of me remember. Now I've upgraded (fresh install) to 10.3 beta 1, and am having the exact problem again.

I have a cable modem, connected to my wireless router, and my PC is connected directly to the router. I can't get online. Not even to my router which is 192.168.2.1.

If I remember right, it seems like it was a permissions setting that had to be changed in the new Suse 10.1 (since 10.0), but I can't be sure.

I understand there are many things one can do to try this, and try that, and check this or that, but as mentioned, it was an easy fix, and I'm hoping somebody knows what that is, cuz it's driving me f'n nuts!!

Anyone? Thanx!
 
Old 08-12-2007, 05:59 PM   #2
tjyorkshire
Member
 
Registered: Jun 2007
Location: UK
Distribution: openSUSE 10.2
Posts: 138

Rep: Reputation: 15
A permissions setting? I'm running 10.2 and i don't remember having to do anything like that.

So, I'm guessing you can't even ping the router? I'm also guessing that you are not connecting through wireless?

It might be helpful if you gave the output of the routing table and ifstatus? It may however, be that the NIC hasn't installed properly or you don't have the right drivers

Last edited by tjyorkshire; 08-12-2007 at 06:00 PM.
 
Old 08-12-2007, 06:29 PM   #3
DoctorWynn
Member
 
Registered: Nov 2005
Distribution: OpenSuSe 10.1
Posts: 63

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by tjyorkshire View Post
So, I'm guessing you can't even ping the router? I'm also guessing that you are not connecting through wireless?

It might be helpful if you gave the output of the routing table and ifstatus? It may however, be that the NIC hasn't installed properly or you don't have the right drivers
When I ping a website, "unknown host." When I ping the router, "network unreachable."

And no, not through wireless, connected directly to the router via ethernet cable.

As for the output of ifstatus, I'm assuming you want it from the command, "ifstatus eth0" ? Posting that output will be fun considering I'm not online on my pc. Anything in particular I should be looking for though when I run that command? If I can fix this in kde in anyway, that would be great, as I'm not much for the command line.
 
Old 08-13-2007, 10:08 AM   #4
emg
Member
 
Registered: Apr 2005
Location: Western Mass USA
Distribution: Sabayon 4.2K 64bit
Posts: 107

Rep: Reputation: 15
Quote:
Originally Posted by DoctorWynn View Post
Ok, I've had this problem before, but I can't find any info on it after hours of searching. When I installed Suse 10.2, my internet connection no longer worked. Someone told me a simple fix, which I can not for the life of me remember. Now I've upgraded (fresh install) to 10.3 beta 1, and am having the exact problem again.

I have a cable modem, connected to my wireless router, and my PC is connected directly to the router. I can't get online. Not even to my router which is 192.168.2.1.

If I remember right, it seems like it was a permissions setting that had to be changed in the new Suse 10.1 (since 10.0), but I can't be sure.

I understand there are many things one can do to try this, and try that, and check this or that, but as mentioned, it was an easy fix, and I'm hoping somebody knows what that is, cuz it's driving me f'n nuts!!

Anyone? Thanx!
Try this .. in yast network services > network card .. edit your nic and be sure that activate on boot is set then put in a manual IP for it .. I would say 192.168.2.55 subnet 255.255.255.0 and make sure the gateway is set to 192.168.2.1 (your router IP) also the DNS can/should be set to 192.168.2.1 ... this is in case your router is not setup to give IP's (DHCP server) ... then see if you can get to the internet with it
 
Old 08-13-2007, 01:36 PM   #5
DoctorWynn
Member
 
Registered: Nov 2005
Distribution: OpenSuSe 10.1
Posts: 63

Original Poster
Rep: Reputation: 15
Nope, didn't work. Whatever the problem is, it was a simple fix last time. It happens when I install suse for the first time. I just got a new hard drive, and rather than copy over everything, I installed a new copy of the latest 10.3 version. Now the last time I upgraded to 10.2 from 10.1, the exact same thing happened. Can not connect to the internet. Here is what I have for settings, maybe this will help find the problem...

under network devices>network card, I have it set with...

Network setup method - traditional with ifup
IPv6 - tried both, enabled & disabled (what should it be?)
request broadcast response - unchecked
change hostname via DHCP - checked
write hostname to /etc/hosts - checked
update name servers and search list via DHCP - checked

Then under the settings for the card itself...

dynamic address - DHCP
activate device - at boot time
firewall zone - external zone
kernel module - tulip (when i change this to dmfe, it won't remain. changes back to tulip).


Now, I don't pretend to know what all these things mean, but that is what they're set at. Does it all look right?

I wonder if I connect my pc directly to the cable modem, then reset the modem? If it connects, then connect it to the router? Just grasping at straws. Damn I wish I could remember what fixed it last time. This is driving me nutz. I hate using windoze to get online!!
 
Old 08-13-2007, 01:48 PM   #6
tjyorkshire
Member
 
Registered: Jun 2007
Location: UK
Distribution: openSUSE 10.2
Posts: 138

Rep: Reputation: 15
This all sounds very similar to a problem i had in suse. For some reason it created an odd entry in the routing table. It took me ages to figure out what was wrong (and sounds very much like your problem). However, once i found out what was wrong, all i had to do was a simple change of the routing table and all was fine .

So if you can somehow post the output of route -n, it might be helpful

Last edited by tjyorkshire; 08-13-2007 at 01:49 PM.
 
Old 08-13-2007, 03:52 PM   #7
DoctorWynn
Member
 
Registered: Nov 2005
Distribution: OpenSuSe 10.1
Posts: 63

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by tjyorkshire View Post
This all sounds very similar to a problem i had in suse. For some reason it created an odd entry in the routing table. It took me ages to figure out what was wrong (and sounds very much like your problem). However, once i found out what was wrong, all i had to do was a simple change of the routing table and all was fine .

So if you can somehow post the output of route -n, it might be helpful
I'll do that. I'll do that later today. Thanx!
 
Old 08-14-2007, 08:24 AM   #8
DoctorWynn
Member
 
Registered: Nov 2005
Distribution: OpenSuSe 10.1
Posts: 63

Original Poster
Rep: Reputation: 15
Ok, outputs of a couple commands...

Here is the output of "route -n"

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo


And here is "ifstatus eth0"

eth0 device: Davicom Semiconductor, Inc. 21x4x DEC-Tulip compatible 10/100 Ethernet (rev 40)
eth0 dhcpcd is still waiting for data
eth0 is up
2: eth0: <BROADCAST,MULTICAST,NOTRAILERS,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
link/ether 00:08:a1:a3:49:81 brd ff:ff:ff:ff:ff:ff
inet6 fe80::208:a1ff:fea3:4981/64 scope link
valid_lft forever preferred_lft forever


And what else is odd, when I change the card settings from "traditional method with ifup" to "user controlled," and knetworkmanager loads, it connects. Or at least it seems to. It says connected to wired connection, but still nothing. Can't even load my wireless router in the browser at 192.168.2.1, nor retrieve pop mail with kmail.

Something appears to be blocking me from using the connection. As I've repeated, it was a simple fix, and I've been frying my brain trying to remember what the hell it was with no luck. I know this setup works, as I've been using it for years since opensuse 10.0 with no special modifications. In fact, in those days, it worked without a hitch. Then with every upgrade, I've had to do something to get my connection back BUT WHAT??
 
Old 08-14-2007, 10:23 AM   #9
tjyorkshire
Member
 
Registered: Jun 2007
Location: UK
Distribution: openSUSE 10.2
Posts: 138

Rep: Reputation: 15
It seems as though linux isn't receiving anything from the DHCP server, however, you said that it wouldn't work with a static IP either?
Sorry to be a pain , but could you post the same information when you use a static IP address.
 
Old 08-16-2007, 03:40 PM   #10
DoctorWynn
Member
 
Registered: Nov 2005
Distribution: OpenSuSe 10.1
Posts: 63

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by tjyorkshire View Post
It seems as though linux isn't receiving anything from the DHCP server, however, you said that it wouldn't work with a static IP either?
Sorry to be a pain , but could you post the same information when you use a static IP address.
No pain here, whatever I have to do to get this going. It's driving me nutz using windoze. Here is what I got from route -n after following the static ip instructions above...

Quote:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.2.1 0.0.0.0 UG 0 0 0 eth0
 
Old 08-16-2007, 03:49 PM   #11
tjyorkshire
Member
 
Registered: Jun 2007
Location: UK
Distribution: openSUSE 10.2
Posts: 138

Rep: Reputation: 15
Do:
Code:
route del -net 169.254.0.0 netmask 255.255.0.0 gw 0.0.0.0
Now see if you can ping
 
Old 08-16-2007, 04:07 PM   #12
DoctorWynn
Member
 
Registered: Nov 2005
Distribution: OpenSuSe 10.1
Posts: 63

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by tjyorkshire View Post
Do:
Code:
route del -net 169.254.0.0 netmask 255.255.0.0 gw 0.0.0.0
Now see if you can ping
Do that while setup with the static ip? Or dhcp?

Also, if it means anything, whenever I'm supposedly connected, and I issue "ifstatus eth0" somewhere in there, I see "dhcpdp (sp?) is still waiting for data" meaning to me, I'm not getting my ip address?
 
Old 08-16-2007, 04:18 PM   #13
tjyorkshire
Member
 
Registered: Jun 2007
Location: UK
Distribution: openSUSE 10.2
Posts: 138

Rep: Reputation: 15
While set up with a static ip
 
Old 08-16-2007, 04:33 PM   #14
DoctorWynn
Member
 
Registered: Nov 2005
Distribution: OpenSuSe 10.1
Posts: 63

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by tjyorkshire View Post
Do:
Code:
route del -net 169.254.0.0 netmask 255.255.0.0 gw 0.0.0.0
Now see if you can ping
Still nothing.

Can we try this...what settings SHOULD everything be at in yast? As mentioned, I'm using a cable modem connected to a wireless router. The wireless works fine with all pc's in the house. My linux pc is connected directly to the router via ethernet cable, and that's the one that won't work. So what should all my settings look like? This is so frustrating, I appreciate everyone's help and patience!

The router is setup to use a dhcp server to assign ip addresses.
 
Old 08-16-2007, 06:20 PM   #15
tjyorkshire
Member
 
Registered: Jun 2007
Location: UK
Distribution: openSUSE 10.2
Posts: 138

Rep: Reputation: 15
Ok then, in yast

In the network devices:
Configured using ifup
On your adapter: The address tab should have automatic address selected, the general tab should have device activation at boot time, check user controlled and also firewall disabled (just for the moment).
That should be enough to allow it to work:
However you could:
When you click on the "host name and name server" button put your router address as the name server 1
When you click the "routing" button enter the router as the default gate way.

Also (for now) completely disable the firewall

(hope i didn't sound too condescending)

That should be all that is needed to get it working... )although if not, i'm starting to run out of ideas)

Last edited by tjyorkshire; 08-16-2007 at 06:23 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no internet connection (cable, router) OpossumPetya Suse/Novell 5 01-02-2006 02:59 PM
Can't get to the internet through cable modem/router Myron Linux - Networking 4 03-03-2004 01:09 AM
Cable modem and router - connection lost koswo Linux - Networking 13 01-09-2004 12:19 PM
howto setup Cable modem&router&red hat on machine with ethernet integrated on mobo&XP takanana Linux - Networking 14 10-23-2003 08:20 AM
sharing cable modem connection using router kbaldor Linux - Networking 3 01-29-2002 06:44 PM


All times are GMT -5. The time now is 09:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration