LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 01-15-2008, 08:01 PM   #1
geek_man
Member
 
Registered: Nov 2007
Distribution: Fedora 7, Fedora 9, Solaris 10, Mac OS X, RHEL5
Posts: 71

Rep: Reputation: 15
Question Intel PRO/Wireless 3945ABG not working!!


Hi!

I have just installed OpenSUSE 10.3 and I wanted to try my Wifi connection and it didn't work.
In YaST my card is detected. At the beggining it said not configured, but I configured it and now it says DHCP.
My led is green, which indicates that my wifi is turned on.
If I try to connect with the KNetwork Manager it gets to 28% and never connects.
I used ifconfig wlan0 up and it doesn't display any error but doesn't work.
If I look for intel in YaST, I can see that everything is installed, I mean ipw3945, firmware, etc.
I have been looking in other forums, but there is no answer that works for me.

Thanks.
 
Old 01-15-2008, 09:54 PM   #2
terryxela
Member
 
Registered: Dec 2006
Location: Denver, Colorado, USA
Distribution: SuSE 11.3
Posts: 125

Rep: Reputation: 17
Quote:
Originally Posted by geek_man View Post
Hi!

I have just installed OpenSUSE 10.3 and I wanted to try my Wifi connection and it didn't work.
In YaST my card is detected. At the beggining it said not configured, but I configured it and now it says DHCP.
My led is green, which indicates that my wifi is turned on.
If I try to connect with the KNetwork Manager it gets to 28% and never connects.
I used ifconfig wlan0 up and it doesn't display any error but doesn't work.
If I look for intel in YaST, I can see that everything is installed, I mean ipw3945, firmware, etc.
I have been looking in other forums, but there is no answer that works for me.

Thanks.
Look at the release-notes

"........You can change the default using YaST. Click "Software" -> "Software Management" and remove the ipw3945d package. Then the alternative iwlwifi driver gets automatically selected for installation.
That did it for me

-=terry=-
 
Old 01-15-2008, 11:12 PM   #3
geek_man
Member
 
Registered: Nov 2007
Distribution: Fedora 7, Fedora 9, Solaris 10, Mac OS X, RHEL5
Posts: 71

Original Poster
Rep: Reputation: 15
Wifi not working!!

Hi!

Thanks for the answer. I did what you told me but it didn't work.
I had already installed iwlwifi. I guess I just have to configure something, because I can see the networks that are around me, I just can't connect to them.

Thanks.
 
Old 01-18-2008, 11:27 PM   #4
terryxela
Member
 
Registered: Dec 2006
Location: Denver, Colorado, USA
Distribution: SuSE 11.3
Posts: 125

Rep: Reputation: 17
Quote:
Originally Posted by geek_man View Post
Hi!

Thanks for the answer. I did what you told me but it didn't work.
I had already installed iwlwifi. I guess I just have to configure something, because I can see the networks that are around me, I just can't connect to them.

Thanks.
I assume that you have setup WEP or WPA and password correctly!
 
Old 01-19-2008, 10:20 AM   #5
geek_man
Member
 
Registered: Nov 2007
Distribution: Fedora 7, Fedora 9, Solaris 10, Mac OS X, RHEL5
Posts: 71

Original Poster
Rep: Reputation: 15
Intel 3945ABG not working!!

Quote:
I assume that you have setup WEP or WPA and password correctly!
Actually I haven't set a password for my router.
 
Old 01-20-2008, 12:25 PM   #6
terryxela
Member
 
Registered: Dec 2006
Location: Denver, Colorado, USA
Distribution: SuSE 11.3
Posts: 125

Rep: Reputation: 17
Your chip has some problems however it will work. I have a thinkpad x61. When I followed the tips from the opensuse 10.3 release notes it did the trick. The following is a list of steps to check for a wireless connection. There was a site with an excellent description of all the steps but..I can not find it, so I hope this does it ;-) It may help you find where the problem is.
But again before you go through it go to yast and the network card and disable the knetwork manager, delete the module and it will load the new one and try with up and down few times. Also go to starbucks and see if you can access the hot spot. In some cases the problem is with the wireless router (yes I know it works with windows :-)) so if you can use it in starbucks you have to look at a problem with the router.

Wireless troubleshooting

(1) Be sure the wireless hardware switch is on

(2) Open xterm

and become root


(3) Is the chip recognized or exist?

#lspci | grep -i Wireless

(4) Which wireless interfaces you have in your machine?

# iwconfig

find wireless interface for example eth1 or wlan0. Use this interface for all the commands.

If you do not have a wireless interface:

a. you do not have a wireless card and that would have shown in step 3 or
b. you do not have the correct module installed just #lsmod and see if yours is listed

If the interface has an IP great, if not dhcpd did not work. Any messages?

(5) Can you see any wireless network around?

# iwlist (interface) scanning
for example iwlist eth1 scanning

This shows the MAC address of any remote wireless access points (or peers if in AdHoc mode?).

If you can not find anything to connect:
a) remove interference: turn off microwaves, turnoff cordless phones (mainly 2.4)
b) move close to access point

(6) Setting:

Mode: if you are connecting to and access point -> Managed Mode.

Channel is determined automatically.

ESSID:you can't connect to an AccessPoint unless you are both using the same ESSID!

Network: this is the IP address.

Manually you can setup those paramters:

iwconfig eth2 mode Managed
iwconfig eth2 essid "secret_password"


In Managed Mode the channel is setup automatically.

check up after the setup:

# iwconfig eth1

If problems:
(a) turn the interface down and up see below and the run iwconfig again.
(b) be sure the ESSID are the same in the router and card

(7) Check connection

$ ping -c2 google.com

(8) How to bring the interface UP or DOWN.

# ifdown eth1

#ifup wlan0

Note: ifup and ifdown work IF the Knetworkmanager is not enable (opensuse)
Some user had problems with the Knetworkmanager. I did not.

(8) Try unloading the kernel module for the card and reloading it

(9) Miscellaneous tips:

9.1 It can be some interaction between the wireless and the wired chips. If you want to use wired interface when you are plugged to a cat5 cable and wireless when you are not, set both devices to power up on cable connection (YaST -> Network Devices -> Network Card -> Advanced -> Detailed Settings -> Device Activation)

9.2 If nothing works you can always try with ndswrapper
http://www.tuxmagazine.com/node/1000167
http://www.andrewd18.com/ndiswrapper/
I do not have any experience with it.

9.3 This is the site for the new module, the one I am using, however I use the one from the opensuse repository that is installed with yast.
http://intellinuxwireless.org/

-=terry=-

Last edited by terryxela; 01-20-2008 at 12:29 PM.
 
  


Reply

Tags
intel wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel Pro Wireless 3945ABG Debian Help jaredhocutt Linux - Newbie 7 01-24-2010 11:22 PM
Intel PRO Wireless 3945ABG: Help! LDJ Linux - Newbie 13 09-21-2007 06:21 AM
Fedora 7 + intel PRO/Wireless 3945ABG :( adam_blackice Linux - Wireless Networking 9 08-13-2007 12:48 PM
Problem - Intel Intel(R) PRO/Wireless 3945ABG suresheva31 Fedora 2 09-18-2006 08:45 PM
Intel PRO/Wireless 3945ABG card not working in SuSE 10.1 iamjunko Suse/Novell 6 07-29-2006 01:10 PM


All times are GMT -5. The time now is 11:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration