LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Intel 2200BG wireless problems (http://www.linuxquestions.org/questions/suse-novell-60/intel-2200bg-wireless-problems-295668/)

idahoakl 02-27-2005 09:11 PM

Intel 2200BG wireless problems
 
I know this has probably been posted before and hashed over again and again. I am a noob at linux and searched the net for a few hours looking for a solution to this problem. For starters i'm running suse 9.2 on a IBM R51. I got the version of suse from the novell download so it isn't the purchased one. I installed ipw-firmware and had the wireless working at one time, decided to upgrade to ipw2200 1.0.0. Upon doing this my wireless doesn't work any more and i get this in my dmesg file.

module ieee80211 unsupported by SUSE/Novell, tainting kernel.
ieee80211: disagrees about version of symbol ieee80211_crypt_deinit_entries
ieee80211: Unknown symbol ieee80211_crypt_deinit_entries
ieee80211: disagrees about version of symbol ieee80211_crypt_delayed_deinit
ieee80211: Unknown symbol ieee80211_crypt_delayed_deinit
module ieee80211 unsupported by SUSE/Novell, tainting kernel.
module ipw2200 unsupported by SUSE/Novell, tainting kernel.
ipw2200: disagrees about version of symbol ieee80211_wx_set_encode
ipw2200: Unknown symbol ieee80211_wx_set_encode
ipw2200: disagrees about version of symbol ieee80211_wx_get_encode
ipw2200: Unknown symbol ieee80211_wx_get_encode
ipw2200: disagrees about version of symbol ieee80211_crypt_delayed_deinit
ipw2200: Unknown symbol ieee80211_crypt_delayed_deinit
ipw2200: disagrees about version of symbol ieee80211_wx_get_scan
ipw2200: Unknown symbol ieee80211_wx_get_scan
ipw2200: disagrees about version of symbol ieee80211_rx
ipw2200: Unknown symbol ieee80211_rx
ipw2200: disagrees about version of symbol ieee80211_rx_mgt
ipw2200: Unknown symbol ieee80211_rx_mgt
ipw2200: Unknown symbol free_ieee80211
ipw2200: Unknown symbol alloc_ieee80211

I get these errors even if i have the latest firmware installed and even tried ipw2200 1.0.1. Any help would be greatly appreciated.

Thanx

Matt

onjoo 03-03-2005 06:09 AM

Same problem here.
Did you find a way to fix it ?

dillwead 03-08-2005 09:30 PM

I have the same lines in my dmesg. They are generated when my system tries to load the driver at boot time or when i try to manually load it using modprobe ipw2200. However, I have been able to get the wireless to work if i run the "load" program that came with the ipw2200 driver (from http://ipw2200.sourceforge.net/). Have you tried that?

Unfortunately this means i have to manually load the drivers every time i want to use wireless. I am very much interested in a solution that would fix the auto loading of the drivers at boot.

mserms 03-11-2005 05:16 PM

I have been unable to find docs on the 'load' script how do I load the module using that?

casperghst42 03-12-2005 08:24 AM

I solved it by updating to the latest kernel (2.6.8-24.11-default), and then reboot.


Regards/Casper


All times are GMT -5. The time now is 11:27 AM.