LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Installing PHP4 and 5 - problems? (http://www.linuxquestions.org/questions/suse-novell-60/installing-php4-and-5-problems-564806/)

russh 06-27-2007 06:24 AM

Installing PHP4 and 5 - problems?
 
I have two PHP applications to run on a single box - one PHP4 based, and one PHP5 based.

I've been advised that I can probably install them both side by side and as long as you are using the Apache web server, you can put a different .htaccess file in each program's directory. For example, in /APP1_is_PHP5/.htaccess you could have the line 'AddHandler x-httpd-php5 .php' and in /APP2_is_PHP5/.htaccess you could have the line 'AddHandler x-httpd-php .php' and each program would use the correct engine.

From this I guess that I'd also install apache2-mod_php4 and apache2-mod_php5.

Does anyone have experience of doing this? Does it work? :-)

Russ.

russh 06-27-2007 06:35 AM

Quote:

Originally Posted by russh
I have two PHP applications to run on a single box - one PHP4 based, and one PHP5 based.

I've been advised that I can probably install them both side by side and as long as you are using the Apache web server, you can put a different .htaccess file in each program's directory. For example, in /APP1_is_PHP5/.htaccess you could have the line 'AddHandler x-httpd-php5 .php' and in /APP2_is_PHP5/.htaccess you could have the line 'AddHandler x-httpd-php .php' and each program would use the correct engine.

From this I guess that I'd also install apache2-mod_php4 and apache2-mod_php5.

Does anyone have experience of doing this? Does it work? :-)

Russ.


Found an alternative solution, but not quite as flexible:

http://www.linuxquestions.org/questi...d.php?t=419733


All times are GMT -5. The time now is 09:42 AM.