LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 09-10-2007, 10:28 PM   #1
noir911
Member
 
Registered: Apr 2004
Location: Baltimore, MD
Posts: 681

Rep: Reputation: Disabled
install subversion 1.4.4 on suse linux enterprise server 9


I'm trying to install subversion 1.4.4 (subversion-1.4.4-10.24.i586.rpm) on
Suse Linux Enterprise Server 9 but it says Failed dependencies:
libapr-1.so.0 is needed by subversion-1.4.4-10.24
libaprutil-1.so.0 is needed by subversion-1.4.4-10.24

I have libapr installed - libapr0-2.0.49-27.34

Is it possible to install subversion 1.4.4 without upgrading to libapr-1.so.0
or by any other means? I tried --nodeps but that gives error while starting
svnserver. Thanks.
 
Old 09-11-2007, 03:06 PM   #2
digen
Member
 
Registered: Dec 2005
Location: India
Distribution: Ubuntu Feisty Fawn
Posts: 107

Rep: Reputation: 15
1. I would suggest using a package manager like yum to install software. It would automatically take care of dependencies for you. I'm not sure what Suse uses beneath for package management.

2. Checking the subversion website suggests that it also has another tar ball for dependencies which combines with the main subversion tar ball once extracted. You might also want to give that a shot instead of manually hunting down dependencies.
http://subversion.tigris.org/servlet...xpandFolder=74
 
Old 09-13-2007, 04:18 AM   #3
noir911
Member
 
Registered: Apr 2004
Location: Baltimore, MD
Posts: 681

Original Poster
Rep: Reputation: Disabled
tried #1 at first place and the search box in Yast2 doesn't give back anything. So, Yast doesn't know what subversion is.

tried #2 but it fails on dependencies - libapr.

Is there ANY ISO from Novell website that I can download that has subversion RPM for SLES 9 patch level 3? I don't care about subversion version - just ANY subversion will do. I have downloaded the following ISOs from Novell website but none of them have subversion!

SLES-9-SP-3-i386-RC4-CD1.iso
SLES-9-SP-3-i386-RC4-CD2.iso
SLES-9-SP-3-i386-RC4-CD3.iso

Any help would be much appreciated. Thanks.
 
Old 12-29-2008, 01:57 PM   #4
carltm
Member
 
Registered: Jan 2007
Location: Canton, MI
Distribution: CentOS, SuSE, Red Hat, Debian, etc.
Posts: 697

Rep: Reputation: 93
I found a newer version of subversion along with neon, libapr1
and libapr-utils1 that was built for SLES 9. Just search,
download and install.

http://software.opensuse.org/search
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
what is differences between SUSE Linux Enterprise Server 10 and SUSE Linux Enterprise samba4010 Linux - Distributions 4 08-28-2006 09:06 AM
I Can't install SuSE Enterprise Server 9 muhammaduk Linux - Enterprise 1 02-27-2006 09:35 PM
SuSE 9.1 Pro or SUSE LINUX Enterprise Server 9? Mega Man X Linux - Distributions 11 09-24-2004 10:51 AM
How to install Subversion(Version Control with Subversion) under RedHat Linux. netkiller Linux - Networking 1 07-01-2004 05:45 AM
CAN't INSTALL ORACLE 9.2.01 ON SUSE LINUX ENTERPRISE SERVER 8! grim2 Linux - Software 1 04-29-2004 04:46 AM


All times are GMT -5. The time now is 08:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration