LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 08-24-2006, 11:08 PM   #1
da_tibmeister
Member
 
Registered: Oct 2003
Distribution: SLES 9.3
Posts: 40

Rep: Reputation: 15
Question incorrect swap reporting on SLES9.3


Okay, so I am installing SLES on one of my servers (Dell PowerEdge 2950) for Oracle 10g. I was looking everything over and both top and free reports my swap space as having 1042MB free. This concerns me because I have a swap partition of 15GB added. I do want to point out that I did not transpose the 42 and 24, which I thought was strange. So, after much experimentation, it appears that this is related to free and top, because ksysguard reports the swap correctly. Anyone else run acrossed this and should I be concerned about this inconsistensy?
 
Old 08-31-2006, 02:14 PM   #2
da_tibmeister
Member
 
Registered: Oct 2003
Distribution: SLES 9.3
Posts: 40

Original Poster
Rep: Reputation: 15
Update

As an update, ksysguard is now only reporting 1048MB total for my swap size. I verified that the partition is 15GB. This server is 64 bit, and so is SLES9.3, but I have reproduced this on a 32-bit VM running SLES9.3 as well, with a large swap partition as well. Back in my days on Slackware, I added 10GB partitions and had no problems with this. I'm not sure what is going on here....
 
Old 09-07-2006, 01:10 PM   #3
da_tibmeister
Member
 
Registered: Oct 2003
Distribution: SLES 9.3
Posts: 40

Original Poster
Rep: Reputation: 15
I am able to duplicate this on every system I try, including a Slackware 10.2 box running 2.6.5 kernel. I believe it is a kernel bug and I'm going to persue this. I'm going to try and recompile with a newer kernel and see what happens.
 
  


Reply

Tags
incorrect, size, swap


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Incorrect Mouse, Incorrect Keymap, and Trapped in X Kenji Miyamoto Debian 8 08-24-2005 02:42 PM
p2p and sles9 berrance Linux - Software 3 02-27-2005 05:33 AM
SLES9 Screensavers jdozarchuk Suse/Novell 1 11-03-2004 02:27 PM
How to unmount actual swap and mount a new(bigger) swap space? isaac Linux - Newbie 1 06-06-2004 01:23 AM
Qt Parted reporting incorrect parition types nrunge Linux - Software 2 01-28-2004 11:21 AM


All times are GMT -5. The time now is 04:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration