LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   Impossible to install SKYPE 1.4.0.74 under SuSE 10.2 (http://www.linuxquestions.org/questions/suse-novell-60/impossible-to-install-skype-1-4-0-74-under-suse-10-2-a-563270/)

riba43 06-20-2007 03:35 PM

Impossible to install SKYPE 1.4.0.74 under SuSE 10.2
 
Hi,

is there somebody out there who successfully installed the las version of Skype in SuSE10.2. I have been trying to install it without success. I have qt4 installed. The previous version worked fine. Where can I get it??

reddazz 06-21-2007 07:51 AM

If you are compiling from source, did you install the qt4 devel packages? Post back more details about where exactly you are facing problems and any detailed error messages, so that someone can help you out.

riba43 06-22-2007 03:54 AM

Hi redazz,
I have qt4 and devel package installed. I have dl skype-1.4.0.74-static. Trying to execute skype from the extracted file nothing happened. ????

bgorjup@riba:~/Prenosi/skype-1.4.0.74/skype-1.4.0.74> ./skype
./skype: error while loading shared libraries: libQtDBus.so.4: cannot open shared object file: No such file or directory
bgorjup@riba:~/Prenosi/skype-1.4.0.74/skype-1.4.0.74>

ionmich 06-22-2007 05:46 AM

Quote:

Originally Posted by riba43
Hi redazz,
I have qt4 and devel package installed. I have dl skype-1.4.0.74-static. Trying to execute skype from the extracted file nothing happened. ????

I have had the same problem and the same error. I suspect that this version may work with SUSE 10.3. I have the skype-1.3.0.53-suse.i586.rpm file which was downloaded from the Skype web page and which works on my SUSE 10.2 GM. A google search for this file only produces a Chinese page. I believe I can legally send it to you but it is 9.5 megs in size and possibly too large for an E-mail attachment. But I can try if you want to give me your address.

riba43 06-22-2007 10:54 AM

Ionmich,
My e-mail is : gorjup.bogomir@siol.net. Do not worry about the size. I have a broadband and a lot of space on my account. Thanks a lot. I know that the older version is working, because I had it installed. I have been trying to dl from a web but it is not on it anymore. Thank you.

ionmich 06-22-2007 04:58 PM

Quote:

Originally Posted by riba43
Ionmich,
My e-mail is : gorjup.bogomir@siol.net.

It's on the way from a server called voila.fr.

reddazz 06-22-2007 08:19 PM

Quote:

Originally Posted by riba43
Hi redazz,
I have qt4 and devel package installed. I have dl skype-1.4.0.74-static. Trying to execute skype from the extracted file nothing happened. ????

bgorjup@riba:~/Prenosi/skype-1.4.0.74/skype-1.4.0.74> ./skype
./skype: error while loading shared libraries: libQtDBus.so.4: cannot open shared object file: No such file or directory
bgorjup@riba:~/Prenosi/skype-1.4.0.74/skype-1.4.0.74>

You need to install the qt4 dbus package.

riba43 06-23-2007 07:08 AM

Quote:

Originally Posted by reddazz
You need to install the qt4 dbus package.

Hi redazz,
I checked my qt4 packages. I have (I think) all of them, but noway, I cant setup Skype. I installed the old version which I got from ionmich and it works without problems. But anyway, I would like to be able to install the new version on SuSE 10.2 as well.

Here are the qt4 packages I have on my system:

libqt4
libqt4-dbus-1
libqt4-devel
libqt4-devel-doc
libqt4-devel-doc-data
libqt4-qt3support
libqt4-sql
libqt4-sql-mysql
libqt4-sql-postgresql
libqt4-sql-sqlite
libqt4-sql-unixODBC
libqt4-x11

reddazz 06-23-2007 04:38 PM

It seems like you have the right packages. Did you try the non static version?

odiseo77 06-23-2007 05:13 PM

I tried skype's beta version on suse 10.2 and it ran smoothly (it was the dynamic package, I think (I'm not on suse right now, so I can't tell))... @riba43: by any chance are you running 64 bits suse?? (I had a similar problem with qt4-dbus package on Ubuntu 64 bits).

riba43 06-24-2007 02:21 AM

Hi,
yes odiseo, I am running 64 bit system and redazz I tried both versions with the same result.

ionmich 06-24-2007 05:06 AM

Quote:

Originally Posted by riba43
Hi,
yes odiseo, I am running 64 bit system and redazz I tried both versions with the same result.

Well I am running the 32 bit version of SUSE 10.2 GM and I would like to get skype-1.4.0.74 running if we ever figure out what the problem is. Keep us posted please riba43.

riba43 06-24-2007 09:37 AM

ionmich be sure I will.

odiseo77 06-24-2007 11:10 AM

Quote:

Originally Posted by riba43
Hi,
yes odiseo, I am running 64 bit system and redazz I tried both versions with the same result.

Hi riba43. Well, not being on Suse 64 bits I can't be of much help here, but I tell you what I did on Ubuntu 64 bits in order to get skype running (I just followed the steps detailed on a howto on ubuntuforums.org):

1.- see if you can find packages with names like ia32-libs on suse's repositories; if so, install all of them.

2.- Find the i386 packages for qt4-core, qt4-gui, libsigc++-2.0 and libdbus (or sigc++-2.0 and dbus, something like that). (You can search in sites like http://rpmfind.net/ ; I'm not on suse right now, so I'm not sure what the names will be). Once you find them, extract the contents of these packages and copy them to /usr/lib32. After you've done this, execute ldconfig /usr/lib32 as root.

3.- Run either the dynamic or the static skype binary, if the above steps are correct, you should have skype sunning on your machine.

Greetings.

pilotgi 06-24-2007 04:01 PM

I installed skype 1.4.0.74 successfully on openSUSE 10.3 alpha 5. Other than the files listed on the skype site that are required, I added the ia32el rpm that was mentioned in the above post. Simply untarred the file and typed ./skype and the welcome window popped up asking for my user name and password.

Edit: I also installed it on 10.2 with no problem. I didn't add ia32el this time. I haven't used skype to call anyone yet, but it installed fine.


All times are GMT -5. The time now is 11:10 AM.