LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 10-25-2012, 10:14 AM   #1
dwhb
Member
 
Registered: Jul 2012
Location: Down Under
Distribution: Mint 17 Qiana KDE
Posts: 55

Rep: Reputation: Disabled
HPLIP failed to download driver at end of installation


I installed hplip-3.12.10a but just when you come to the time to plug/unplug to continue, it asked whether you wanted to download the correct driver. It failed (nothing wrong with my network connection) twice,so my HP LaserJet Professional p1102w is not printing. To make matters worse, CUPS print manager cannot start because my Firefox has crashed (died) completely. It cannot start at all. Therefore, Firefox being the default browser, I cannot get into CUPS Print Manager to have a look. I don't know where to get to the page, so I'm stuck without the ability to print. I need to print out pages of install notes I made because the disappointing openSuSE12.2 has too many problems to list in one posting.

As a result, hp-setup cannot detect any printer at all although from Yast the printer was listed. Perhaps from the previous 11.4 version of suse although I did a new install of the 12.2.

I just wonder if its possible to download a ppd driver from somewhere? Help please!

Thanks in advance
 
Old 10-25-2012, 03:59 PM   #2
x-alien
Member
 
Registered: Aug 2008
Distribution: Slackware
Posts: 39

Rep: Reputation: 21
From YaST - Repositories, click on "Add" and insert: http://download.opensuse.org/reposit...openSUSE_12.2/
Name it, for example: "OpenSUSE 12.2 Printing".

Now, from YaST - Package Manager, select "Repository" - "OpenSUSE 12.2 Printing" and click on "Switch system packages".

Then, reboot and ... good luck!
 
Old 10-25-2012, 08:26 PM   #3
dwhb
Member
 
Registered: Jul 2012
Location: Down Under
Distribution: Mint 17 Qiana KDE
Posts: 55

Original Poster
Rep: Reputation: Disabled
Thanks very much. Did all you suggested and download happened. After reboot, I ran the hp-setup again and no printer was detected:
HP Linux Imaging and Printing System (ver. 3.12.10a)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Searching... (bus=usb, search=(None), desc=0)
error: No devices found on bus: usb
I am not sure whether its a USB or mounting problem because after trying to get printer detected, Disk Information in MyComputer normally shows already mounted partitions (swap, root, home) are now a blank. When CDs/DVDs or flash drives are plugged are not detected. Firefox is permanently crashed after it updated itself to version 16. Address Book in KMail cannot be created, imported hence can't be displayed. Addresses manually typed in when sending email are not picked up automatically so they are displayed when selection "To". My list of problems go on & on. I don't know if anybody else are encountering as many issues with openSuSE12.2 as me. There are also no sounds in videos (youtube or normal DVD videos), audio CDs, Amarok etc or system notification sounds although right after installation of codecs, at least Amarok was playing my mp3 collections.

Thanks for reading through. I hope I someone can help me resolve the most pressing issues - printing and KMail/address book display/import/creation. I dread having to stare down the barrel of re-installation yet again!

Cheers
Attached Images
File Type: jpg MyComputer_sysinfo.jpg (92.5 KB, 1 views)
 
Old 10-26-2012, 06:46 AM   #4
dwhb
Member
 
Registered: Jul 2012
Location: Down Under
Distribution: Mint 17 Qiana KDE
Posts: 55

Original Poster
Rep: Reputation: Disabled
Printer still not working because none of my usb disks, CD or DVD drives can be picked up by Device Notifier. Diagnostic suggested by Launchpad was done, bug report submitted. Yast's Hardward info listed all the drives that MyComputer SystemInfo does not display since yesterday. The HP printer was listed as HP SmartInstall (guess thats the driver plug-in).

No printing is possible since the printer cannot be detected with hp-setup. I have posted in the Desktop board about the system info under MyComputer. Hopefully, my problems will be solved.

Cheers
 
Old 10-26-2012, 03:36 PM   #5
x-alien
Member
 
Registered: Aug 2008
Distribution: Slackware
Posts: 39

Rep: Reputation: 21
I have installed OpenSUSE 12.2 64 bit and everything is working perfectly.
Probably, in your case there are hardware or software problems; perhaps, you have installed OpenSUSE from a corrupted CD/DVD.
 
Old 10-27-2012, 03:50 AM   #6
dwhb
Member
 
Registered: Jul 2012
Location: Down Under
Distribution: Mint 17 Qiana KDE
Posts: 55

Original Poster
Rep: Reputation: Disabled
I am now downloading another iso of 12.2 using Firefox Downthemall with built in checksum. Hopefully a new install will not have so many problems, all of which I've never encountered before from version 9 onwards. I have been so used to and like suSE that I am a bit reluctant to move to other distros.

The install DVD was checked before installation and no errors came up. BTW, it was a new install.

Thanks for the reply. I'm glad to hear that you have not come across any problems because I am going to install fresh again after download is complete. I also intend to wipe root clean with fdisk so that whatever mistakes were left behind will not be automatically kept. I have a feeling that was the reason why so many problems crop up.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Sorry, installation of this driver failed. Please have a look at the log file for de Crowey17 Linux - Newbie 3 10-05-2012 02:34 PM
[SOLVED] hplip-3.11.1 in 13.37rc3: plugin download error kingbeowulf Slackware 4 10-06-2011 02:16 AM
printing with hplip doesn't work: /usr/lib/cups/backend/hp failed ToK Linux - Hardware 10 02-02-2011 05:45 PM
openSuse 10.2, AMD x86_64, NDAS installation with Ximeta driver failed EichbaumExport Linux - Hardware 0 05-21-2007 04:09 PM
[Redhat9.0] RPM-driver installation problems...failed dependencies Patrique Linux - Software 2 05-30-2004 09:59 AM


All times are GMT -5. The time now is 08:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration