LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   hp-systray problem (http://www.linuxquestions.org/questions/suse-novell-60/hp-systray-problem-4175431477/)

anandrajan 10-10-2012 07:13 AM

hp-systray problem
 
I recently upgraded to opensuse 12.2. I have hplip installed with the following packages:

rpm -qa |grep hplip
hplip-sane-3.12.10-59.1.x86_64
hplip-3.12.10-59.1.x86_64
hplip-hpijs-3.12.10-59.1.x86_64

python-2.7.3-3.6.1.x86_64 is installed

I'm running kde 4.9 as the DE.

The HP Device Manager does not bring up the gui any more. When I monitor the command line, I see the following (python?) errors. Does anyone else have the same problem and/or a fix?

Anand

--------------------------------------------------------
warning: Reportlab not installed. Fax coverpages disabled.
warning: Please install version 2.0+ of Reportlab for coverpage support.
Traceback (most recent call last):
File "/usr/bin/hp-toolbox", line 257, in <module>
toolbox = DevMgr5(__version__, device_uri, None)
File "/usr/share/hplip/ui4/devmgr5.py", line 204, in __init__
if not utils.Is_HPLIP_older_version( installed_version, self.user_settings.latest_available_version):
File "/usr/share/hplip/base/utils.py", line 1927, in Is_HPLIP_older_version
if(int(installed_array[cnt]) < int(available_array[cnt])):
ValueError: invalid literal for int() with base 10: "10a Public Release</a><br />')"

frankbell 10-10-2012 08:03 PM

You need the GUI, hp-toolbox. It's often a separate package.

In Debian, that package is called hplip-gui; I don't know what it is called in rpm-world.

anandrajan 10-10-2012 08:39 PM

An update - hplip-3.12.10a (available today at opensuse Printing) solved the problem.

Anand


All times are GMT -5. The time now is 04:41 AM.