LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   HP laptop advice for Suse 10,will it work (http://www.linuxquestions.org/questions/suse-novell-60/hp-laptop-advice-for-suse-10-will-it-work-375627/)

ifbaptist 10-21-2005 10:30 PM

HP laptop advice for Suse 10,will it work
 
I just bought an HP ze2315us laptop. Does anyone know how Suse 10 will work on it? Mostly these are my concerns:

1. ACPI support - is it good or bad

2. WLAN support

3. ATI graphics

I've never used Suse but it's suppossed to be really stable and well maintained. I'm not finding to much info about how it is on laptops.

Any advice would be greatly appreciated.

Here are the spec on my laptop:

-AMD Mobile Sempron 3000+ with Powernow Tech (1.8GHz)
-60gb hard drive
-512 DDR SDRAM
-ATI RADEON XPRESS 200m IGP with 128 MB video memory(shared)
-54g 802.11g/b WLAN (It's a Broadcom)
-DVD burner

I'm running Ubuntu on my desktop AMD64 3500 and it's doing great but I couldn't get it going on my laptop.

biophysics 10-22-2005 04:29 AM

http://www.linux-on-laptops.com/hp.html

check here if any models that are close to your laptop configuration work with some distro. You need to know only some tricks to apply it to your distro of choice.

AFAIK HP laptops work good with ACPI. WLAN will depend on the make, WEP, WPA... Installing ati proprietary drivers are NOT always successful in any distro.

dbogdan 10-22-2005 03:07 PM

Simplest way would be to grab a live DVD and boot off it.....

http://www.opensuse.org/Download


I can almost guarantee you're gonna have issues with the broadcom stuff tho (not JUST a SuSE issue either), you can get it to work with ndiswrapper but it 'can' be a bit frsutrating to get working correctly.

Dave

Just a suggestion, I really like suse but take a look at Mepis, it's a great, user friendly install that REALLY works well with laptops/wireless.

ifbaptist 10-23-2005 02:02 AM

laptop distro
 
Thanks for the info. I had already checked linux-on-laptops and couldn't really find what I was looking for. (Excellent suggestion though) I'm going to check out Mepis this week. I took your advice and downloaded the Suse 10 Live DVD last night. (Filezilla is awesome!!) Good thing the laptop has a DVD burner.

It booted right up on my laptop and even showed my battery power. My sound didn't work and the NIC's had issues but that could have been because it was a Live "install" and I really couldn't configure much.

I had a $30 promotion on Amazon so I ordered the Suse box set for total $23.99 with free shipping. I know I could have downloaded for free. But install support and hard copy docs will be kinda cool. This is the first time I'v ever payed for linux.

I'll post how it all went next weekend. Wish me luck. I checked the ndiswrapper site and I think with LQ and a little effort I'll be Ok.

The first distro I ever used was Slackware and it's true that you tend to have to learn at least the basics pretty quick. I'm no linux guru but I try hard not to waste folks time with easily solved problems.

Wish me luck!!! Cya later.

ifbaptist 11-11-2005 12:17 AM

Installation results
 
Well I installed SUSE 10 on my laptop and things went pretty well. It resized my XP partition and booted right up into a GUI.

There are only 2 things I'm having problems with:

1. As expecte the WLAN is not working yet. I've looked into it and I'm debating about saving some time and using linuxant to get it going vs ndiswrapper. Any opinions?

2. There is currently no 3d accelaration with the Radeon 200m "video card". I'm not sure what I'm going to do about that yet.

I haven't had to much time to deeply research these issues yet so over all I'm pretty happy with the install. To give you an idea how new to SUSE I am I haven't even found out what ftp repository to add for downloading additional software (like Scribus). I'll probably work on these issues this weekend.

The desktop is just a little bit slower than I feel is necessary so maybe once all my other issues are worked out I'll give XFCE a try to speed things up a bit. This is no fault of SUSE I only have 512mb of shared RAM with the Radeon using 128.

The overall polish and detail of the desktop however is very nice. All of the installed packages seem to work great.

My only problem is that the Novell website isn't exactly what I would consider intuitive to navigate for answers but with LQ and Suse forums that's not too big a deal.

If I get wireless and 3d worked out Suse is definitely a keeper for me. I'll keep you posted.

crazibri 11-11-2005 12:37 AM

I've got a HP ze5470us laptop and I've got full capability. 3d support on my ATI and Broadcom wireless w/ WPA encryption works great. I have my vpn client and usb support so its all good.

My suggestion for wireless is you can use the ndiswrapper but I've heard its difficult to configure and if you're linux savy go for it. Otherwise, I suggest linuxant. I got tired of configuring ndiswrapper after each linux install on my laptop (i've been thru RH9, Suse 9.0 thru Suse 10.0). Each time I'd reformat the linux partitions and just thought it was worth the $20. ATI 3d support was built right in for me. I just went to Yast Modules / Hardware / 'Graphics Card and Monitor' and then just checked the box for 3d support. It works fine for me beause Suse has builtin glrfx. If you find that doesnt work for you, I'd suggest checking ATI's linux site for a driver? I've heard though its not very intuitive if you find one.

A great way to transfer files between Linux and Windows is having a separate Fat32 partition. I actually use my fat32 partition to store/install Suse packages (all 5 CDs).

Anyway, let me know if you need some pointers.

ifbaptist 11-20-2005 01:29 AM

video card with 3d
 
My 3d option is greyed out. What type of ATI video do you have on your laptop? As near as I can tell the driver on the ATI website wil not support the "200m" that is installed on my HP ze2315us. I really can't tell at all when I'm doing real work. I only notice when I goof off and try some games that need 3d.

So either way it's not a show stopper for me but if you have any suggestions I'd appreciate it.

Thx.

mjrdzine 11-22-2005 11:15 AM

I recently got an HP L2000 (Lance Armstrong Edition) and have pretty much an identical situation. (no wifi, no 3D) I've used Suse starting with version 6.4, and was pleased when almost every thing on my laptop was supported. The only additional issue i have is that the built in card reader on my unit isn't supported. I already have a USB reader, so it's not really an issue for me. The wifi, how ever, is an issue. I may jut go buy another USB wifi unit. The one i have for my shutttle box with Suse 10 out of the box.

Pcghost 11-22-2005 02:09 PM

You may be able to enable 3d for the RS200 (integrated radeon) by using the radeon driver (7000 if I remember correctly) instead of the default VESA driver SuSE uses when this card is detected.

jack.s-suse 11-22-2005 08:06 PM

I have a dv1220 and SUSE works like a dream. ACPI support is purfect, hibernate, standby, and cpu scaling all work fine. I dont have any problem with graphics or wireless because they are both made by Intel. (intel pro/wireless, and intel extreme graphics). What really supprised me is that the light that tells me when i am connected to a network also works.

For your wireless have you tried using another wireless connection program? just a guess.

what Desktop Enviroment are you using? I found that KDE on suse was a bit slugish as well. Gnome is much faster though, Enlightenment is ok, i havent tried XFCE, maybe ICEWM?

crazibri 11-24-2005 11:13 AM

Just to follow up, my ATI integrated is RS200 4337. the 3d support with glrfx works perfect except for suspend. Suspend just hangs after I try it, so basically for me right now thats the only button I have that has a "dont touch" sign on it.

parsek77 12-14-2005 08:50 AM

what is the size of your swap partiton?
 
Quote:

Originally Posted by jack.s-suse
I have a dv1220 and SUSE works like a dream. ACPI support is purfect, hibernate, standby, and cpu scaling all work fine. I dont have any problem with graphics or wireless because they are both made by Intel. (intel pro/wireless, and intel extreme graphics). What really supprised me is that the light that tells me when i am connected to a network also works.

For your wireless have you tried using another wireless connection program? just a guess.

what Desktop Enviroment are you using? I found that KDE on suse was a bit slugish as well. Gnome is much faster though, Enlightenment is ok, i havent tried XFCE, maybe ICEWM?

This is good for you. What I am wandering is that your swap partition and memory sizes. I read somewhere that the swap partition's size should be at least the size of the memory for standby. Is this correct? Because I will install Suse 10.0 on my new laptop and I'll have 1.5GB memory. According to this I'll adjust my swap. Thanks.

Cogar 12-14-2005 01:13 PM

Quote:

Originally Posted by parsek77
This is good for you. What I am wandering is that your swap partition and memory sizes. I read somewhere that the swap partition's size should be at least the size of the memory for standby. Is this correct? Because I will install Suse 10.0 on my new laptop and I'll have 1.5GB memory. According to this I'll adjust my swap. Thanks.

The rule of thumb I heard is twice your RAM, although that may be more applicable for people with lower RAM (say, less than 512 MB). Anyway, if you have sufficient space available (hard to guess, since laptops vary so much), you might consider running a 2 GB swap partition. If space is a little tight (less than 30 GB hard drive space), 1 GB should be OK.

bob@racote.com 12-18-2005 09:40 PM

Has anyone had experience with the HP Pavillion 1310? It seems to have a couple of glitches. It reports the eth0 interface as busy and cannot seem to find the wireless.

Bob

bob@racote.com 12-29-2005 07:28 PM

Answering my own question--
A couple of things regarding the HP Pavilion DV1310 and SuSE 10.0.
I had trouble with APCI install, so I went with out it.
While I did not have trouble with eth0 after this, it still did not recognize the wireless interface. A check with the Windows hardware list showed the wireless is a Broadcom device. I followed suggestions from a couple of other sites that suggested the ndiswrapper utility. I followed these steps and then set up the security.

ndiswrapper -i bcmwl5.inf
ndiswrapper -l
ndiswrapper -m
ndiswrapper -hotplug

It was very gratifying when little blue wireless light came on.


All times are GMT -5. The time now is 10:36 PM.