LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 10-09-2006, 09:22 AM   #1
jadukor
Member
 
Registered: Nov 2005
Location: Bangladesh
Distribution: openSUSE
Posts: 83

Rep: Reputation: 15
Howto make Samba work on Suse10.1


Hi all

I am a novice user & I have just switched over to Suse10.1 from
Slackware10.2
(been running Slackware since Slackware9.1)

I have 4 PC connected to a home LAN. 1 running Linux, & others are
running WinXP

1)
I have (somewhat) setup samba using Yast, but the thing is, if the
firewall turned off, then I am able to access the LAN from my Suse box,
otherwise it says "Unable to find any workgroups in your local network.
This might be caused by an enabled firewall." But as far as I can
recall there was an option during samba configuration to "Open Firewall
ports"... which I did... so what could be going wrong??

The XP boxes are able to access my samba server without any problem though.

I am also pasting my /etc/samba/smb.conf

Thanks in advance :-)
Emon

# smb.conf is the main Samba configuration file. You find a full commented
# version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
# samba-doc package is installed.
# Date: 2006-05-02
[global]
workgroup = LANLINK
bind interfaces only = true
interfaces = eth0 192.170.0.1
hosts allow = 192.170.0.0/255.255.255.0 127.0.0.1
log level = 1
log file = /var/log/samba/log.%m
max log size = 1024
printing = cups
printcap name = cups
printcap cache time = 750
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain logons = No
domain master = No
netbios name = magicbox
security = user
[homes]
comment = Home Directories
valid users = %S, %D%w%S
browseable = No
read only = No
inherit acls = Yes
[profiles]
comment = Network Profiles Service
path = %H
read only = No
store dos attributes = Yes
create mask = 0600
directory mask = 0700
[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/
[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes
[printers]
comment = All Printers
path = /var/tmp
printable = Yes
create mask = 0600
browseable = No
[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin root
force group = ntadmin
create mask = 0664
directory mask = 0775
[share]
inherit acls = Yes
path = /media/hd/MAGICSTORE/share/
read only = No
create mask = 0775
browseable = Yes
public = yes
 
Old 10-09-2006, 09:45 AM   #2
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
either configure NIC as internal zone (all services accessible in LAN, none outside), or as external zone and open tcp139 (in this case you don't need tcp445, or close 139 and open 445)

if you configure external zone, then you can harden samba a little bit (unless behind firewall)

configuring zone:
Yast -> Security and users -> Firewall -> Interfaces
right click on the NIC you want to use and change zone. Next, if you selected external zone click on "allowed services" and add "Samba server"
This option will be greyed out if you selected internal zone as all servicess are allowed in internal zone


also check
/etc/sysconfig/SuSEfirewall2
and configure allowed tcp/udp ports

this would be tcp139 (not udp139),
and eventually udp 138, udp 137 (not tcp, this is common error)
 
Old 10-10-2006, 09:24 AM   #3
jadukor
Member
 
Registered: Nov 2005
Location: Bangladesh
Distribution: openSUSE
Posts: 83

Original Poster
Rep: Reputation: 15
Thanks

Can you please clarify how to change those ports & stuff...... I an no genius, so a little bit of spoon feeding might help :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HOWTO Make TV Out work under ati chips PEACEYALL Linux - Hardware 2 05-18-2006 12:16 AM
ATI TV Card - Howto make it work? Micah Linux - Hardware 1 06-17-2005 08:53 AM
A wierd problem( Howto make programms work under normal user) k0ljat Linux - Software 2 09-01-2004 01:11 AM
howto make work cgi moonloader Slackware 1 08-19-2004 02:04 PM
howto: MAke a symlink to a samba share??? trey85stang Mandriva 1 03-14-2004 06:43 PM


All times are GMT -5. The time now is 09:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration