LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 01-03-2007, 02:22 AM   #1
doobie_doobie_doo
LQ Newbie
 
Registered: May 2006
Distribution: SuSE
Posts: 4

Rep: Reputation: 0
Post HOWTO: Correct "Out of Range" error for LCD monitor on SuSE 10.1 boot


This is no longer an issue, however, it was such a bear to get around that I felt it my job to share my solution.

To be specific, I've upgraded to a Viewsonic VA721 monitor not too long ago and have been fighting with my SuSE installations ever since (9.2 & 10.1). After googling until my eyes were bleeding, I found no luck using the standard solutions. A few things that I tried:

1. Manually modified Xorg.conf. Various posts all of the Internet suggest that modifying a handful of lines (e.g., Section Screen and Modes, etc) correct the issue. No luck.
2. Run SaX2 in text mode. This was useful in order to better configure the monitor's default settings, but did not resolve the fundamental issue at hand.
3. Disabled graphical splash screen at boot time. This seemed promising and actually sent me in the right direction, but did not in itself correct the issue.

Finally, and just in time, I found that the issue was actually being caused by the Grub boot loader configuration that was installed by default (when my monitor was a standard CRT).

The solution that did work:

1. Updated "VGA Mode" to "1024x768, 16 bits (791)". A search or two revealed a few common VGA modes for LCD monitors and shortly there after I found the lucky winner.
2. Updated "Other Kernel Parameters" to "showopts resume=/dev/hdb1 splash=silent". Probably not necessary, but is helpful when testing VGA modes without going through the GUI Grub boot loader configuration utility.

Hope this helps someone out there!

Thanks,
Dylan
 
Old 05-03-2007, 01:39 PM   #2
shango
LQ Newbie
 
Registered: Apr 2007
Posts: 6

Rep: Reputation: 0
Hello, I too have this problem.

When you say that you updated vga mode etc...
Which config file did you edit to accomplish this?


Quote:
Originally Posted by doobie_doobie_doo
This is no longer an issue, however, it was such a bear to get around that I felt it my job to share my solution.

To be specific, I've upgraded to a Viewsonic VA721 monitor not too long ago and have been fighting with my SuSE installations ever since (9.2 & 10.1). After googling until my eyes were bleeding, I found no luck using the standard solutions. A few things that I tried:

1. Manually modified Xorg.conf. Various posts all of the Internet suggest that modifying a handful of lines (e.g., Section Screen and Modes, etc) correct the issue. No luck.
2. Run SaX2 in text mode. This was useful in order to better configure the monitor's default settings, but did not resolve the fundamental issue at hand.
3. Disabled graphical splash screen at boot time. This seemed promising and actually sent me in the right direction, but did not in itself correct the issue.

Finally, and just in time, I found that the issue was actually being caused by the Grub boot loader configuration that was installed by default (when my monitor was a standard CRT).

The solution that did work:

1. Updated "VGA Mode" to "1024x768, 16 bits (791)". A search or two revealed a few common VGA modes for LCD monitors and shortly there after I found the lucky winner.
2. Updated "Other Kernel Parameters" to "showopts resume=/dev/hdb1 splash=silent". Probably not necessary, but is helpful when testing VGA modes without going through the GUI Grub boot loader configuration utility.

Hope this helps someone out there!

Thanks,
Dylan
 
Old 05-04-2007, 01:41 AM   #3
doobie_doobie_doo
LQ Newbie
 
Registered: May 2006
Distribution: SuSE
Posts: 4

Original Poster
Rep: Reputation: 0
Shango,

Try the following and I think you should be all set:

1. Goto YaST
2. Proceed to System group, and select the Boot Loader object.
3. Select the appropriate section/boot configuration.
4. Click Edit.
5. Put "1024x768, 16 bits (791)" in the VGA Mode field, and click Ok, Next, etc.

Once that has been committed and the boot loader configuration is updated, reboot and (hopefully) enjoy!

Let me know if this works for you.

Thanks,
Dylan
 
Old 02-06-2008, 04:06 AM   #4
aereb
LQ Newbie
 
Registered: Jan 2008
Posts: 1

Rep: Reputation: 0
Thumbs up out of range - refresh rate error

bleed my i's too, didn't find anything - tried xorg, x11 ......

Sol: DON'T have to change anything (files)

The problem is the Monitor config - manually select a generic LCD monitor = PnP type.

Open the Display config from System > Admin > Display menu

Select the H/W tab

Select Monitor and config

Select Generic LCD => 1280 x 1024 (or any)

apply & restart
 
  


Reply

Tags
lcd, suse, viewsonic


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Monitor Error "Out Of Frequency Range" GCZFFL Ubuntu 6 03-06-2007 05:22 AM
LCD monitor: "out of scan range" won't load gui...how to add or configure peetkato Linux - Newbie 4 01-31-2006 07:29 AM
Why do i get an "out of range" error on my monitor when i turn on suse9.1 linux? bobby1970 Linux - Hardware 4 06-24-2005 05:25 AM
"Out-Of-Range" monitor error on 1st boot after install wingnut2292 Fedora 0 09-19-2004 01:42 AM
LCD monitor "out of range" truthseer Linux - Hardware 1 11-21-2003 03:09 AM


All times are GMT -5. The time now is 07:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration