LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 08-07-2005, 05:11 PM   #1
carcassonne
Member
 
Registered: Jul 2005
Distribution: Fedora6 x86_64
Posts: 118

Rep: Reputation: 15
How to turn off cdrom recognition ?


Hi all,

I'm using SuSE 9.3. When I insert a cdrom eventually a KDE file manager window will pop up showing the contents of the cdrom. I don't want that. How can I turn that automatic stuff off ?

Cheers.
 
Old 08-07-2005, 08:49 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,474

Rep: Reputation: 155Reputation: 155
"I'm using SuSE 9.3. When I insert a cdrom eventually a KDE file manager window will pop up showing the contents of the cdrom. I don't want that. How can I turn that automatic stuff off ?"

Edit /etc/fstab and remove the automount parameter from the line that describes your cdrom.

------------------------
Steve Stites
 
Old 08-07-2005, 09:14 PM   #3
carcassonne
Member
 
Registered: Jul 2005
Distribution: Fedora6 x86_64
Posts: 118

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by jailbait
Edit /etc/fstab and remove the automount parameter from the line that describes your cdrom.
The actual fstab line looks like this (I've broken it down for screen formatting):

/dev/dvdram
/media/dvdram
subfs
noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

Hmmm. It says noauto in there, so it's not mounted at startup. But this new-to-kernel 2.6 feature of hotplugging makes it recognized when a disk is inserted and then it's eventually relayed to KDE who'll pop up a window.

I have the same problem with hard disks connected by means of an IDE to USB adapter. As soon as the disk is connected the kernl works then KDE pops up a window with the content of the drive.

I don't have the impression that it has something to do with fstab.

Cheers.
 
Old 08-07-2005, 09:34 PM   #4
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 47
This should help... subfs being the key here...
http://portal.suse.com/sdb/en/2004/0...rom_subfs.html

KC
 
Old 08-08-2005, 07:09 AM   #5
carcassonne
Member
 
Registered: Jul 2005
Distribution: Fedora6 x86_64
Posts: 118

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by kencaz
This should help... subfs being the key here...
http://portal.suse.com/sdb/en/2004/0...rom_subfs.html
That looked very fine... until I opened the /etc/sysconfig/hotplug file and found out that there's no such variable !

I'm using 9.3. The hint was made for 9.1.

I'll keep on looking. If someone has an idea how to stop automounting of USB drives and CDROMS, let me know.


Cheers.
 
Old 08-08-2005, 07:45 AM   #6
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Turning off the hal daemon should help, then you'll have to put entries into fstab like you normally would andmount manually.
 
Old 08-08-2005, 09:05 AM   #7
carcassonne
Member
 
Registered: Jul 2005
Distribution: Fedora6 x86_64
Posts: 118

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Looking_Lost
Turning off the hal daemon should help, then you'll have to put entries into fstab like you normally would andmount manually.
That worked. Specifically what I did is to remove any reference to hal in the files:

/etc/init.d/.depend.start
/etc/init.d/.depend.stop

Thanks.
 
Old 08-08-2005, 02:39 PM   #8
Looking_Lost
Senior Member
 
Registered: Apr 2003
Location: Eire
Distribution: Slackware 12.0, OpenSuse 10.3
Posts: 1,120

Rep: Reputation: 45
Just for future reference, to turn off/on services you can use chkconfig or Yast runlevel editor rather than altering the actual contents of files if it isn't really necessary to do so.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to start, stop, turn on, and turn off deamons BuckRogers01 Debian 3 08-16-2005 09:39 AM
turn off doesn't really turn and power off pcandpc Mandriva 11 05-30-2005 03:22 PM
recognition Kane2002 General 7 01-24-2005 03:44 PM
How to turn off Xserver in the gui and turn it off in the command line geminiviper Linux - Newbie 8 08-20-2004 08:05 AM
k3b cdrom recognition problem TweakerFD Linux - Software 1 08-23-2003 03:33 PM


All times are GMT -5. The time now is 06:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration