LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   How to turn off cdrom recognition ? (http://www.linuxquestions.org/questions/suse-novell-60/how-to-turn-off-cdrom-recognition-350926/)

carcassonne 08-07-2005 05:11 PM

How to turn off cdrom recognition ?
 
Hi all,

I'm using SuSE 9.3. When I insert a cdrom eventually a KDE file manager window will pop up showing the contents of the cdrom. I don't want that. How can I turn that automatic stuff off ?

Cheers.

jailbait 08-07-2005 08:49 PM

"I'm using SuSE 9.3. When I insert a cdrom eventually a KDE file manager window will pop up showing the contents of the cdrom. I don't want that. How can I turn that automatic stuff off ?"

Edit /etc/fstab and remove the automount parameter from the line that describes your cdrom.

------------------------
Steve Stites

carcassonne 08-07-2005 09:14 PM

Quote:

Originally posted by jailbait
Edit /etc/fstab and remove the automount parameter from the line that describes your cdrom.

The actual fstab line looks like this (I've broken it down for screen formatting):

/dev/dvdram
/media/dvdram
subfs
noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

Hmmm. It says noauto in there, so it's not mounted at startup. But this new-to-kernel 2.6 feature of hotplugging makes it recognized when a disk is inserted and then it's eventually relayed to KDE who'll pop up a window.

I have the same problem with hard disks connected by means of an IDE to USB adapter. As soon as the disk is connected the kernl works then KDE pops up a window with the content of the drive.

I don't have the impression that it has something to do with fstab.

Cheers.

kencaz 08-07-2005 09:34 PM

This should help... subfs being the key here...
http://portal.suse.com/sdb/en/2004/0...rom_subfs.html

KC

carcassonne 08-08-2005 07:09 AM

Quote:

Originally posted by kencaz
This should help... subfs being the key here...
http://portal.suse.com/sdb/en/2004/0...rom_subfs.html

That looked very fine... until I opened the /etc/sysconfig/hotplug file and found out that there's no such variable !

I'm using 9.3. The hint was made for 9.1.

I'll keep on looking. If someone has an idea how to stop automounting of USB drives and CDROMS, let me know.


Cheers.

Looking_Lost 08-08-2005 07:45 AM

Turning off the hal daemon should help, then you'll have to put entries into fstab like you normally would andmount manually.

carcassonne 08-08-2005 09:05 AM

Quote:

Originally posted by Looking_Lost
Turning off the hal daemon should help, then you'll have to put entries into fstab like you normally would andmount manually.
That worked. Specifically what I did is to remove any reference to hal in the files:

/etc/init.d/.depend.start
/etc/init.d/.depend.stop

Thanks.

Looking_Lost 08-08-2005 02:39 PM

Just for future reference, to turn off/on services you can use chkconfig or Yast runlevel editor rather than altering the actual contents of files if it isn't really necessary to do so.


All times are GMT -5. The time now is 03:18 PM.