LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 02-22-2009, 12:02 PM   #16
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957

You do not remove anything necessary if you completely remove the two lines. Your PATH is set up somewhere else. These two lines just overwrite the content of the already existing PATH variable. Consider the command you issued:
Code:
# echo "PATH=$PATH: /usr/lib/tcl/" >> ~/.bashrc
this told to echo the value of the PATH variable. You see this value has been expanded by the shell before actually writing the line in .bashrc. This means the PATH was already set before. Just remove the two lines, save and quit. Then close the root's session and start a new one (that is just open another terminal and do su - again). Do
Code:
echo $PATH
and check if it is correct.
 
Old 02-22-2009, 12:08 PM   #17
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
Quote:
Originally Posted by raju.mopidevi View Post
Thank you very much for replying me !!
i had edited those 2 lines .
I had deleted the statements after : at the end of each of two lines
" /usr/lib/tcl"
and " /usr/lib/tcl/"
Now i am not getting any error message after opening of terminal in "su" mode .

Thanks to all .
I'd completely remove those two lines! Take in mind that setting the PATH in this way, that is in a fixed format with all the directories already expanded, avoid to do any modification to the PATH variable - if the system do such a modification in a step prior to the sourcing of the ~/.bashrc file.
 
Old 02-22-2009, 12:11 PM   #18
raju.mopidevi
Senior Member
 
Registered: Jan 2009
Location: vijayawada, India
Distribution: openSUSE 11.2, Ubuntu 9.0.4
Posts: 1,155
Blog Entries: 12

Original Poster
Rep: Reputation: 92
Thumbs up

Thanks for "colucix"
I had deleted those 2 lines . It is working nice .
Today i had learned a lot from you . thanks a lot
 
Old 02-22-2009, 12:14 PM   #19
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
You're welcome!
 
  


Reply

Tags
path, variables


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting PATH variable Aigarzs Linux - Newbie 2 02-07-2008 03:27 PM
Trouble setting PATH variable krutten1986 Suse/Novell 4 09-04-2006 02:21 PM
Setting Path Variable for LibXML2 Miyamoto Linux - Software 1 08-19-2003 10:00 AM
Help setting $PATH variable Nylex Linux - General 9 08-09-2003 12:44 PM
setting path variable shahrahulb Linux - General 2 07-30-2003 09:25 PM


All times are GMT -5. The time now is 08:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration