LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Suse/Novell (http://www.linuxquestions.org/questions/suse-novell-60/)
-   -   How to set the path for pkg-config?? (http://www.linuxquestions.org/questions/suse-novell-60/how-to-set-the-path-for-pkg-config-412125/)

westman 02-06-2006 03:05 AM

How to set the path for pkg-config??
 
Hi,
I have a problem installing gaim in SLES 9. When I tried to configure(./configure)the source file, I get an error message showing that pkg-config is missing and it failed to find glib2. But I've already installed both! So, what is the problem here? At the end of the configuration, it also says something about PKG_CONFIG_PATH. Actually, what is that? Hope someone can help me takcle this problem. TQ

abisko00 02-06-2006 03:20 AM

If pkg-config is installed it can be found in /usr/bin, so you could run ./configure PKG_CONFIG_PATH=/usr/bin. But usually this should not be required. In case of glib2, make sure the 'devel' package is installed. Also check the version requirement of your software.

bretts5964 02-07-2006 12:53 AM

A few ideas...
 
Have you seen these write-ups?

How to build RPMs for SuSE 9.2 x86_64
http://blog.mecworks.com/articles/20...use-92-x86_64/

How to Build Gaim for SUSE Linux 9.1...
http://www.novell.com/coolsolutions/feature/1583.html

I have done the compile thing with Gaim before, but have since forgotten what I learned. I ultimately gave up on compiling, and my solution for apps like Gaim was to find a few reliable YAST repositories where I could get the latest stable versions. With Gaim in particular, it's difficult to get a compatible version of gaim-encryption, but I get mine from the Guru site now:

Guru's RPM Site: Home Packages Network gaim
http://linux01.gwdg.de/~pbleser/rpm-...=Network/gaim/

If you have other reasons for wanting to compile, then I'd be interested to hear them. I only ask because it seems like you're trying to mix oil and water. SLES 9 came out in August of 2004, and you're trying to install a cutting edge desktop app like Gaim 1.5.

Good luck,
Brett

westman 02-07-2006 09:24 PM

Continueee...
 
Hi again,

Hey Brett, thanks for the info and url. It certainly give me new knowledge.

FYI, I've already done it before(compiling gaim1.5) and successfully installed it. But I forgot the steps how I accomplished the job and having a difficult time remembering it.Hehe...

Right now, I'm facing a new problem. The pkg-config is now working, but the gtk+ seems have gone missing.

Quote:

checking for pkg-config... /usr/local/bin/pkg-config
checking for GLIB - version >= 2.0.0... yes (version 2.2.3)
checking for pkg-config... (cached) /usr/local/bin/pkg-config
checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occurred. This usually means GTK+ is incorrectly installed.configure: error:
*** GTK+ 2.0 is required to build Gaim; please make sure you have the GTK+
*** development headers installed. The latest version of GTK+ is
*** always available at http://www.gtk.org/.
I checked with the yast and found that gtk2 (version 2.2.4) was already installed(or did I:confused: ). I don't know if I have to configure gtk or not in this case. Any idea?

reddazz 02-07-2006 10:16 PM

You need to install the development packages of gtk2 and glib2, not just the binaries. Search for gtk and glib using yast and you should find the development (devel) packages.


All times are GMT -5. The time now is 02:55 PM.