LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 12-25-2005, 07:30 AM   #1
akshay_jp
LQ Newbie
 
Registered: Sep 2005
Location: Bangalore,India
Distribution: Ubuntu dapper
Posts: 26

Rep: Reputation: 15
how to set permissions for normal users to access windows hard drives on suse 10?


hi people thanks for all the help obtained.....

now i have another problem.. i have win 2k and suse 10 running in parallel... as root i can acces the files in my windows (NTFS and FAT) drives... but get the permission denied message if i try it as a normal user...
i need to know how to set the permissions for normal users to access any (or all files) in the windows drive...

i used the chmod 777 * for the purpose but dint seem to work... please help...
i wish to access the files till the end of the directory structure in the windows drive.... as a normal user...

thanks in advance

akshay
 
Old 12-25-2005, 09:25 AM   #2
mhowell
LQ Newbie
 
Registered: Jan 2005
Posts: 23

Rep: Reputation: 15
to access fat and ntfs files from normal user account you will have to change the fstab. To change it open up a Konsole and run kdesu kate /etc/fstab

you will have a file looking similar to this:

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / reiserfs notail 0 1
/dev/hdc /media/cdrom0 udf,iso9660 ro,user,noauto 0 0
/dev/hda5 /windows/server vfat defaults 0 0
/dev/hdb1 /windows/audio ntfs defaults 0 0
/dev/fd0 /media/floppy0 auto defaults 0 0

any line with ntfs or fat as type remove what is in the options section and add rw,user,users,auto,umask=0000 so it looks similar to

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / reiserfs notail 0 1
/dev/hdc /media/cdrom0 udf,iso9660 ro,user,noauto 0 0
/dev/hda5 /windows/server vfat rw,user,users,auto,umask=0000 0 0
/dev/hdb1 /windows/audio ntfs rw,user,users,auto,umask=0000 0 0
/dev/fd0 /media/floppy0 auto defaults 0 0

Save this and when you restart the computer the drives will be available to everyone. Fat wil be read/write to everyone NTFS will only be read.

hope that helps
 
Old 12-25-2005, 09:55 AM   #3
Keruskerfuerst
Member
 
Registered: Oct 2005
Location: Lat: 482356N, Lon: 104145E
Distribution: Gentoo 2006
Posts: 719

Rep: Reputation: 31
You should not try to write a ntfs filesystem. So the lines in fstab should look like follows:
/dev/hda5 /windows/server vfat ro,user,users,auto,umask=0000 0 0
/dev/hdb1 /windows/audio ntfs ro,user,users,auto,umask=0000 0 0
 
Old 12-25-2005, 10:28 AM   #4
mhowell
LQ Newbie
 
Registered: Jan 2005
Posts: 23

Rep: Reputation: 15
Quote:
Originally Posted by Keruskerfuerst
You should not try to write a ntfs filesystem. So the lines in fstab should look like follows:
/dev/hda5 /windows/server vfat ro,user,users,auto,umask=0000 0 0
/dev/hdb1 /windows/audio ntfs ro,user,users,auto,umask=0000 0 0
those trwo sets of lines would make the vfat partition read only aswell, instead of read/write.

any vfat partitions should have rw as an options and ntfs should have the option ro instead.

that should solve the problems and prevent any problems happening if ntfs was attempted to be written to.
 
Old 12-25-2005, 12:33 PM   #5
akshay_jp
LQ Newbie
 
Registered: Sep 2005
Location: Bangalore,India
Distribution: Ubuntu dapper
Posts: 26

Original Poster
Rep: Reputation: 15
thank u note

thanks ppl i lltry tat out as soon as i log out of stupid(sorry no hard feelings) windows!!!!

akshay
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sharing SUSE 9.3 Hard Drives with Windows XP nutsobilly Linux - Networking 4 12-14-2005 09:24 PM
How to disable password changing permissions to normal users ? toraghun Linux - Newbie 14 11-17-2005 10:17 AM
Allowing normal users read-write access to Windows partitions Aphex_Twin2 Slackware 5 05-23-2005 09:22 AM
Captive-ly mounted drives not available to normal users azdruid Linux - Newbie 1 05-01-2005 03:43 PM
Cant mount cdrom in normal user, tried to set permissions, no work. Kindly help me. RHLinuxGUY Slackware 2 09-13-2004 09:35 PM


All times are GMT -5. The time now is 07:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration