LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 02-16-2008, 10:31 AM   #1
vitalstrike82
Member
 
Registered: Oct 2007
Location: Singapore
Distribution: OpenSuse, Slackware, Redhat
Posts: 315

Rep: Reputation: 40
How to mount external hard drive


I using Suse 10.3. When i use i system, i do not use as root user.
Mount a external hard drive requires me to open a terminal and log in as root.

After logging in as root, i type this to mount the sdb1 to directory /media/root.
Code:
mount /dev/sdb1 /media/hd
However this method only enables the root to view the contents in the external hard disk. How do i mount so that i when i log in as a user to view the contents of the external hard drive?

Thanks
 
Old 02-16-2008, 10:47 AM   #2
budword
Member
 
Registered: Apr 2003
Location: Wisconsin
Distribution: Switched to regualr Ubuntu, because I don't like KDE4, at all. Looks like vista on crack.....
Posts: 675

Rep: Reputation: 31
This should help...I really ought to write up my own howto just for this site, as this question gets asked quite a bit. Let us know if this doesn't answer your question.

http://www.novell.com/coolsolutions/feature/11637.html

By the way, kde does this for you, and I think gnome does too, though it's been a while since I've used gnome. What desktop are you using ?

David
 
Old 02-16-2008, 06:33 PM   #3
pilotgi
Member
 
Registered: Apr 2002
Location: ks
Distribution: openSUSE 12.2 64 bit
Posts: 488

Rep: Reputation: 32
If you're using KDE, it should prompt you if you want to mount the drive automatically.

First, make sure the external drive is on before you plug it in. After plug in, a window should pop up asking you if you would like to open the device in a new window. Just select yes/accept and the drive will be mounted for you.
 
Old 02-17-2008, 12:27 AM   #4
vitalstrike82
Member
 
Registered: Oct 2007
Location: Singapore
Distribution: OpenSuse, Slackware, Redhat
Posts: 315

Original Poster
Rep: Reputation: 40
I'm using kde but when insert the USB external hd, it detects automatically but when i open it, it reply

Code:
hal-storage-mount-removable-extra-options auth_self_keep_always <-- (action, result)
So manually mount the HD enables me to read the contents inside the hard disk but as root user.

Anyway, learning to mount using root account and make it available to all users is something new i can learn and i'm quite looking forward to the solutions for this issue. So i do not really bother why it cannot automatically detect previously.

Since i'm asking this question, i might as well ask y it prompt this error when i plug in my HD?

Thanks

Last edited by vitalstrike82; 02-17-2008 at 12:30 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot mount external hard drive thisObject Linux - Software 4 12-06-2006 11:53 PM
cannot mount external hard drive vash331 Linux - Newbie 1 12-31-2005 07:19 AM
Can't mount external hard drive...HELP! Stevetgn Linux - Hardware 4 10-18-2005 07:38 PM
can't mount fs on external hard drive fatblueduck Linux - General 11 06-10-2005 03:03 PM
external hard drive mount omarbohsali Linux - Newbie 4 04-27-2005 09:24 PM


All times are GMT -5. The time now is 10:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration