LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 01-26-2006, 01:58 PM   #1
Red Knuckles
Member
 
Registered: Jan 2006
Location: Colorado USA
Distribution: Debian AMD 64 Testing, Sabayon Linux x86-64 3.4, and Ubuntu AMD 64 7.04
Posts: 235

Rep: Reputation: 30
Question How to launch Thunderbird from Firefox.


How do I launch Thunderbird from the 'Mail' icon in the navigation bar in Firefox? Also, in general I don't understand how to set preferences in Suse [KDE]. I've also used Fedora and Ubuntu with Gnome. So how do I set preferred apps, such as Thunderbird, in Suse KDE??? For instance if in Firefox or Konqueror I click on "File>Send Link" I want it to use Thunderbird. How do I do this?
 
Old 01-26-2006, 02:06 PM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
To change default apps, you need to do Kcontrol -> KDE Components. As for enabling emailing from Firefox, take a look at this article.
 
Old 01-26-2006, 02:08 PM   #3
Randall Slack
Member
 
Registered: Feb 2005
Location: Rotterdam, The Netherlands
Distribution: Debian - Ubuntu
Posts: 219

Rep: Reputation: 30
klick the green lizard at the left bottom-controlcenter-KDE components-Component chooser-and fill in thunderbird as emailcient
 
Old 01-26-2006, 02:12 PM   #4
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Rep: Reputation: 45
Doesn't work for me in SUSE 10
 
Old 01-26-2006, 02:19 PM   #5
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Works for me. As soon as you have default, you can even set in FireFox how to open the new windows coming in from external programs... new tab, new window, current window. YOu just need to set Thunderbird as the default mail client, and then make sure FireFox has no actions set for mail. So long as KDE knows what your default is, and once you login/logout(to change settings) you are fine, and the read mail will work from FF to open Thunderbird. All it does is read your system default, though there are a few extensions that can help you use non defaults.
 
Old 01-26-2006, 03:02 PM   #6
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Rep: Reputation: 45
Have you got the name as thunderbird or "thunderbird" or /usr/bin/thunderbird or "/usr/bin/thunderbird".

http://img215.imageshack.us/img215/9...mailclenit.jpg

[EDIT] Added image

Last edited by Jongi; 01-26-2006 at 03:06 PM.
 
Old 01-26-2006, 05:00 PM   #7
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Quote:
thunderbird
I browsed to it with the menu and let it select it. But it is the command you would use in the terminal to run the program, exactly as in the terminal.
 
Old 01-26-2006, 06:30 PM   #8
Red Knuckles
Member
 
Registered: Jan 2006
Location: Colorado USA
Distribution: Debian AMD 64 Testing, Sabayon Linux x86-64 3.4, and Ubuntu AMD 64 7.04
Posts: 235

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by reddazz
To change default apps, you need to do Kcontrol -> KDE Components. As for enabling emailing from Firefox, take a look at this article.
I was able to learn how to set preferences in 'Kcontrol>KDE Components> Component Chooser'. I haven't been able to get thunderbird to open from firefox yet as per the suggested article. Am continuing research. If anyone has more ideas/suggestions would be happy to hear from you.
 
Old 01-26-2006, 06:35 PM   #9
Red Knuckles
Member
 
Registered: Jan 2006
Location: Colorado USA
Distribution: Debian AMD 64 Testing, Sabayon Linux x86-64 3.4, and Ubuntu AMD 64 7.04
Posts: 235

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by RedShirt
Works for me. As soon as you have default, you can even set in FireFox how to open the new windows coming in from external programs... new tab, new window, current window. YOu just need to set Thunderbird as the default mail client, and then make sure FireFox has no actions set for mail. So long as KDE knows what your default is, and once you login/logout(to change settings) you are fine, and the read mail will work from FF to open Thunderbird. All it does is read your system default, though there are a few extensions that can help you use non defaults.
As noted in previous post I haven't gotten it to work for me yet. Is it possible I'm missing something?
 
Old 01-26-2006, 06:45 PM   #10
Red Knuckles
Member
 
Registered: Jan 2006
Location: Colorado USA
Distribution: Debian AMD 64 Testing, Sabayon Linux x86-64 3.4, and Ubuntu AMD 64 7.04
Posts: 235

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Jongi
Have you got the name as thunderbird or "thunderbird" or /usr/bin/thunderbird or "/usr/bin/thunderbird".

http://img215.imageshack.us/img215/9...mailclenit.jpg

[EDIT] Added image
So far I have tried thunderbird [w/o quotes] and /usr/bin/thunderbird [w/o quotes]. Neither has worked yet.
 
Old 01-26-2006, 07:29 PM   #11
Red Knuckles
Member
 
Registered: Jan 2006
Location: Colorado USA
Distribution: Debian AMD 64 Testing, Sabayon Linux x86-64 3.4, and Ubuntu AMD 64 7.04
Posts: 235

Original Poster
Rep: Reputation: 30
Question

Quote:
Originally Posted by reddazz
To change default apps, you need to do Kcontrol -> KDE Components. As for enabling emailing from Firefox, take a look at this article.

Ok, I now am able to get thunderbird to open from firefox EXCEPT for 'Read Mail'. It will now open from 'New Message' from the icon on the nav bar and will open from 'File>Send Links'. Oddly it will not open thunderbird from 'Read Mail' from the icon in the nav bar.

What I did was per the 'article' mentioned above I open firefox and went to URL 'about:config' and changed 'value' from '/usr/bin/thunderbird' to simply 'thunderbird'. That has led to the current operating conditions. In 'Kcontrol>KDE Components>Component Chooser' I currently selected from the Box [...] next to the space 'Use a different e-mail client' thunderbird as per the drop down window. I'm curious as to why thunderbird doesn't open from the 'Read Mail' command but DOES from the 'New Message' command???
 
Old 01-27-2006, 04:54 AM   #12
abisko00
Senior Member
 
Registered: Mar 2004
Location: Munich
Distribution: SuSE, Ubuntu
Posts: 3,511

Rep: Reputation: 58
I followed the instructions from reddazz's link exactly, appart from using /usr/bin/thunderbird, rather than /usr/bin/mozilla-thunderbird. It works perfectly!

Code:
3) If you do NOT have network.protocol-handler.app.mailto (normally
you don't), create it using these steps:
  a) right-click
  b) choose New --> String
  c) new string: network.protocol-handler.app.mailto
  d) new value: /usr/bin/thunderbird
Thanks, reddazz! I was trying to solve this problem for quite a while now.
 
Old 01-27-2006, 08:49 AM   #13
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Quote:
So far I have tried thunderbird [w/o quotes] and /usr/bin/thunderbird [w/o quotes]. Neither has worked yet.
What you probably need to do, is not type it yourself. There is a box next to the text box in the kcontrol center section for the component chooser. It is a little box with three dots(an ellipsis or "...". It means browse. Click on that it will bring up a browsing, go to Thunderbird that way and let it set it. Then logout/login and give it a whirl.
 
Old 01-27-2006, 11:30 AM   #14
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Rep: Reputation: 45
That article did the trick
 
Old 02-22-2006, 02:26 PM   #15
Red Knuckles
Member
 
Registered: Jan 2006
Location: Colorado USA
Distribution: Debian AMD 64 Testing, Sabayon Linux x86-64 3.4, and Ubuntu AMD 64 7.04
Posts: 235

Original Poster
Rep: Reputation: 30
Smile

Quote:
Originally Posted by RedShirt
What you probably need to do, is not type it yourself. There is a box next to the text box in the kcontrol center section for the component chooser. It is a little box with three dots(an ellipsis or "...". It means browse. Click on that it will bring up a browsing, go to Thunderbird that way and let it set it. Then logout/login and give it a whirl.
I upgraded to Firefox 1.5 and Thunderbird 1.5 and now everything works as expected.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Thunderbird and Firefox, Thunderbird doesnt launch firefox? sovietpower Slackware 1 11-01-2004 12:51 PM
Thunderbird only launch as root chug Linux - Newbie 4 07-26-2004 02:55 PM
launch script for thunderbird? webazoid Linux - Software 2 07-11-2004 09:31 PM
Can't launch thunderbird. akihandyman Mandriva 5 06-23-2004 05:42 PM
Thunderbird won't launch from launcher davedorm Linux - Software 9 10-18-2003 09:57 PM


All times are GMT -5. The time now is 07:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration