LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 12-18-2005, 10:31 PM   #1
chmtdist
LQ Newbie
 
Registered: Oct 2005
Distribution: SuSE Debian, other stuff?
Posts: 7

Rep: Reputation: 0
how to get dri working with ATI radeon xpress 200m


The goal of this is to get the output of 'glxinfo|grep direct' to say:
"Direct rendering: yes" instead of no.

My graphics card is a ati radeon xpress 200m and I am using the radeon driver for X. The man page for radeon says that my card is supported. I am on suse 10 x86_64. The kernel module fglrx is loaded.

Does anyone know how to get direct rendering working. Or in which direction to point me? I think it has some thing to do with Mesa.
I compiled mesa with 'make linux-dri-x86-64' and did the make install thing. How come the output of glxinfo|grep direct doesn't say yes?
 
Old 12-19-2005, 03:17 PM   #2
mimithebrain
Member
 
Registered: Nov 2003
Location: ~
Distribution: Ubuntu 10.04
Posts: 843
Blog Entries: 1

Rep: Reputation: 30
This document, although gentoo related, might help you: (it helped me)
http://odin.prohosting.com/wedge01/g...adeon-faq.html

You need to load, in this order: agpgart, [nameofchipset]_agp, fglrx. once this is done, you need to fill the kernel dependencies (such as installing the right kernel/modules), and you are usually done.

Oh, it's has to be the right chipset agp driver, otherwise, it won't work. You need to load the ati agp module is it's a IGP card. check lspci if you aren't sure
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
8.6.20 ATI Drivers and ATI Radeon XPress 200M ltracy Linux - Hardware 8 04-28-2006 08:52 PM
Cant get DRI working with ATI Radeon 7000 and Gentoo Linux kofrad Linux - Hardware 21 04-21-2006 02:10 PM
ATI Xpress 200m and Suse 10 Sivik Suse/Novell 6 11-19-2005 11:50 PM
Ati Radeon Express 200M FedoraUsr Linux - Laptop and Netbook 4 08-28-2005 12:20 PM
DRI not working on XFree86 4.0 with ATI Radeon Mobility nef Linux From Scratch 1 03-13-2004 02:24 AM


All times are GMT -5. The time now is 10:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration