LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 02-20-2006, 07:19 PM   #1
ArthurHuang
Member
 
Registered: Jan 2006
Posts: 174

Rep: Reputation: 30
How to enable ssh service on suse 10?


I type "service ssh start", "command not found"

I enter etc/rc.d/ , ./sshd start, It's ok

But I still can not ssh to the server by putty?What should I do

Thanks!
 
Old 02-20-2006, 07:37 PM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Is there a firewall on the machine?
If so disable first and see if you can login.

Here a good link to setup ssh. http://www.suso.org/docs/shell/ssh.sdf
 
Old 02-20-2006, 08:56 PM   #3
crazibri
Member
 
Registered: Mar 2004
Location: Orange County, CA
Distribution: OS X, SuSE, RH, Debian, XP
Posts: 377

Rep: Reputation: 31
SSH service is installed if you took the default installation packages. You just have to allow the SSH service through your firewall. Yast Modules/Security and Users/Firewall. Then for your services select SSH. This opens TCP port 22 which is the default SSH port.

You can test your ssh by going to a Konsole and typing "ssh localhost" and it will ssh to your machine through the loopback device "lo". It should prompt for your password which is the same user account as what you typed that command. It should accept your password and then you can just type "exit" to quit the SSH connection.

Hope this helps!
 
1 members found this post helpful.
Old 02-20-2006, 11:37 PM   #4
nguyennh
Member
 
Registered: Feb 2006
Location: Vietnam
Distribution: FC , RH , SuSE
Posts: 106

Rep: Reputation: 15
Oh I think default , "service" command set is only available on RedHat and Fedore distribution so you can not use it on SUSE until you setup (ie , install) it .
On SUSE , first you must check sshd is available (by using locate or which command , for example which sshd ) . If it exists , all you have to do to enable sshd (I mean ssh server not ssh client) is type sshd at your console . That's all . After that , you can using secure shell (ssh command) to log on your computer which enable service ssh ( ie , ssh server or sshd) .

Hope it help you ,
nguyennh

Last edited by nguyennh; 02-20-2006 at 11:39 PM.
 
Old 02-21-2006, 07:47 AM   #5
broch
Member
 
Registered: Feb 2005
Distribution: Arch current, SuSe 10.1 32-bit, FreeBSD current, OpenBSD 4.0
Posts: 453

Rep: Reputation: 30
ssh is enabled by default (unfortunately) in SUSE. You will have to configuere it only.
 
Old 02-21-2006, 07:13 PM   #6
ArthurHuang
Member
 
Registered: Jan 2006
Posts: 174

Original Poster
Rep: Reputation: 30
Thank you guys, It's the problem of firewall. I have figure out it.
Appreciate
 
Old 12-07-2010, 08:15 PM   #7
errigour
Member
 
Registered: May 2009
Posts: 278

Rep: Reputation: 5
I was just reading

Useful information using suse,
type as root user that is type,
chkconfig without arguments if you want
but chkconfig sshd on to start sshd at
start up and alternativly
chkconfig sshd off to set it back.
 
Old 12-08-2010, 08:38 AM   #8
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,989

Rep: Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672
Quote:
Originally Posted by errigour View Post
Useful information using suse,
type as root user that is type,
chkconfig without arguments if you want
but chkconfig sshd on to start sshd at
start up and alternativly
chkconfig sshd off to set it back.
This is not only hard to read/unserstand, but is on a FOUR YEAR OLD THREAD that has been closed quite a while. Please don't reopen old threads.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
enable ssh davidhk Debian 7 10-09-2007 06:49 PM
How do I enable SSH in suse 9.1 pro? wearetheborg Linux - Software 3 10-16-2004 04:13 PM
Enable serial service with rfcomm and bluetooth. philipina Linux - General 0 06-21-2004 09:08 AM
how to enable pop3 service in redhat advaced server 3 ehpserver Linux - Networking 1 12-15-2003 11:29 PM
how to enable FTP service? hedaPrakash Linux - Newbie 7 07-17-2003 11:36 PM


All times are GMT -5. The time now is 11:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration