LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 05-07-2005, 06:48 AM   #1
simanyay
LQ Newbie
 
Registered: Jul 2003
Location: Imperial Library, Trantor
Distribution: SuSe Linux 9.3 Pro
Posts: 23

Rep: Reputation: 15
How to disable touchpad?


Hello. I've installed SuSe Linux 9.3 Pro on my Gateway 7422GX. Everything is ok except one thing: i can't disable my touchpad. Touchpad and my USB mouse is on one file: /dev/mouse. How can I disable it?
 
Old 05-07-2005, 07:33 AM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
try the BIOS
 
Old 05-10-2005, 06:49 AM   #3
simanyay
LQ Newbie
 
Registered: Jul 2003
Location: Imperial Library, Trantor
Distribution: SuSe Linux 9.3 Pro
Posts: 23

Original Poster
Rep: Reputation: 15
I can't find it there
 
Old 05-10-2005, 06:53 AM   #4
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Well, the touchpad does not use the same modules as the USB mouse.
I can't imagine that not being in the BIOS, and I know absolutely nothing
about SuSE, but if nothing else works, you should be able to remove the
PS/2 mouse support from your kernel, and perhaps that will disable the
touchpad.
 
Old 05-10-2005, 07:08 AM   #5
okmyx
Member
 
Registered: May 2004
Location: Cornwall, UK
Distribution: Ubuntu 8.04
Posts: 464

Rep: Reputation: 31
It might not be the same, but my Toshiba laptop have keyboard combo to disable the touch pad (Fn+Key).
 
Old 05-26-2005, 05:51 AM   #6
xmav78
LQ Newbie
 
Registered: Mar 2004
Location: Rome
Distribution: suse 9.2
Posts: 7

Rep: Reputation: 0
I have the same problem on a travelmate 254; several fn+Fn keys do not work. xev gives no hit for those keys. Disabling by BIOS? or other? I would like to be able to enable/disable it on the fly, each time I want! It is possible under Windows so it must be possible under linux too! using keyboard special keys for this and other stuff (for example, volume and muting, for this i almost solved the problem...)
..
 
Old 06-04-2005, 11:11 AM   #7
phillips321
Member
 
Registered: Jan 2005
Location: Newport, WALES
Distribution: SuSE
Posts: 74

Rep: Reputation: 15
in suse 9.3 it may be possible to use SaX2 to disable it? have a little look
 
Old 06-14-2005, 08:33 AM   #8
xmav78
LQ Newbie
 
Registered: Mar 2004
Location: Rome
Distribution: suse 9.2
Posts: 7

Rep: Reputation: 0
suse 9.3

Quote:
Originally posted by phillips321
in suse 9.3 it may be possible to use SaX2 to disable it? have a little look
ops i have sus 9.2...

but i tried with sax... i killed all input devices like mice that it shows me and...
still i can move my mouse!! - of course i restarted the gfx system too

doing a cat on the /dev/mouse or something like that it happens there is output
both if i move my mouse or if i touch the tpad... hmmm...

Last edited by xmav78; 06-14-2005 at 08:34 AM.
 
Old 06-24-2005, 01:24 AM   #9
awtoc123
Member
 
Registered: Apr 2002
Location: China
Distribution: Suse 10
Posts: 225

Rep: Reputation: 30
touchpad

Same problem here, I need to totally disable the tocuhpad,

I'm using Redhat RHEL4 with kernel 2.6.11

Notebook Compaq M2000

In the old Compaq 2200 thee where a small switch where you could enable/disable the touchpad, but as always when you upgrade to new model something is left out.
The touchpad is very fustrating when using mouse and you are typing your arm hair or hand touches the touchpad, and you are typing in a diffeent place.

I have been thinking to open the machine to pull the plug, but there must be a way via software to disable it.

I have tried to uninstall all the synaptics drivers so there is absolutly no reference to the touchpad in xorg.conf, but still it is working.

Any Idea would be highly welcome.
 
Old 09-20-2005, 09:16 AM   #10
xmav78
LQ Newbie
 
Registered: Mar 2004
Location: Rome
Distribution: suse 9.2
Posts: 7

Rep: Reputation: 0
touchpad off... forever?

ok i have done: touchpad is out. i did it in a very unfriendly way: i noticed
as said that there's a device that "hears" both tpad and mouse, but still they are reacheable
via single device entry. (check it via cat /dev/mouse or /dev/input/mouse*)
so I made a link of /dev/input/mice to /dev/mouse if I remember well... worked, until I run sax2
which get confused... x86conf in trouble, X didnt started, i fixed it (there where two
line with SendCoreEvent) and now seems to work... but well still I am not able to get back
the touchpad and if I plug out the mouse, nothing can move the pointer! even though I plug in
it again... hm hotplug too get confused?
wll, still i really didn't need the tpad but in a future....
when i will understand better the matter i will post a answer with details... bye
 
Old 11-02-2005, 06:19 PM   #11
rlfederico
LQ Newbie
 
Registered: May 2003
Location: Denver, CO
Distribution: SUSE 8.2
Posts: 5

Rep: Reputation: 0
Thumbs down Gateway 7422GX and SUSE 9.2

I installed Suse 9.2 on my Gateway 7422GX and it freezes after boot. What did i do wrong.
What can I do to get a useable screen?
 
Old 12-06-2005, 10:03 AM   #12
hg01
LQ Newbie
 
Registered: Dec 2005
Posts: 1

Rep: Reputation: 0
I know, this post is old, but this reply may be usefull for others. I am newbe, but it works on my laptop + USB mouse (distro archlinux, kernel 2.6.13)
To see on witch device your touchpad is mapped, try (in a console)
"cat /dev/input/mouse0 (or mouse1, mouse2,...) and move first only your mouse. Garbage will appear. Then touch your touchpad. If nothing appear, it's the right one. (for me /dev/input/mouse2)
(Press ctrl+c to cancel it.)
In /etc/X11/xorg.conf (make first a backup from yout file!), in Section "InputDevice", replace:
Option "Device" "/dev/input/mice"
with
Option "Device" "/dev/input/mouseX" (X ist the right number)
You must have only 1 entry for Input Device. Comment out the others.
Save your new xorg.conf
Rerun X (Ctrl+alt+backspace for killing X session)
It should work
Sorry for my bad english!
 
Old 06-26-2007, 04:42 AM   #13
robin48gx
LQ Newbie
 
Registered: Jun 2007
Posts: 2

Rep: Reputation: 0
thankyou !

the f**king touchpad was driving me insane. I would be typing away and the cursorwould have moved to some randon place in the text nd mucked everything up.

Thanks once again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
disable touchpad in kde? kahn Linux - Hardware 1 05-29-2005 08:21 PM
disable touchpad MicahCarrick Linux - Laptop and Netbook 0 07-18-2004 07:23 PM
How to disable touchpad? jimbo Linux - Laptop and Netbook 3 04-04-2004 09:06 AM
disable synaptic touchpad ljpete Linux - Newbie 1 01-31-2004 05:42 AM
disable synaptic touchpad ljpete Linux - Distributions 0 01-30-2004 09:59 PM


All times are GMT -5. The time now is 05:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration