LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 11-17-2008, 01:00 PM   #1
casmac
Member
 
Registered: Aug 2006
Distribution: SUSE 10
Posts: 31

Rep: Reputation: 15
How to disable one CPU on an Intel Duo Core platform


Hi All,
I am currently running Suse 10.1 on Intel Duo core.
I am running some performance test which requires to test the program execution time on single CPU. I was wondering if it is possible to disable one CPU with Linux. If Linux did not prohibit such action, how to do this properly?

A long time ago, I have been told to modify some script file so that each CPU is running at the lowest possible speed, however I no longer remember how i did it back then.

Thanks.


tony
 
Old 11-17-2008, 02:09 PM   #2
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
Boot linux passing the parameter maxcpus=1.
 
Old 11-17-2008, 02:10 PM   #3
watcher69b
Member
 
Registered: Nov 2007
Location: /home/watcher69b
Distribution: RH, Fedora & CentOS
Posts: 539

Rep: Reputation: 39
I have never tried it myself but Next time change the boot options "nosmp" or "maxcpus=0"
 
Old 11-19-2008, 06:56 PM   #4
casmac
Member
 
Registered: Aug 2006
Distribution: SUSE 10
Posts: 31

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by colucix View Post
Boot linux passing the parameter maxcpus=1.
Thanks. But i don't even remember how to enter the booting options dialog. Pressing F1 or F11 or .. ?

tony
 
Old 11-19-2008, 07:18 PM   #5
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,509

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
I don't remember exactly in 10.1, but if you select OpenSuSE from the boot menu, does it appear a line "Boot options" below the menu entries? If yes, just type maxcpus=1 into it and press enter to boot.
 
  


Reply

Tags
cpu, disable


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel Core 2 Quad Q6600 *VS* Intel Core 2 Duo E6850 MasterOfTheWind Linux - Hardware 61 04-13-2008 04:47 AM
Fedora i386 on intel E6750 Core 2 Duo Cpu Libertes Linux - Hardware 6 01-30-2008 03:45 PM
Linux Installation Halted on Intel Core 2 Duo on intel 946G MotherB srilinux Linux - Hardware 3 10-06-2007 09:30 AM
Intel DG33FB motherboard - cannot run second core on cpu (core 2 duo) rmitev Linux - Enterprise 2 09-28-2007 05:54 AM
does red hatlinux 9 support intel core 2 duo and intel DG965RY motherboard sa_2400 Linux - Hardware 8 07-11-2007 01:13 PM


All times are GMT -5. The time now is 04:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration