LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 07-14-2006, 09:26 PM   #1
baosheng
Member
 
Registered: Oct 2004
Location: Lubbock, TX, USA
Distribution: Ubuntu 7.10
Posts: 74

Rep: Reputation: 15
how to disable auto login in SUSE 10?


hi guys,
I am a newbie to SuSE. But when I start the computer, the system automatically logs as the username I defined at installation. Now I don't wanna it automatically log in but stop at the log in window and wait for me to enter the username and password. How can I do?

Thanks.
 
Old 07-14-2006, 09:32 PM   #2
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
You can do it from the kde control panel if your running kde. You just go the the login manager.
 
Old 07-19-2006, 04:08 AM   #3
baosheng
Member
 
Registered: Oct 2004
Location: Lubbock, TX, USA
Distribution: Ubuntu 7.10
Posts: 74

Original Poster
Rep: Reputation: 15
well, I use GNOME....
 
Old 07-19-2006, 08:02 PM   #4
Sören Schneider
Member
 
Registered: Apr 2005
Location: Brazil
Distribution: SUSE 9.0 Pro, SUSE OSS 10.0, KDE 3.4.2
Posts: 156

Rep: Reputation: 30
Try this
edit /etc/sysconfig/displaymanager

there is a line:
## Type: string
## Default:
#
# Define the user whom should get logged in without request
#
DISPLAYMANAGER_AUTOLOGIN=""

delete the name between the ""
 
Old 08-12-2006, 07:52 AM   #5
Robo_e
LQ Newbie
 
Registered: Aug 2006
Posts: 1

Rep: Reputation: 0
Hi guys, short time listener, first time caller and all that.

I installed SUSE 10.1 a few days ago as a replacement for xp as my primary development environment (that's a posh way of saying I want to look cool in programming lectures) and everythings been going well except for this login issue.

I've gone through YaST and disabled auto login and even edited the display manager to make sure that it didnt login my primary user but it still logs me in following a restart.

Are there any other files or configuration scripts controlling auto login?

I am the only user showing up in the YaST user manager and am running kernel version 2.6.16.13-4-default.
 
Old 09-02-2006, 01:37 PM   #6
dwains
LQ Newbie
 
Registered: Dec 2002
Location: Raleigh NC USA
Distribution: Red Hat
Posts: 18

Rep: Reputation: 0
If you edit these files manually, you need to SuSEconfig (as root) after you make the edits. This (in YAST's terminology) activates them.

You can also do this from within YAST2.

Click System/</etc/syconfig Editor> and expand Desktop / Display manager. Just set DISPLAYMANAGER_AUTOLOGIN to nothing and it will then do the right thing at next bootup.

IMHO SLES 10.1 should not do this as a default. It seems like a real security hole to me. And its really hard to undo.
 
Old 09-04-2006, 03:09 PM   #7
hemendra144
LQ Newbie
 
Registered: Sep 2006
Location: India
Distribution: SUSE
Posts: 6

Rep: Reputation: 0
NOT LOGIN AS root

Quote:
Originally Posted by Caeda
You can do it from the kde control panel if your running kde. You just go the the login manager.

Dear,

1. I am newbie in this linux sea, I am using SuSe10.1 everythin' went well but login screen not showing ROOT user and gives error that "can't login as root".

2. I tried in Login Manager an Yast2 to include root as user on login screen but all in vain.

3. Help pl all of you linux geeks...

regards
 
Old 09-04-2006, 11:33 PM   #8
hemendra144
LQ Newbie
 
Registered: Sep 2006
Location: India
Distribution: SUSE
Posts: 6

Rep: Reputation: 0
Quote:
Originally Posted by hemendra144
Dear,

1. I am newbie in this linux sea, I am using SuSe10.1 everythin' went well but login screen not showing ROOT user and gives error that "can't login as root".

2. I tried in Login Manager an Yast2 to include root as user on login screen but all in vain.

3. Help pl all of you linux geeks...

regards

After fighting fr half an hour i got it right through config of Login Manager

thanks
 
Old 09-05-2006, 06:39 AM   #9
delta_9
Member
 
Registered: Feb 2006
Location: Athens
Distribution: opensuse 11/kubuntu 8.04
Posts: 99

Rep: Reputation: 15
baosheng, go to yastmodules->security and users->user management->choose the user u want to disable autologin->expert options->login settings and disable autologin
 
  


Reply

Tags
as, login, root, suse, suse10


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No auto login to KDE suse 10.0 supwiddiss Suse/Novell 1 11-02-2005 02:56 PM
Disable auto login at startup x ferry.hidayat Linux - Newbie 2 10-03-2003 10:32 AM
disable auto login into KDE tonic Linux - General 3 02-16-2003 01:06 PM
How to disable auto-login (MDK9) skip1 Linux - Software 3 02-07-2003 01:10 PM
auto login ~ how to disable? thinguy10 Linux - General 3 02-04-2002 06:34 AM


All times are GMT -5. The time now is 03:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration