LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 02-25-2006, 09:00 PM   #1
sirius57
Member
 
Registered: Jun 2004
Distribution: Fedora core 1, puppy linux, suse 10.0, opensuse 11.3, 12.1, mythdora
Posts: 462

Rep: Reputation: 30
How to browse a windows box using samba server?


When I click the network icon in file manager, a windows network icon appears. When the windows network icon is clicked, I get a blank file manager screen. I made sure all the samba related packages were installed. I am using the gnome desktop and suse linux 10.0. Do I need to be root to use samba server? My firewall is running and configured for the external zone. This was set up by the installer routine. I am behind a linksys router. How can I check my local network address?
 
Old 02-26-2006, 01:52 AM   #2
pcweirdo
Member
 
Registered: Oct 2004
Location: Melbourne-ish, Australia
Distribution: Gentoo, Windows XP Pro
Posts: 58

Rep: Reputation: 15
I shall make some assumptions, please correct me if I'm wrong.
- You have a box called "sirius" which you are sitting in front of now. It has some porn on it.
- You have a Microsoft Windows XP computer called "candy". It has LOTS of porn on it.
- These computers are switched on, connected by some degree of computer network, and are probably not made of cheese.

You do not use a samba server to browse candy's files from sirius. You could use a samba server running on sirius to browse sirius's files from candy, but that is not what you want to do today.

For this exciting dish, you will need all the samba client libraries and packages and crap. You probably won't need a kernel-level driver, but if you see something to do with samba in your kernel config, enable it. I've never used SUSE or Novell, what the hell would I know, ey? You also need to know the name of a share on candy; for example, \\candy\SharedDocs .

Go to your shell (Konsole, terminal, console, xterm, $TERM, etc) and run as root
# mkdir /mnt/zomg
# mount //candy/SharedDocs /mnt/zomg -o username=USERNAME_ON_CANDY
And then you'll hopefully have to type in a password. Or you could try leaving off everything after (and including) the "-o" bit. Stoned pregnant teenagers are right: experimentation is good. Anyway, ideally you'd then have candy's shared documents appear in /mnt/zomg.
# chmod -R -v 777 /mnt/zomg
is an enjoyable command, containing several vital minerals and nutrients, which will allow your non-root users to access the files.

And if that all doesn't work, come ask more questions. Copy and paste from your shell even. If it does work, sacrafice three (3) virgins to the SATA gods and/or post here to say how you went.

Also,
$ ifconfig
shows your network adapters and their addresses (we hope).

On Windows, try 'ipconfig /?' or 'ipconfig' on the command line or right-clicking randomly on the system tray.

And just to satisfy my curiosity, please run 'uname -a' on your Linux computer and put the result here. Also fun (and tell me how they go) are:
$ ls -lt /mnt
$ cat /
$ echo lol
and
$ ping internet

-pcweirdo.

EDIT: Ja need root, mon.

Last edited by pcweirdo; 02-26-2006 at 01:55 AM.
 
Old 02-26-2006, 07:52 PM   #3
sirius57
Member
 
Registered: Jun 2004
Distribution: Fedora core 1, puppy linux, suse 10.0, opensuse 11.3, 12.1, mythdora
Posts: 462

Original Poster
Rep: Reputation: 30
After my post and before your reply, I went poking around in Yast and opend Samba server. It requested I insert a cd from the suse 10.0 cd set and loaded the necessary files. I went to the xp box and in explorer, in the network pc names, Linux was listed. Clicking on LInux, opened several folders on the Linux box. Clicking on a folder made a pop up with username and password appear. I am assuming Samba server is now running. I am going to do your suggestion to see the xp box from linux. Does the xp box have to be mounted every time the linux box is booted up to see it on the network? I will post further results.
 
Old 02-26-2006, 08:39 PM   #4
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Sorry to hijack the post, but PCWEIRDO, I am having problems via command line accessing my Windows Server 2003 box. It works fine in the KDE GUI, but not via command line.

I tried your example and I get this error:

Code:
cli_negprot: SMB signing is mandatory and we have disabled it.
7070: protocol negotiation failed
SMB connection failed
 
Old 02-26-2006, 08:41 PM   #5
sirius57
Member
 
Registered: Jun 2004
Distribution: Fedora core 1, puppy linux, suse 10.0, opensuse 11.3, 12.1, mythdora
Posts: 462

Original Poster
Rep: Reputation: 30
Ok, I made the /mnt/zomg folder, then typed the mount //.... and linux came back with what looked like a help screen, with a list of arguments for the mount command. I typed -o username= and without. Is there something from the shell to post that would help?
 
Old 02-26-2006, 08:42 PM   #6
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
Did you try running as ROOT?

COPY/PASTE what was in your command line so we see EXACTLY what you typed. You could have made a typo or something.
 
Old 02-27-2006, 07:13 PM   #7
sirius57
Member
 
Registered: Jun 2004
Distribution: Fedora core 1, puppy linux, suse 10.0, opensuse 11.3, 12.1, mythdora
Posts: 462

Original Poster
Rep: Reputation: 30
Here is a copy/paste from root:
linux:~ # mount //lenora/shared documents /mnt/zomg
Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] ... : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .

To sum up:
I created a directory /mnt/zomg I then tried to mount to the xp box. Is there any other info I can paste?
 
Old 02-28-2006, 04:52 AM   #8
pcweirdo
Member
 
Registered: Oct 2004
Location: Melbourne-ish, Australia
Distribution: Gentoo, Windows XP Pro
Posts: 58

Rep: Reputation: 15
Quote:
Originally Posted by Micro420
Sorry to hijack the post, but PCWEIRDO, I am having problems via command line accessing my Windows Server 2003 box. It works fine in the KDE GUI, but not via command line.

I tried your example and I get this error:

Code:
cli_negprot: SMB signing is mandatory and we have disabled it.
7070: protocol negotiation failed
SMB connection failed
MY NAME IS NOT ALL IN CAPS. BUT FAIR ENOUGH THAT YOU TYPE LIKE THAT, SINCE CAPSLOCK IS CRUISE-CONTROL FOR COOL. WHAT YOU ARE DOING THERE IS OVERLY COMPLICATED AND MUST BE POSTED IN A SEPARATE THREAD. I HAVE NO IDEA WHAT YOUR COMPUTER IS SAYING, BUT IT MAY WELL BE A LITTLE TERRORIST INSIDE, AND YOU MIGHT NEED DICK CHENEY TO COME AND SHOOT HIM IN THE FACE.

siriusXXX (I forget the number, sorry!), do you have a program called smbmount or sambamount or smbmnt or anything that sounds remotely like that in your PATH? PATH is a list of folders like /bin and /usr/bin and /usr/local/bin and /usr/sbin and /sbin and /usr/local/sbin and ~/bin and ~/porn (hey THAT'S not educational!) etc.

Keep up the good effort,
-pcweirdo.
 
Old 02-28-2006, 08:28 PM   #9
sirius57
Member
 
Registered: Jun 2004
Distribution: Fedora core 1, puppy linux, suse 10.0, opensuse 11.3, 12.1, mythdora
Posts: 462

Original Poster
Rep: Reputation: 30
I am new to the under the hood stuff, however, I found a file: /etc/profile that seems to have all the scripts for startup. It does say to use instead /etc/profile.local for all local settings. I looked in the /bin folder for any combination of smbmount and did a file search and could not find any reference in the /etc/profile file. I have done dos batch files, but need a primer on linux.
 
Old 03-01-2006, 03:46 AM   #10
pcweirdo
Member
 
Registered: Oct 2004
Location: Melbourne-ish, Australia
Distribution: Gentoo, Windows XP Pro
Posts: 58

Rep: Reputation: 15
/etc/profile is the shell startup, not the system startup. Its job is setting the colour of your command prompt setting and all that crap. The system startup is in places like /etc/init.d , but that's a whole different kettle of fish.

Looking at your copy-and-paste from the shell, you've fallen into a common tarp. And under that tarp was a trap!

You'll need to 'escape' (verb) that space in "shared documents", because the way you've written it, the computer is looking for a share called "shared", to mount in a place called "documents", and has no idea what the fuck you're on about after that.

So modify your command to look more like
# mount //lenora/shared\ documents /mnt/zomg
or
# mount //lenora/'shared documents' /mnt/zomg

Notice that in the first example, I have put a slash in. The slash (note the two kinds of slashes that are different, and I can't remember which one is called what) tells the shell to treat that space as a space rather than as a separator between arguments. Perhaps the quoting style is easier, since it demonstrates that the words "shared documents" are bound together by the quote marks.

I'd like to see more copy-and-paste from you shell please.

-pcweirdo.
 
Old 03-01-2006, 08:24 PM   #11
sirius57
Member
 
Registered: Jun 2004
Distribution: Fedora core 1, puppy linux, suse 10.0, opensuse 11.3, 12.1, mythdora
Posts: 462

Original Poster
Rep: Reputation: 30
At least it tried to connect. I checked the xp box name in explorer under workgroup and it is Lenora.


Password:
linux:~ # mount //Lenora/'shared documents' /mnt/zomg
8299: Connection to Lenora failed
SMB connection failed
linux:~ #

Also tied the other variation to mount with same error. Does zomg need to be in fstab? I also disabled the firewall on the xp box. I am running a fire wall on the Linux box, but since the xp box can see Linux, I dont think that is an issue?
 
Old 03-02-2006, 12:58 AM   #12
Micro420
Senior Member
 
Registered: Aug 2003
Location: Berkeley, CA
Distribution: Mac OS X Leopard 10.6.2, Windows 2003 Server/Vista/7/XP/2000/NT/98, Ubuntux64, CentOS4.8/5.4
Posts: 2,986

Rep: Reputation: 45
How about we try to connect to your Windows box graphically? Open konqueror and type this as the address:

smb:\\username@ipaddressofwindows\sharefoldername

example:
smb:\\micro420@192.168.0.2\share

You should then get a box asking for an account password.

Last edited by Micro420; 03-02-2006 at 12:59 AM.
 
Old 03-02-2006, 03:47 AM   #13
pcweirdo
Member
 
Registered: Oct 2004
Location: Melbourne-ish, Australia
Distribution: Gentoo, Windows XP Pro
Posts: 58

Rep: Reputation: 15
Quote:
Originally Posted by sirius57
At least it tried to connect. I checked the xp box name in explorer under workgroup and it is Lenora.


Password:
linux:~ # mount //Lenora/'shared documents' /mnt/zomg
8299: Connection to Lenora failed
SMB connection failed
linux:~ #

Also tied the other variation to mount with same error. Does zomg need to be in fstab? I also disabled the firewall on the xp box. I am running a fire wall on the Linux box, but since the xp box can see Linux, I dont think that is an issue?
It is very encouraging that it is trying to connect. zomg does not need to be in fstab. Your problem may be that the name 'Lenora', while known to the Windows box, is not known to the Linux box. Get the IP address of Lenora on the LAN, and use that in the place of 'Lenora' in the above command. You can get Lenora's IP address by typing 'ipconfig /all' in a command prompt. It might be something like '192.168.1.65'.

Micro420, I thank you for bringing up the graphical method, as I myself have no idea how to use much of the Linux GUI. I welcome your expertise.

-pcweirdo.
 
Old 03-03-2006, 07:54 PM   #14
sirius57
Member
 
Registered: Jun 2004
Distribution: Fedora core 1, puppy linux, suse 10.0, opensuse 11.3, 12.1, mythdora
Posts: 462

Original Poster
Rep: Reputation: 30
The graphical method works! I did ipconfig /all, got the xp ip address, and bingo! the web page looked like an ftp: address. I just had to ok my way on the xp box firewall to allow the connection. Thank you pcweirdo and Micro420!

A quick thought, can the ip address be used in the mount command?
 
Old 03-04-2006, 05:44 AM   #15
pcweirdo
Member
 
Registered: Oct 2004
Location: Melbourne-ish, Australia
Distribution: Gentoo, Windows XP Pro
Posts: 58

Rep: Reputation: 15
Quote:
Originally Posted by sirius57
The graphical method works! I did ipconfig /all, got the xp ip address, and bingo! the web page looked like an ftp: address. I just had to ok my way on the xp box firewall to allow the connection. Thank you pcweirdo and Micro420!
Hooray! I'm glad the graphical method worked, as the command-line was is overly complex. Good stuff Micro420!

Quote:
Originally Posted by sirius57
A quick thought, can the ip address be used in the mount command?
Yep. Sorry if I didn't make that clearer. ^^;

Happy hunting,
-pcweirdo.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
trouble setting shares so samba networked xp box can browse files mjewell Mandriva 4 11-13-2005 08:20 AM
Samba box as Software Management Server for windows?? any one oiaohm Linux - Software 2 04-05-2005 05:34 AM
can browse samba network with windows but not linux tuxkwb Linux - Networking 0 12-01-2004 04:52 PM
can't browse windows workgroup when linux box online revdshepard Linux - Networking 2 02-04-2004 02:14 PM
SAMBA - browse Windows filesystem? ruprecht Linux - Software 3 11-24-2003 12:42 PM


All times are GMT -5. The time now is 06:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration