LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 06-30-2007, 10:06 AM   #1
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Rep: Reputation: 31
Question how to access files in USb flash drive


Hi,

i need an instruction about the following problem:

I can see my flash drive in "My computer" but cant see any files in it. I am getting the following message:
"The option flush is not allowed for uid=1000"
I tried to change that in YAST, but obviously I cant. So I need help.
 
Old 07-01-2007, 04:07 PM   #2
rednuht
Member
 
Registered: Aug 2005
Posts: 239
Blog Entries: 1

Rep: Reputation: 30
if you run
Code:
sudo dmesg
the last messages should give you a better idea whats going on.
evn better run dmesg before and a few seconds after plugging in the device
 
Old 07-01-2007, 05:06 PM   #3
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I just plugged in a Cruzer mini. This is how it was automounted:
Code:
/dev/sdc1 on /media/disk-1 type vfat (rw,nosuid,nodev,noatime,flush,uid=1000,utf8,shortname=lower)
The "My Computer" icon opens up konqueror with the url of "sysinfo:/". Locate the device on the page and right click. Select Properties. Click on the "Mounting" tab. Notice the mounting options on the bottom. Make sure mount as user is selected. If it is you could try unselecting the "Flushed I/O" box.

I wonder if the filesystem on the drive itself is OK. You might want to mount it once as root.

sudo mount -t vfat /dev/sd<##> /mnt -o rw,defaults,dmask=000,fmask=111,uid=1000
Where <##> is the device, such as sdb1

If it doesn't mount, check out the filesytem:
Code:
example:
# make sure it is unmounted
sudo umount /media/disk-1
sudo /sbin/fsck.vfat /dev/sdc1
dosfsck 2.11, 12 Mar 2005, FAT32, LFN
/dev/sdc1: 119 files, 4629/15656 clusters
Your device's mount point is probably somewhere else.

Last edited by jschiwal; 07-01-2007 at 06:09 PM.
 
Old 07-02-2007, 01:02 AM   #4
riba43
Member
 
Registered: Feb 2005
Location: Slovenia
Distribution: suse11.0
Posts: 749

Original Poster
Rep: Reputation: 31
jschiwal thanks. i fixed the problem. Just unchecked the "Flushed I/O" in the properties windov.
Thanks again
 
Old 07-09-2007, 03:34 AM   #5
ashwinidubey
LQ Newbie
 
Registered: Jun 2007
Location: Mumbai, India
Posts: 24

Rep: Reputation: 15
one of the easiest way is
cd /media/urUsbDeviceName/
ls
use
cp command to copy

may be u need to be super user
so
su
ur password
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot delete drive from root desktop - cannot mount usb flash drive - openSuSE 10.2 bluecog6 Linux - General 6 01-29-2007 03:18 PM
Cannot mount USB Flash Drive, 4 device files Hakala Linux - Software 1 04-01-2006 12:20 PM
Access USB flash drive? Zeno McDohl Linux - Newbie 4 01-16-2006 12:47 PM
Having trouble with DSL File Management: USB flash drive files zubalove DamnSmallLinux 2 08-19-2005 09:01 PM
How to access a USB flash drive captainpicard Linux - Hardware 1 04-20-2003 12:19 PM


All times are GMT -5. The time now is 10:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration