LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices

Reply
 
Search this Thread
Old 01-03-2005, 07:58 PM   #61
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31

Can anyone that does have a working xconfig email a copy.
How good is novell premium support? Anyone have any experince with it?
 
Old 01-03-2005, 10:22 PM   #62
pilotgi
Member
 
Registered: Apr 2002
Location: ks
Distribution: openSUSE 12.2 64 bit
Posts: 488

Rep: Reputation: 32
Quote:
Originally posted by JackieBrown
Can anyone that does have a working xconfig email a copy.
How good is novell premium support? Anyone have any experince with it?
I take it you reinstalled SUSE and are still having problems. Did you get the nvidia drivers installed and still having problems with 3d or are you having problems with nvidia?

Never tried the premium support but I think if you pay, they'll work with you until the problem is solved. I don't think your xconfig file is the problem since it's generated automatically.
 
Old 01-03-2005, 11:33 PM   #63
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
I reinistalled SUSE three times and now I am back to nothing. I tried using YOU after the install but before the log into to X. That didn't work
I tried installing via YOU after the install and after X ran, but that did work.
Finally I tried running it directly using the drivers.
That doesn't work either.
Since no one seems to be having this problem I assume I am missing some small but crucial step, but for the life of me I cannot figure what that is.
I really like the setup of SUSE linux , enough to have even purchased it full retail - that was before I got my NVIDIA card.
The NVIDIA card works just fine in windows so I know it is not the card.
I am at a loss.
 
Old 01-03-2005, 11:43 PM   #64
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
Also it is $40 every 20 minutes. That is a lot of money. Do you think it would be solved in less than 20 minutes?
 
Old 01-04-2005, 01:37 AM   #65
eco2geek
Member
 
Registered: Feb 2003
Location: Portland, OR
Distribution: openSUSE 10.3, among others
Posts: 141
Blog Entries: 1

Rep: Reputation: 15
First off: Understand that there are two nVidia drivers.

The driver named "nv" is shipped with Linux. It's open-source, but does not allow acceleration.

The driver named "nvidia" is not generally shipped with Linux, because it's not open-source. (However, it's free to use and distribute as long as you don't change the binaries.) The "nvidia" driver allows acceleration. That's the one you're trying to download and install.

Here's my experience installing the nVidia drivers on SuSE.[list=1][*]Installed SUSE. For some reason, it couldn't go online during the setup process, so it couldn't connect to YOU then.[*]Made sure Internet connection was working. Started YOU. Told YOU to download and install the nVidia driver. Logged out of X and back in (which stopped and restarted X). The nVidia driver obviously installed OK because the nVidia logo showed up.[*]Acceleration was not automatically enabled by the installer. When I tried to enable it using YaST, I also tried to move my screen to the right using the on-screen controls at the same time. Don't know why, but YaST screwed things up royally by resetting XF86Config back to the "nv" driver and upping the screen resolution to the next highest (which I didn't want or ask for). Moral: After you've installed the nVidia driver, don't use YaST to alter your video settings, or you may have problems. Modify XF86Config by hand, with your favorite text editor, as root.[*]In order to enable acceleration (and turn off the nVidia logo) I added the following lines to XF86Config (in the same section it says "Driver "nvidia" ":

Option "NoLogo" "1"
Option "RenderAccel" "1"[/list=1]
And that's all there was to it!

Keep in mind that if you make any changes, YaST does keep a backup of the original configuration file, which you can restore.
 
Old 01-05-2005, 03:29 PM   #66
ten0rman
LQ Newbie
 
Registered: Jan 2005
Location: Cumbria, UK
Distribution: Linux Mint
Posts: 13

Rep: Reputation: 0
Jackie,

Reading through the posts there seems to have been a lot of in-depth stuff going on, and I wonder if something very simple is being missed. You see I have Suse9.1 dual-booted with Win98SE. My machine uses Nvidia GeForce2 MX200 3D Graphic Accelerator and works perfectly after downloading the drivers via YAST/YOU. To be fair I do not have onboard video, but I would assume that if the card works ok in Windows, then it should work ok in Suse.

Since I need to keep Windows working, I had to dual-boot. I therefore allowed Suse to do it's own partitioning, load all the default software plus all the games, and ignored the option to update. Trying the games showed that the 3D ones unsurprisingly would not work, so I eventually downloaded the updates, including the Nvidia drivers, using YAST/YOU and following instructions about loading sequences. The whole lot worked like a dream, and I can now play the 3D games. (If I want! Which I don't!)

Bearing in mind that I am a noobie of 4 weeks, my suggestion would be to completely reload Suse using the option to setup a new install and using the default software/partitioning. You may like to include one or more of the 3D games as well for testing purposes. Do not take the update option yet. On completion of loading, test the installation using a 2D game, say Klondike or Freecell. These should work ok. Then try the 3D game. You should get a failure message. Then do the update via YAST/YOU checking carefully for instructions about loading sequences. Restart the machine, and if all has gone well you should see a white screen with Nvidia across it during the boot-up sequence. Then try the 3D game which should now work.

Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cant enable 3d acceleration ghostlkp Linux - Newbie 6 09-03-2005 02:37 PM
Can't enable 3D hardware acceleration. daedalusonlinux Suse/Novell 20 03-20-2005 09:42 PM
How do I enable 3d Acceleration in SUSE 9.1? Ray Finkel Linux - Newbie 2 08-19-2004 07:02 PM
I want to Enable my 3D Acceleration... mir_sheely Linux - Hardware 1 06-07-2004 05:32 AM
How do you enable 3d acceleration ultravox Linux - Hardware 2 04-05-2003 06:17 PM


All times are GMT -5. The time now is 01:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration