LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 01-01-2005, 08:16 AM   #46
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31

on a hunch i tried sax2 -m 0=nv but that didn't work either.
 
Old 01-01-2005, 08:21 AM   #47
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
do you think this is what is messing it up:

Card1 => BusId : 0x0
Card1 => SlotId : 0x02
Card1 => FuncId : 0x0
Card1 => Vendor : Intel
Card1 => Device : i845
Card1 => VID : 0x8086
Card1 => DID : 0x2562
Card1 => Module : nvidia
Card1 => BusType : PCI
Card1 => Detected : 2
Card1 => Flag : DEFAULT
Card1 => SUB-VID : 0x109f
Card1 => SUB-DID : 0x3186
]

How do I undect it. I did everything I could to turn that off in the bios. Also when I plug the moniter into the on video drive, I get no picture at all neither before linux or windows boots uo or afterwards so it seem like the has it off but linux for some reason can still detect it.\
I think this must be the problem since no one else seems to experience the same trouble I have had.
I know in windows I can just go to device manager and disable a device. How do I do that in Linix?
Or am I reading the error message wrong. ( I am reading it as though there are two card card 0 = nv card 1 = intel)
 
Old 01-01-2005, 09:25 AM   #48
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
Would this be a setting in the boot up. I tried clicking on the hardware tool icon in the sys tray. I selected the second card (trigen). It then takes me to yast2 wher it has my graphic settings but it shows the info for the nvidia card.
By the way, I love the resolution in Linux. I have never had a slicker looking desktop
 
Old 01-01-2005, 09:26 AM   #49
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
Actually when I read the log I posted it also says nvidia. Just to clarify, I only have 1 nvdia card
 
Old 01-01-2005, 02:07 PM   #50
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
Well I looked throught my handy admister guide and could not find anything about removing devices.

So my questions are:

are these 2 cards most likely causeing some kind of conflict
-if so, how do I remove one of them from SUSE
sight
are there two drivers for the same card and this makes it look like there are 2 cards
-same question, how would I remove one or the other?

I tries sax2, sax2 -m 0=nv, sax2 -m 1=nv, sax2 -m 0=nvidia, sax2 -m 1=nvidia, and different case variations of nvdia in case this was case sensitive (live most of linux is). I also tried going thru YAST2 hardware, grahics, enable 3d acceleration and was told that "(EE) nvidia(0) *****Aborting*****
(EE) Screen (s) found, but none have a usable configuration"
Which also brings another question:
I let SUSE choose the moniter for me since mine was not on the list (I know my moniter supports 3d acceleration, but maybe this one doesn't? btw my brand isn't on the list and has no linux driver -
 
Old 01-01-2005, 02:41 PM   #51
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
"Card0 => BusType : AGP"

This was in the error log under card 0. I have a pci card which is what card 1 shows. Does that matter?

Wow I have a lot of questions. Please don't give up on me.
 
Old 01-01-2005, 02:54 PM   #52
pilotgi
Member
 
Registered: Apr 2002
Location: ks
Distribution: openSUSE 12.2 64 bit
Posts: 488

Rep: Reputation: 32
What is the result of this command:

(as root)# modprobe nvidia
 
Old 01-01-2005, 08:56 PM   #53
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
it say module nvidia not found
 
Old 01-01-2005, 09:03 PM   #54
pilotgi
Member
 
Registered: Apr 2002
Location: ks
Distribution: openSUSE 12.2 64 bit
Posts: 488

Rep: Reputation: 32
Quote:
Originally posted by JackieBrown
it say module nvidia not found
Then there's no way the sax2 command with the nvidia option is going to work. Why don't you try installing the latest nvidia module like I explained on page 3 of this thread?

And now you say you have a pci card and not an agp card. I'm not sure if this will matter or not. What are the results of the command:

lspci

edit: I have SIS integrated video on my SUSE 9.2 box and I have never needed to disable it in the bios to get my agp nvidia card to work.

Last edited by pilotgi; 01-01-2005 at 09:06 PM.
 
Old 01-02-2005, 01:29 AM   #55
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
I have installed the entire dvd to my hard drive and and now getting an error that the precomplied or configured kernel is not found.

I must have messed this up royally.
I am going to again reinstall SUSE.

If someone - and I really appreciate your patience- can please just post or email me the steps without YAST (I tried doing the update via yast about 6 times in row since someone said that you may need to do that) along with with packages I need. I know I need the kernel source, gcc, make. Is there anything else?

Please right this as though I am a baby because I am about to through my computer out the window.

I am sorry I will not let this thread die. When I get this working I will go thru every post and person click that thanks button.

Once again I am really sorry, but I do not want to give up. I really don't.

Please help me.

Thank you all
 
Old 01-02-2005, 10:20 AM   #56
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
Do I need ti install all of KDE and KDE development
 
Old 01-02-2005, 03:14 PM   #57
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
bump
 
Old 01-02-2005, 03:54 PM   #58
pilotgi
Member
 
Registered: Apr 2002
Location: ks
Distribution: openSUSE 12.2 64 bit
Posts: 488

Rep: Reputation: 32
Quote:
Originally posted by JackieBrown
Do I need ti install all of KDE and KDE development
If you're asking if you need to install these programs to get 3d acceleration to work, the answer is no. Usually the default install of KDE packages in SUSE is plenty.

If everything goes well, running YOU after the install will give you the option to install the nvidai drivers that enable 3d. And everything is done for you by the scripts that SUSE provides. Also, don't do the kernel updates until your machine reboots like the warning message says.
 
Old 01-02-2005, 04:31 PM   #59
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Original Poster
Rep: Reputation: 31
"pilotgi"
When I get home I am going to reinstall my system again.
1) When I am done doing that there will be a kernal update in YOU

2) Should I wait to update that until after I have used YOU to install the nvidia driver?

3) Also, does the kernel source also update?

4) Also, am I suppose to be running YOU with the x-server stopped in order to do this update. If so how do I run YOU from the command line?
 
Old 01-02-2005, 05:51 PM   #60
pilotgi
Member
 
Registered: Apr 2002
Location: ks
Distribution: openSUSE 12.2 64 bit
Posts: 488

Rep: Reputation: 32
Quote:
2) Should I wait to update that until after I have used YOU to install the nvidia driver?
During the install, your machine will reboot after the first part and then install all the additional packages plus ask you to choose your user name, root password, etc. At the end it will ask you if you want to run YOU. If you say yes here, there will be a warning that says this is not a good time to update the kernel before rebooting.

You can skip this update entirely or just update the programs, including nvidia, without updating the kernel. Then after rebooting you can update the kernel and the kernel sources.
Quote:
4) Also, am I suppose to be running YOU with the x-server stopped in order to do this update. If so how do I run YOU from the command line?
No, you don't need to stop X.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cant enable 3d acceleration ghostlkp Linux - Newbie 6 09-03-2005 03:37 PM
Can't enable 3D hardware acceleration. daedalusonlinux Suse/Novell 20 03-20-2005 10:42 PM
How do I enable 3d Acceleration in SUSE 9.1? Ray Finkel Linux - Newbie 2 08-19-2004 08:02 PM
I want to Enable my 3D Acceleration... mir_sheely Linux - Hardware 1 06-07-2004 06:32 AM
How do you enable 3d acceleration ultravox Linux - Hardware 2 04-05-2003 07:17 PM


All times are GMT -5. The time now is 07:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration