LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Suse/Novell
User Name
Password
Suse/Novell This Forum is for the discussion of Suse Linux.

Notices



Reply
 
Search this Thread
Old 05-31-2006, 09:26 PM   #1
PerfectStranger
LQ Newbie
 
Registered: Dec 2005
Distribution: SuSE
Posts: 20

Rep: Reputation: 0
Question How can I permanently disable an individual Yast Online Update patch?


I am running SuSE 10.0 and I have a version of an rpm installed and I need that particular version to make a program function correctly, but now Yast Online Update is constantly telling me that a new security update is available for that package. When I open YOU it has the little green arrow/black arrow icon next to the package (which is for updating).

I can try clicking that icon to just get the checkmark (Keep) and I can right-click and select the lock icon (Protected -- do not modify) and accept that, but the status of YOU never changes and it keeps wanting me to update that package.

Anyway to tell it to tell it to forget about that package update permanently?
 
Old 05-31-2006, 10:11 PM   #2
nlinecomputers
Member
 
Registered: Aug 2005
Location: Midland, TX
Distribution: Ubuntu
Posts: 125

Rep: Reputation: 15
Can you not mark it taboo? You may have to do that in YaST and not YOU.
 
Old 06-01-2006, 01:22 AM   #3
shshjun
Member
 
Registered: Nov 2004
Location: del
Distribution: jds
Posts: 88

Rep: Reputation: 15
yes, you can select the patch and mark it as taboo. this is done in YOU. next update will list the marked patch but not install it by default.
there isn't way to not show the taboo-ed patch in the list yet. maybe someone here knows how to do that, if possible.
 
Old 06-03-2006, 03:10 PM   #4
PerfectStranger
LQ Newbie
 
Registered: Dec 2005
Distribution: SuSE
Posts: 20

Original Poster
Rep: Reputation: 0
I just tried marking it as taboo in both YOU and YaST and it didn't work. Apparently since the package is already installed (just a lower version) it won't let me taboo it because taboo is just to tell it to never install a package that hasn't been installed yet. When I go to the list of updates and right click and taboo all of them in the list it taboos every one besides the one that I don't want to update.

Frustrating...
 
Old 06-05-2006, 09:00 AM   #5
shshjun
Member
 
Registered: Nov 2004
Location: del
Distribution: jds
Posts: 88

Rep: Reputation: 15
i am not aware of any workaround to disable certain update only.
howevr when your package in not in the database, YOU will not try to update it. it's as simple as you do not run suse.config...
here are steps but on your own risk...

1. make sure you have the rpm somewhere (of your version) mypkg-lowerversion.rpm
2. rpm -e myppkg
3. download mypkg-lowerversion in tarball format and install it

in case it breaks something, you simply install it back via your mypkg-lowerversion.rpm

please share here when it works. above method is not tested.
 
Old 09-08-2006, 04:27 PM   #6
PerfectStranger
LQ Newbie
 
Registered: Dec 2005
Distribution: SuSE
Posts: 20

Original Poster
Rep: Reputation: 0
Shen,

Unfortunately, I don't have access to a tar or source version of the program. But it sounds like installing it this way so that it is not in the rpm database would solve the problem of YaST trying to update it each time.

Basically, what I have done is just ignore the one package and continue to update the necessary updates and leave that one as is (i.e. I'm just going to live with it for now). I'm planning on updating that machine to a newer version of SuSE anyways which, I think, would make the piece of software (at least this version) obsolete anyways.

If anyone tries Shen's solution or has any other solution, please post.

Thanks all!

PerfectStranger

Last edited by PerfectStranger; 09-08-2006 at 04:29 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with NVIDIA drivers after kernel update with yast online update Sheytan Linux - Software 4 05-06-2007 11:27 AM
Wine update with yast online update. Mojojo Linux - Software 2 02-05-2006 11:43 PM
YaST Online Update Fails with Patch error...... hollywoodb Linux - Distributions 7 02-23-2005 07:14 AM
Problems with NVIDIA drivers after kernel update with yast online update Sheytan Linux - Distributions 0 10-13-2004 12:01 PM
YaST Online Update + AMD kernel patch = kernel panic THX1138 Linux - General 3 10-26-2003 05:25 PM


All times are GMT -5. The time now is 08:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration